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Foreword 

This guide has been written for advanced users, as well as consultants and other 
professionals who are configuring and administrating the AMOS M&P program. The 
objective of this guide is to provide the technical information needed to perform these 
tasks. 

Since many of the configuration features described in this guide affect the way a system 
function or module operates, it assumed that the reader is familiar with the AMOS M&P 
program. A good knowledge of automatic data processing and general familiarity with 
the Windows® operating environment are also assumed. 

The aim of this manual is to cover all relevant technical issues of the program. However, 
it does not include topic oriented user instructions, which are to be found in the User 
Guide. The remaining documentation for AMOS M&P is to be found in the following 
manuals:  

AMOS M&P Installation Guide • 

• AMOS M&P User Guide 

Please note that this manual is not meant to be read from cover to cover, but rather to 
serve as a reference manual covering the topics listed. 
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1 Introduction 

1.1 The AMOS Maintenance & Purchase 
application 

AMOS M&P is a complex and powerful Windows program to handle maintenance, 
stock and purchasing functions in an organisation that may consist of multiple locations. 
It is a client/server application, where the client program is run on a Windows PC, and 
the server program may use one of several different database systems. 

Note that the appearance of the screenshots in this manual may differ somewhat 
from those you can see on your screen. This is due to the fact that there are some 
optional modules that can be used with AMOS M&P. In addition to the optional 
modules,  there are a significant number of 'user defined fields' that your 
organisation may have chosen to implement.  

1.2 How to use this manual 
This Reference Manual is written to contain all relevant technical information about 
AMOS M&P. 

Most of the material is organised according to the menu structure of the application. For 
example, the File menu is presented in Chapter 3 and all the commands and sub-
commands of this menu are presented in the same order they appear in the application 
itself. The subsequent chapters cover the other menus in AMOS M&P. 

In addition, some other topics are covered elsewhere in the manual. For example, section 
2.1 contains a description of the client/server set-up on which the AMOS M&P 
application is based. Other topics not related to one single menu command are covered 
elsewhere in Chapter 2, and in the appendices at the end of the reference manual. 

In order to make it easier to find the desired information in the reference manual, a 
number of cross-references are included. These will refer to the number of the section in 
which a topic is covered. 

The selected structure makes it easy to find out where in the manual a menu command is 
described. However, it may be more difficult to find information about a function for a 
user who does not know which command is used to activate the function. If this is the 
case, try to use the Index at the back of the manual in order to locate the function. Extra 
effort has been put into making the index as extensive as possible to facilitate finding the 
desired function in the reference manual. 
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1.3 Related documentation 
There are two other manuals written for AMOS M&P: 

AMOS M&P Installation Guide contains description of how the application is 
installed and upgraded. The installation guide covers the various database 
platforms for which AMOS M&P is available. 

• 

• AMOS M&P User Guide is written for end users, and is organised according to 
topics. It does not cover all the available functions and options in the program. In 
addition to the various AMOS M&P functions, the user guide also contains a 
chapter covering a general introduction to the Windows environment intended for 
users lacking such experience. 

1.4 Troubleshooting 
In the event that you are experiencing problems with AMOS M&P, and you wish to 
contact us either through GSS or by e-mail, it is important for us to know certain 
details of your system set-up. In the past it has occasionally taken several phone calls 
and some time to ascertain the exact installation details so we have made the process 
quicker and simpler. 

If you press the keys CTRL+SHIFT+F8 together you will see a window similar to the 
following: 

 
Click on the ClipBoard button to copy the contents of this window and then paste the 
contents into GSS or an e-mail. 

Explain the problem you are having with the application and we will attempt to solve 
the problem as quickly as possible. 
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2 Principles and Tasks 

2.1 The client / server model 
AMOS M&P is a client/server application, and the data is stored in a database. This 
section provides a brief description of the client/server model on which the AMOS M&P 
application is based. 

2.1.1 The hardware components 
The illustration below shows a typical hardware set-up for an AMOS M&P installation: 

 
Each AMOS M&P user runs the application on a client PC with Windows. The 
PCs are connected to and communicate with a database server through a network. 

• 

• 

• 

This is not the only possibility. AMOS M&P may also be set up in a stand-alone 
configuration, where the database is located on the same PC as the AMOS M&P 
application. 

AMOS M&P may be used in organisation with multiple locations. Typically, a 
Local Area Network (LAN) is used to set up for each location to facilitate the 
communication on that location. There are also functions in AMOS M&P that 
make it possible to exchange data stored in databases on the various locations. 
Such data exchange typically takes place on a Wide Area Network (WAN). For 
example, this makes it possible to exchange data between a main office and the 
various locations in the organisation
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2.1.2 The software components 
The next illustration shows some of the vital software components that are involved in 
an AMOS M&P installation: 

 
The client program AMOS M&P is installed on each PC where it is to be run. • 

• 

• 

• 

• 

The type of interface library depends on which database management system is 
used at the installation. For example, for the Adaptive Server Anywhere database 
system, an ODBC (Open Database Connectivity) interface may be used.  

The database engine typically resides on the database server machine (or an a PC 
in a stand-alone configuration). During installation, it is necessary to set certain 
parameters that allow AMOS M&P to communicate with the database engine 
through the interface library. 

The Amos.db database file is created when the application is installed. It is the 
selected database engine that actually creates the database file according to its 
internal structural rules. 

When AMOS M&P is upgraded to a new version, the installation program 
automatically handles the updating of the database. Please note that the AMOS 
M&P application can only communicate with the database file through the 
interface library and the database file. 
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2.2 Navigating within AMOS M&P 
AMOS M&P is designed to be as user friendly as possible. The user interface, in 
similarity to many commonly used applications, offers alternative navigation options to 
cater for most peoples preferences. The currently active window ‘Title Bar’ will contain 
information to keep you informed of where you are within the application. The display 
will normally look something like the following image: 
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2.2.2 The Menu Bar 
The main navigation area within AMOS M&P is the Menu Bar below. 

 
All of the commands and functions available within the application can be accessed 
through the Menu Bar. 

If you click on any of the items on the Menu Bar, a list of available sub-menu items 
appears beneath that menu item. If any of the available menu items have an arrow to the 
right hand side, it means that there is a further sub-menu available, which is accessed by 
moving the mouse pointer over the menu line containing the arrow. 

 

Arrows indicate that a 
sub-menu is available.

Most applications allow for the use of shortcut keys when selecting menu items, and 
AMOS M&P is no exception. 

Each menu item has a single underlined letter within its name. If you want to select a 
top-level menu item such as the ‘Stock’ menu, you should press the ‘Alt’ key at the 
same time as the ‘S’ key (usually indicated by ‘Alt+S’). 

Once a top-level menu has been opened, you only need to press the key corresponding 
to the underlined letter to move to the next menu item. 

The above menu selection can be achieved with the following keystrokes: 

Alt+F (followed by) O (followed by) G 

Then, if you want to open the Price Classes window, you should press the ‘E’ key. 

Note: Once you open a data window, the Menu Bar changes to include the Edit and Options 
menu items illustrated below. 

 
These menu options are explained further in section 2.4.
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2.2.3 The Standard Toolbar 
AMOS M&P, in similarity to many common applications, makes extensive use of 
‘Toolbars’ to make it easier for the user to navigate within the program. The toolbar 
shown below is the ‘Standard Toolbar’ and is usually placed directly beneath the ‘Menu 
Bar’ at the top of the application window. 

 
As you move the mouse pointer over a button, it will appear as if it is raised up slightly 
and, if you have Toolbar tips activated (menu item Tools/Options), a small description 
of the button’s function will appear. 

The following buttons are normally available on the Standard Toolbar: 

Button  Description  Menu Hierarchy 

  Components  File/Open Register/Components 

  Stock Items  File/Open Register/Stock Items 

  Job Descriptions  File/Open Register/Job Descriptions 

  Addresses  File/Open Register/Addresses 

  Functions  File/Open Register/Functions 

  Rounds   File/Open Register/Rounds 

  Component Hierarchy File/Open Hierarchy/Components 

  Function Hierarchy File/Open Hierarchy/Functions 

  Generate Work Orders Maintenance/Generate Work Orders… 

  Report Work  Maintenance/Report Work… 

  Work Orders  Maintenance/Work Orders 

  Work Planning  Maintenance/Work Planning 

  Requisition Work  Maintenance/Requisition Work… 

  Purchase Forms  Purchase/Forms 

  Reports   Tools/Reports 

  Switch Department File/Switch Department… 

  Help   Help/Contents (or F1 function key) 

Note: The number of visible buttons may vary depending on how the application has been set-
up and your access level within the system. 

Further navigation options are available through the new style interface described in 
section 7.10 Tools/Options. 
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2.2.4 The Window Toolbar 
When you open a window within AMOS M&P a second toolbar, called the ‘Window 
Toolbar’ usually becomes available. 

This toolbar, unlike the ‘Standard Toolbar’, can be different for each window that you 
open (the buttons available are dependant on the functions related to the open window). 

The Window Toolbar is normally found directly beneath the ‘Standard Toolbar’. 

The toolbar shown below is for the ‘Components’ window. 
(File/Open Register/Components) 

 
The functions represented on the Window Toolbar are a mixture of the more basic 
functions of the File and Edit menus combined with the most used functions within the 
Options menu. 

These buttons behave in the same way as the ones on the Standard Toolbar with regard 
to the toolbar tips description appearing when you point to a button with the mouse. 
Below is a list of each button from the Window Toolbar shown above. 

Button  Description  Menu Hierarchy 

   New   Edit/New Record 

   Save   Edit/Save Changes 

  Delete   Edit/Delete Record 

  Filter   File/Filter… 

  Print   File/Print… 

  Cut   Edit/Cut 

  Copy   Edit/Copy 

  Paste   Edit/Paste 

  Details   Options/Details 

  Requisition Work  Options/Requisition Work… 

  Report Work  Options/Report Work… 

  Close   File/Close 

If you are viewing a window toolbar that contains different buttons to the ones shown 
above you should point to the button you are interested in with the mouse pointer and 
wait for the toolbar tip description to become visible. 

Switching on toolbar tips and other navigation options are covered in section 7.10 
Tools/Options
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2.2.5 Shortcut Keys 
Many of the most commonly used commands within AMOS M&P can be accessed by 
pressing a single key on the keyboard or a combination of key presses. These key 
combinations are called ‘Shortcut Keys’. 

 
Wherever you see key combinations to th
you can use them as an alternative. If the
you should press the ‘Control’ or ‘Alt’ ke
same time. 

Shortcut Keys  Equiva
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2.3 Filtering information 
AMOS M&P makes extensive use of Filters throughout the application. Many of the 
menu commands open initially with a Filter window to enable you to restrict the amount 
of information you are presented with. These filter windows are recognisable because 
they all contain the following title in the top left hand side of the window. 

 
If you are already viewing information in an open window and you want to restrict the 
information further, or you want to use the same window function to view information 
for a different stock or component item, you can click on the icon that looks like a small 
funnel, which is located on the window toolbar. This will open the filter window for the 
current menu item and you can enter new filter information. 

  Note:   The filter function can also be accessed by pressing the shortcut keys Ctrl+F. 

2.3.1 What is a Filter? 
A Filter allows you to tailor the data screens so that you don’t have too much to scroll 
through when finding the entry you really need.  This isn’t too much of a problem in the 
beginning, when your database is relatively small, but as time goes on, and your 
database grows larger, it can be very time consuming to trawl through 500 records to get 
to the one you really want. 

A Filter modifies the SQL statement sent by AMOS M&P to the database running 
behind the application. 

Filters change their appearance according to the data you’re requesting.  Here’s an 
example of a filter for the Stock Items function: 

 

 
As you can see, there are many fields you can use to cut down the amount of 
information returned. 

The fields in a filter can also be used in different combinations to produce a search that 
restricts the data returned to an extremely exact specification – useful when your 
database entries number in the thousands! 
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2.3.2 Look-up Filters 
In addition to the filter windows mentioned in the previous section, you will often find 
small buttons that look like a magnifying glass at the right-hand side of certain fields. 
Clicking on one of these buttons will either take you to a second filter window and then 
to a ‘look-up’ filter or, occiasionally, directly to a ‘Look-up’ filter. If you know the 
starting letter or number of the information you are searching for, you can enter it into 
the standard filter window before clicking on ‘OK’ in order to restrict the look-up filter 
by displaying only records beginning with the letter/number you have entered. 

Look up filters enable you to quickly find the information you are searching for. The 
following window shows a typical example of a look-up window. It is possible to sort 
information and search using either the code or the name associated with the information 
you are viewing. You choose the type of information you want to select from by clicking 
in one of the two radio buttons and then type the first letters of the information you are 
searching for. As you type the letters, the highlight moves automatically to the first 
record starting with those letters. Once the highlight is on the record you want to use, 
click on OK.  

 
Certain of these filters may also have an additional ‘Details’ button which can be used to 
open a window containing read only information regarding the highlighted selection. 

2.3.3 Column Sorting 
Apart from using Filters, you can sort entries in data returned by a search by clicking on 
the column headers. 

The columns that you see sortable and their sort state is indicated by an arrow icon in the 
column header. If there is no arrow then the column is unsorted. 
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2.3.4 Column Ordering 
Many of the screen displays within AMOS M&P contain multiple columns. Sometimes 
these columns may not be visible at the same time and the information in the columns 
may be cropped, even when the window has been maximised (see below). 

 
To make it easier for you to see the information that you really want, you can change 
column widths and the order in which the columns appear using ‘drag and drop’ 
techniques. 

To alter the width of a column you should move the cursor to the vertical line at the side 
of the title of the column you wish to alter until the cursor changes to a bold vertical line 
with arrows on either side of it: 

 
Once the above symbol is visible, you can left-click and drag it sideways until you have 
the desired column width and then release the mouse button: 

 
To move a column to a different position, left-click and hold on the title of the column 
that you wish to move (the column will become black in colour). Drag the mouse cursor 
to the new column position and then release the mouse button to drop the column in 
place. 

 
The screen shots above and below show how the Number and Title columns have been 
switched. This facility allows you to re-organise the columns in any way you choose. 
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This technique does not permanently change the column order within AMOS M&P. If 
you close and then re-open the window, the column order will revert to the default 
setting. If you re-apply a filter without closing the window, the column order will remain 
as you altered it. 

If you want to have a more permanent re-ordering of the columns in a window you can 
save the window as a ‘View’ which you can select again and again through the ‘Select 
View’ function described in section 7.5. 

2.3.5 Calendar facility 
AMOS M&P contains a Calendar Facility that can be used to select dates within data 
entry windows and filter windows alike.  

Double-clicking or pressing F2 in any date field brings up a calendar, from which you 
can choose the date to be inserted in that field. 

 
In addition to the arrow buttons, the following commands are available: 

Ctrl-Left (Right) Arrow - Previous (Next) Year 

Shift-Left (Right) Arrow - Previous (Next) Month 

Up (Down) Arrow - Previous (Next) Week 

Left (Right) Arrow - Previous (Next) Day 

Enter   - Accept selected date 

Alt-F4   - Close calendar 

If you prefer to type the dates in manually, you can do so by typing two digits each for 
the day, month and year separated with a space (see below). 

 
When you enter the date information in this way, the date field will automatically adjust 
to the default view when you press enter or move to another field. 

Note: The format of the date within AMOS M&P is controlled by the default settings within 
your operating system. On a ‘Windows’ based machine, open the Regional Settings 
function within Control Panel.
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2.4 The Edit and Options menus 
When you have opened a data window within the AMOS M&P application the Menu 
Bar will extend to show the Edit and Options Menus. 

 

 
 

These menus change depending on the currently active window. 

Note: A combination of these two menus also appears if you right click the mouse whilst you 
are viewing an open window. 

2.4.1 The Edit menu 
The Edit Menu (shown below) contains the basic information manipulation tools for all 
AMOS M&P data windows, providing that there is editable information within the 
window. 

When there is a column at the left hand side of the data window that allows for tagging 
of one or more records, the Edit menu will be the same as below. 

 

These two menu items are only 
available if the data window 
contains selectable information. 

If there is no facility to tag records, the Select All and Deselect All menu options will 
not be visible. 

Cut   Removes the highlighted text and places it on the clipboard. 

Copy   Places a copy of the highlighted text on the clipboard. 

Paste   Places the contents of the clipboard at the cursor position. 

New Record  Creates a new, blank, record. 

Save Changes  Saves any changes made to information. 

Refresh  Updates the current window with recent information. 

Delete Record  Deletes the currently highlighted record. 

Select All  Tags all records in the current window. 

Deselect All  Un-tags all records in the current window. 

Change Template… Changes the template to be used for details screens. 

Note: Changing a template may make it impossible to read existing information that has 
already been entered using a different template or without a template altogether. 
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2.4.2 The Options menu 
The Options menu is specific to the currently active window within AMOS M&P. An 
example of a typical Options menu is shown below.  

 
This is the Options menu associated with the Components widow (File/Open 
Register/Components). Remember that the functions on this menu can also be accessed 
by right clicking the mouse. 

Because the Options menu is different for almost every active window, you will find 
detailed descriptions of each menu option explained thoroughly in the relative chapters. 

2.5 Using Component & Stock Types 
AMOS M&P version 3.0 introduced optional functionality in the form of the two 
registers Component Types and Stock Types. This section describes some of the general 
aspects of using these functions and the advantages they offer, particularly in larger 
organisations. The general principles behind component types and stock types are quite 
similar, and they are therefore described together in this section. You also find 
references to the specific sections in Chapter 3, which describe the relevant registers. 

This functionality is particularly useful in an organisation where the same 
component and/or stock types are used on multiple locations. For example, a 
specific type of pump may be in use at many locations. Traditionally, information 
about a new pump had to be entered in the Components register each time a new 
pump of this type was introduced. This meant more registration work, and 
increased the possibility of incorrect registration.  

• 

• 

• 

• 

If the Component Types register is used instead, the fixed information for the 
pump, such as the name of the Maker and the Type, is registered once only. When 
a new pump of this type is introduced at one of the installations, this information is 
inherited from the central Component Types register. A field such as Serial 
Number is unique for each individual pump, and is therefore registered at the given 
installation. 

The functionality described in this section is optional, controlled by the two 
parameters Use Component Types and Use Stock Types. If these parameters are set 
to the default FALSE value, AMOS M&P will behave as it did prior to version 3.0. 
This means that all component information must be entered in the Components 
register at the individual location, and similarly for the Stock Items register. The 
two parameters mentioned above are described in section 7.7.4. 

If the organisation elects to use the types functionality, the Component Types and 
Stock Types registers are typically updated at the main location only, and 
information is then exported to the various installations. Export and import 
functions are described in section 3.4 of this reference manual. 
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2.5.1 The Component Types register 
The Component Types register is described in section 3.1.9 of this reference manual. 
Below is a screen picture from the Components register when the Use Component Types 
parameter has been set to TRUE. Notice that the three fields Name, Maker and Type are 
grey and unavailable in this register, since the information is inherited from the central 
Component Types register. The picture below may be compared to the one in section 
3.1.1, which shows the same register when the Use Component Types parameter is set to 
FALSE. 

 
The field Type Number at the top of the window is used to select which type the 
component belongs to. Also note that the Serial number is unique for each 
component, and thus available for registration in the Components window. 

• 

• 

• 

• 

• 

• 

• 

When a new Component Type is registered, it may include a set of maintenance 
jobs. These jobs typically contain job descriptions and information about intervals 
that together make up a template for the suggested maintenance programme for the 
component type. 

You find the defined jobs connected to the selected component type on the Jobs tab 
card. As you see from the screen picture above, there are also tab cards for Parts, 
Counters and Images connected to the selected component. 

At an installation, it is possible to register a new component with or without the 
defined jobs. The next two bullet points describe how. 

To register a new component without inheriting any of the pre-defined jobs, enter 
the Components register and select New Record from the Edit menu. This 
approach may be used when the installation wants to have complete control over 
which jobs are to be defined for the new component. 

If the pre-defined jobs are to be added to the jobs at the location when a new 
component is introduced, enter the Component Types register and select Register 
as Component from the Options menu. Any defined jobs connected to the selected 
Component Types are then included in the maintenance programme for the 
location 

2.5.2 The Stock Types register 
As pointed out above, the Stock Types register works according to the same principles 
as the Component Types register. 

The Stock Types register is described in section 3.1.10 of this reference manual. 
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2.5.3 Advantages using Component and Stock Types 
There are several advantages in using the functionality described above: 

It is much easier to carry out analyses across all the installations in the 
organisation. For example, when the Component Types function is used, it is 
possible to select the Components for this Type command from the Options 
menu to get an overview of how many components of the selected type are in use 
in the entire organisation. This makes it much easier to ensure that the stock level 
is correct, and the information is useful in obtaining good quotation prices when re-
ordering stock. 

• 

• Another major advantage is the reduction in the need for registering the same 
information several times. This saves time, and makes it easier avoid 
misregistration of data. If an error has been made, it is sufficient to correct it once. 
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3 The File Menu 

This chapter covers the commands in the File menu: 

 

3.1 Open Register 
AMOS M&P stores entered information in a number of registers. The Open Register 
command in the File menu gives access to the registers: 

 
A filter window is presented once an Open Register sub-command is selected. In 
the following sections, a screen picture and a description of each filter window is 
included.  

• 

• 

• 

Once the Filter has been filled in, the window of the selected register appears on 
the screen. In addition, the Options menu appears in the main menu bar. The 
contents of this menu vary from register to register. In the following section, a 
screen picture and a description of the Options menu is included for each register. 

The Edit menu is also added to the main menu bar when a registered window has 
been opened. The menu normally contains the commands shown in the screen 
picture below. They are used to cut, paste and copy information, and to create, 
delete and save records in the selected register. 
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Access control is used to determine which user groups have access to each 
individual register. Access control is described in section 7.7.2 of this Reference 
Manual. 

• 

3.1.1 Components 
The maintenance information in AMOS M&P is organised according to the physical 
installation: the ship, assembly line or plant. The installation is described by its 
components. A component is any physical unit on which a maintenance task is 
performed.  

A component may be made up of other smaller components. At the lowest level 
components have parts. A part is the smallest physical unit that is normally replaced at 
one time. 

The Components command from the Open Register sub-menu opens the filter window 
for components. There is a corresponding toolbar button. 

The Components filter 

 
The filter dialog box contains the two tab cards, Basic and Advanced. On the 
Advanced tab card it is possible to filter components by Warranty Period, location 
and/or Component Type. 

• 

• The Only Component Classes area on the Advanced tab card contains a list of the 
classes of components that are defined. It is possible to select multiple classes by 
holding the shift button down while clicking the desired classes. Section 3.1.12.8 
describes the Component Classes register.

AMOS M&P Reference Manual 5.3.00 The File Menu  •  19 



 

The Components window 

 
The screen picture above shows the Components window with the Component 
Types function turned off. This function is described in section 2.5. By default, the 
General tab card is selected. 

• 

• 

• 

• 

There are two buttons next to the Location field. If the Search button is clicked, a 
selection list of the defined locations is presented, while a click on the Hierarchy 
button brings up the Locations window. This window is described in section 3.2.3. 

If the Component Types function is used, several fields in the window cannot be 
edited in the Components window, and they appear with a grey background. The 
Component Types register is described in section 3.1.9. 

The Purchased area on the right hand side of the General tab card contains controls 
that may be used to specify when the component was purchased, the price paid and 
the depreciation period. 

The Jobs tab card 

The Jobs tab card gives access to the window to connect maintenance jobs to the 
selected component. 

 
Chapter 3 of the AMOS M&P User Guide describes the most important aspects of 
how to define, plan, report on and follow up maintenance jobs with AMOS M&P. 

• 

• Click the View button to get the window which displays the information for each 
individual job or the Details button to view the job description details screen. 
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Once the Jobs window has been opened, the Options menu is updated to include 
the commands that may be used while defining a job: 

• 

 
The first three commands in the Options menu for the Jobs window are used to 
specify parts and disciplines required for the job, and to set any relevant counters. 
There are corresponding toolbar buttons that may be used to enter the respective 
windows. 

• 

• Several related jobs can be included in the same Round. The Rounds register is 
covered in section 3.1.8. A job also has a Job Description, and this register is 
described in section 3.1.3. 

The Parts tab card 

The Parts tab card gives access to the window used to specify parts connected to the 
selected component. 

 
Click the View button to get the window that displays the stock item window for 
the selected part. The Stock Items register is described in section 3.1.2. 

• 

AMOS M&P Reference Manual 5.3.00 The File Menu  •  21 



 

 
The Counters tab card 

The Counters tab card shows the counters that have been defined for the selected 
component. 

 
The Counter drop-down list to the left on the tab card displays the values that have 
been defined in the Counter Types register. This register is described in section 
3.1.12.3. 

• 

• 

• 

In order to have AMOS M&P calculate average values for a counter, the Calculate 
Average field must be checked. 

The value of a counter may be inherited from a specified component. To select the 
component on which the counter is dependent, click the Search button next to the 
rightmost field on the tab card. This gives access to the window where the 
component may be selected: 

The Images tab card 

AMOS M&P makes it possible to connect images to a component. For example, these 
may be scanned images from the component documentation or video films explaining 
maintenance details. The Images tab card shows the images connected to the component. 
There is a corresponding toolbar button. 
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Section 3.1.11 contains a description of the image functionality available in AMOS 
M&P. 

• 

• The image may be previewed by selecting the image and clicking the View button. 

The Options menu for Components 

 
Details 

The command Details from the Options menu gives access to the window called Full 
Description. The Details toolbar button may also be used to access the window. 

 
The Full Description window may be used for a textual description of the 
component. If a Template is used, the user may be presented for a tailored layout 
containing fields and formatting.  

• 

• If the Change Template command is selected from the Edit menu, AMOS M&P 
presents a warning message to alert the user that a change of template may cause 
problems for data stored with the help of the existing template: 
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Maker 

The Maker command from the Options menu in the Components window gives access 
to the Maker Address window. This window is used to specify address and other 
relevant information of the maker of the component. 

 
If the Search button next to the Maker field is clicked, a filter is presented for the 
Select list of addresses from the Address register.  

• 

Vendor 

The Vendor command from the Options menu in the Components window gives access 
to the Vendor Address window. The General tab window is used to specify address and 
other relevant information about the vendor of the component. The Products tab window 
is used to display the various products that can be supplied by the vendor. 

 

AMOS M&P Reference Manual 5.3.00 The File Menu  •  24 



 

Transaction Codes 

The Transaction Codes parameters may be used to connect expenses to a specific budget 
dimension, like Responsible or Project. The Transaction Codes command from the 
Options menu of the Component window gives access to this window: 

 
Section 7.7.7 describes the screen to define transaction codes. • 

History 

When work is reported in AMOS M&P, the window used for this purpose contains a 
History tab card. The History command from the Options menu in the Components 
window gives access to the History window. 

 
The window may also be used to add history information for the selected 
component. The Date Written field will show the current date, and the Written By 
list will show the name of the user currently logged on. To add a description, select 
the correct Job and click the Save toolbar button. Then select Details from the 
Options menu of the History window to enter the Full Description window. 

• 

Stock Transactions 

AMOS M&P contains functions that allow the organisation to keep track of the items in 
stock, and purchasing functions. These are described in Chapters 4 and 5 of the AMOS 
M&P User Guide. The command Stock Transactions from the Options menu of the 
Component window gives access to the stock transactions connected to the selected 
component. 
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Maintenance Log 

When work is reported, AMOS M&P stores the information in the maintenance log. The 
Maintenance Log command from the Options menu for the Components window gives 
access to the Maintenance Log window. 

 
When one of the records in the Maintenance Log is selected, the Options menu 
contains the following commands that may be used to access the various windows 
of the selected record: 

• 

 
Archive 

The Archive command from the Options menu leads to a sub-menu containing the three 
different kinds of archive information that may be available if you have a component 
that has been transferred in from another department. Note that the parameter ‘Create 
Component Archive On Transfer In’ must be set to true. 
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The three ‘Archive’ windows are similar to the corresponding windows in the main 
section of the Options menu but contain historical data from departments who have 
previously ‘owned’ the particular component. Because of this, the windows are ‘Read 
Only’ and also show which department created each record. 

Report Work 

Work may be reported on a work order defined for the selected component. The Report 
Work command from the Options menu gives access to the following window. There is 
a corresponding toolbar button. 

 
Section 3.3 in the AMOS M&P User Guide explains the Report Work window. • 

• If there are no defined work orders listed in the Report Work window, AMOS 
M&P assumes that the work to be reported is Unplanned. 

Requisition Work 

When work needs to be carried out on a specific component unexpectedly, the 
Requisition Work is used to record the work. The Requisition Work command from the 
Options menu of the Components window gives access to the window to be used. 
There is a corresponding toolbar button. 

 
Section 3.2.4 in the AMOS M&P User Guide explains the use of the Requisition 
Work window. 

• 
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Copy 

It is possible to copy information connected to a component when a new component is 
created. The command Copy from the Options menu for the Components window gives 
access to the Copy Component window. 

 
The field New Component No. is used to specify the number of the new 
component. The checked boxes in the window determine which types of 
information are copied to the new component. When the OK button is clicked, the 
new component is inserted in the list of the Components window. The information 
may be edited with the various commands described previously in this section. 

• 

Change Status 

The parameter Default Status of New Components is used to determine the status of new 
components introduced in the system. It is possible to change the status of a selected 
component with the command Change Status from the Options menu for the 
Components window. 

 
It is possible to check the box ‘Change status of sub-components also’ to have this 
done automatically when the status of the 'parent' component is changed. 

• 

• If you have a component that you want to transfer out to another department, you 
simply select transferred from the New Status drop down window. The ‘Office’ 
installation can then transfer the component to its destination department. 

Note: Changing the component status to Transferred or Scrapped will cause AMOS M&P to 
cancel all outstanding work orders, including round work orders, unless reported as 
started.  

The parameter Default Status of New Components is described in section 7.7.4.1. of this 
reference manual. 

Transfer In 

Once a donating department has set a components status to transferred, the component 
(and sub-components if originally selected for inclusion) will become available for 
transfer in the Office. Select the component to transfer and choose ‘Transfer In’ from the 
Options menu. This will open a dialogue box where you can select the receiving 
department from a drop-down window. 
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3.1.2 Stock Items 
AMOS M&P contains functionality to keep track of stock items in the organisation. The 
Stock menu is covered in Chapter 5 of this reference manual, and in Chapter 4 of the 
AMOS M&P User Guide. The Stock Items command from the Open Register sub-
menu opens the filter window for stock items. There is a corresponding toolbar button. 

The Stock Items filter 

 
The Number field is used to specify the number of the component to which the 
stock item is connected. The Search in Vendors’ Ref. also makes it possible to use 
the criterion entered in the Maker’s Ref. field to search the Vendors’ Ref. register 
also. You can use the Stock Status drop down window to select between All, 
Stocked or Non-stocked items. Finally, it is possible to use the filter to search for 
Perishable Items Only by checking the corresponding field. 

• 

The Stock Items window 

 
The screen picture above shows the Stock Items window with the Stock Types 
function turned off. This function is described in section 2.5. If the Stock Types 
function is used, several fields in the window cannot be edited in the Stock Item 
window, and they appear with a grey background. The Stock Types register is 
described in section 3.1.10. 

• 
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• There are two Add buttons and one Remove button in the middle right part of the 
Stock Items window. These buttons are used to specify which physical locations 
actually contain the selected stock item. The Locations window may be used to 
define a new location, and is described in section 3.2.3. 

The two drop-down lists in the Prices frame of the Stock Items window display the 
defined Currency Codes. This register is described in section 3.1.12.5. 

• 

• 

• 

The Stock Units drop-down list in the Stock Items window displays the defined 
stock units. The Units register is described in section 3.1.12.7. 

The Stock Class drop-down list in the Stock Items window displays the defined 
stock classes. For example, classes like Spare Part and Consumable may be 
defined. The Stock Class register is described in section 3.1.12.9. 

The Options menu for Stock Items 

 
Details 

The command Details from the Options menu for the Stock Items window gives access 
to the window called Full Description. There is a corresponding toolbar button. 

 
The Full Description window may be used for a textual description of the stock 
item. If a Template is used, the user may be presented for a tailored layout 
containing fields and formatting. 

• 
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Maker 

The command Maker from the Options menu for the Stock Items window gives access 
to the Maker Address window. This window is used to specify address and other 
relevant information of the maker of the stock item. The Products tab can be used to list 
the different types of equipment available from a particular Maker. 

 
Preferred Vendor 

The command Vendor from the Options menu for the Stock Items window gives access 
to the Preferred Vendor window. This window is used to specify address and other 
relevant information of the preferred vendor of the stock item. The Products tab can be 
used to list the different types of equipment available from a particular Vendor. 

 
In/Out of Stock 

When stock arrives at or is removed from a stock location, the movement is registered in 
AMOS M&P. The command In/Out of Stock from the Options menu of the Stock 
Transaction window opens the window to register such movements. 
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• The Trans. Date field contains the current date but can be modified for more 
accurate reporting. 

The following transaction types may be used: • 

• 

• 

Purchased (the quantity is increased) 
Used (the quantity is decreased) 
Returned Unused(the quantity is increased) 
Lost (the quantity is decreased) 
Found (the quantity is increased) 
Sold (the quantity is decreased) 
Transferred in (the quantity is increased) 
Transferred out (the quantity is decreased) 
Delivered back (the quantity is increased) 
Lent out (the quantity is decreased) 
Trashed (the quantity is decreased) 

The Transaction Type will determine which other information is required, such as 
Work Order number, Component number etc. 

The Current Stock field shows the total available in the default location. The Total 
Stock field shows the total number of parts available in all locations. The On Order 
field shows how many parts are currently on order.  

Print labels 

The Print Labels command from the Options menu for the Stock Items window prints 
labels for the selected stock items on the default Windows printer. The Labels dialog 
box is used to specify the number of labels to be printed. The parameter Printer Task to 
Use When Printing Labels (see section 7.7.4) may be used to define a Printer Task that 
defines a different printer to be used for printing the labels. 

 
Link to Component 

Stock items may be connected to components from the Components register. The 
command Link to Component from the Options menu gives access to the window to 
establish a connection between the selected stock item and a component. 

 
Set Expiry Date on Transactions 

This option is used to set a dummy expiry date on existing stock items that have been 
redefined as perishable. 
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3.1.3 Job Descriptions 
The Job Descriptions register is used to store descriptions of the maintenance jobs 
defined in AMOS M&P.  

The Job Descriptions command from the Open Register sub-menu opens the filter 
window. There is a corresponding toolbar button. 

The Job Descriptions filter 

 
The Job Descriptions window 

The following screen picture shows a list of job descriptions with codes starting with the 
letter C. 

 
The Class drop-down list displays the contents of the Job Classes register, which 

is described in section 3.1.12.10. 
• 

The Options menu for Job Descriptions 

 
This Options menu contains the following commands: 
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Details 

The Details command from the Options for the Job Descriptions window gives access 
to a window with a Full Description. There is a corresponding toolbar button. 

 
The Full Description window may be used for a textual description of the job. If a 
Template is used, the user may be presented for a tailored layout containing fields 
and formatting. 

• 

Images 

AMOS M&P makes it possible to connect images to a component. For example, these 
may be scanned images from the component documentation or video films explaining 
maintenance details. The Images command from the Options menu of the Job 
Descriptions window gives access to the window to connect images to the component. 
There is a corresponding toolbar button. 

 
The image may be previewed with the View Image command from the Options 
menu for the Images window. 

• 

Components 

A job description may be connected to one or more defined components. The 
Components command from the Options menu of the Job Descriptions window gives 
access to the window where the selected job description may be connected to a 
component. A single job description may be connected to multiple components. 
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Maintenance Log 

When work is reported, AMOS M&P stores the information in the maintenance log. The 
Maintenance Log command from the Options menu for the Job Description window 
gives access to the Maintenance Log window. 

 
When a line is selected in the Maintenance Log window, the Options menu 
contains for commands to view or register History, Stock Used, Resources Used 
and Counter Settings respectively. There are corresponding toolbar buttons for 
these commands. 

• 

Move Job References … 

AMOS M&P allows you to replace all occurrences of a Job Description with another 
one.  The Move Job References … command from the Options menu of the Job 
Descriptions window gives access to the window where all occurrences of the selected 
job description in the database are replaced by the job description you select from the 
menu below: 

 
This function can be protected by Group, at Tools / Configuration / Groups, then 
selecting Access Control from the Options menu and selecting the Functions tab. 
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3.1.4 Addresses 
The Addresses register is used to store information about all companies and persons 
with whom the organisation deals. 

The Addresses command from the Open Register sub-menu opens the filter window 
for addresses. There is a corresponding toolbar button. 

The Addresses filter 

 
The QA Grading drop-down list displays the values entered in the QA Grades 
register, which is described in section 3.1.12.13. 

• 

• The Product Type drop-down list displays the values entered in the register of the 
same name, described in section 3.1.12.4. 

The Addresses window 

 
• The Addresses window is used to enter information about companies and persons. 

The various address information fields are located on the first tab card, called 
General. 

• Each address in the list at the bottom of the window contains a check box all the way 
to the left. This box makes it possible to tag multiple addresses. The tagged 
addresses may then be processed together. For example, it is possible to convert 
multiple addresses (see the next page) at the same time. 
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The Products tab card 

On the Products tab card, it is possible to select one or more product types that are to be 
connected to the selected address. When the New button is clicked, a field with a drop-
down list opens. The list contains the Product types defined (see section 3.1.12.4). 

 
The Options menu for Addresses 

 
The Details command brings up a Full Description window that may be used to 
enter additional textual information about the addressee. There is a corresponding 
toolbar button. 

• 

• 

• 

The Additional Info. command brings up a window that displays any additional 
information that may have been registered for the addressee. 

The Move Address References command may be used to “clean up” a database if 
the same addressee has been entered several times. For example, this   may occur if 
an address is registered at an individual location and then exported to the main 
office. When the command is selected, all database references to the selected 
address are located. You are presented with the list of all the addresses except the 
one from which the references are to be moved. Select the address to which the 
references are to be moved. 
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The command Convert Address Status is used to toggle the status of selected 
addresses. The possible values are Locked and Unlocked. Only authorised users are 
allowed to edit an address with the Locked status. 

 

3.1.5 Employees 
The Employees register is used to store information about the employees in the 
organisation. 

The Employees filter 

 
The Employees window 

 
Each registered employee is assigned a Code, which typically consists of the 
initials of the employee. 

• 

• 

• 

• 

The Search button next to the Address field may be used to select information from 
the Address register. 

The contents of the Discipline drop-down list consist of the register with the same 
name, described in section 3.1.12.2. 

The fields starting with E-Uxx are user-defined fields. See section 7.7.4.8 for more 
information on these fields. 
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The Options menu for Employees 

 
The Details command brings up a Full Description window that may be used to 
enter additional textual information about the addressee. There is a corresponding 
toolbar button. 

• 

• The Additional Info. command brings up a window that displays any additional 
information that may have been registered for the selected employee. 

 
The Address command from the Options menu for the Employees window gives 
access to the Address register to select an address or register a new one. 

• 

3.1.6 Currency Rates 
AMOS M&P can handle amounts in several currencies simultaneously, and one 
currency is defined as the Base Currency. The parameter Base Currency Code 
determines this, and is described in section 7.7.4. 

 
The Currency Rate window is used to set and update the rate of each currency rate 
used in the organisation compared to the Base Currency Rate. When the rate is 
updated, the field Entered By displays the initials or name of the user who has 
performed the update. 

• 

• 

• 

• 

The currency rate should be entered as the comparative value of one unit of 
currency against one unit of the base currency. The illustration above shows that 
one unit of GBP (British Pounds) is worth 1.3765 units of the base currency (USD) 
whilst one unit of YEN (Japanese Yen) is worth 0.0079 units of the base currency 
(USD). 

When a new currency rate is registered, the Currency drop-down list displays the 
values of the Currency Codes register, which is described in section 3.1.12.5. 

The Show All command from the Options menu for the Currency Rates window 
makes it possible to toggle the Show All option. There is a corresponding toolbar 
button. 
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3.1.7 Functions 
Components move around, but functions stay put. For example, in a 6-cylinder internal 
combustion engine, Piston 3 is a function. There can also be a component that is called 
piston 3 - today. However, that physical component may be taken out, cleaned and put 
back into the piston 4 position, and the component name then becomes piston 4. 

The Functions register is described below. The defined functions may also be displayed 
and manipulated in the Functions hierarchy, which is described in section 3.2.2. 

The Functions filter  

 
The Functions window 

 
The Component Performing the Function field displays the component that is 
connected to the selected function. The Functions hierarchy is used to install and 
remove components in defined functions. The Functions hierarchy is described in 
section 3.2.2. 

• 

The Options menu for Functions 

 
The Details command from the Options menu in the Functions window gives 
access to a window with a Full Description. There is a corresponding toolbar 
button. 

• 
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• The Rotation Log command from the Options menu brings up a window which 
shows which components have been installed in and removed from a selected 
function. The rotation log is automatically updated when the Functions hierarchy is 
used to update this information. 

• To see the comments registered while installing or removing a component in a 
function, select the required line and give the menu command Options/Details. 

• The Remove Component command from the Options menu brings up a window 
that allows you to remove the selected component. 

 
• You are given the choice of several reasons for the removal, which translate 

effectively into states of the removed component, and the option to ‘remove sub-
components also.’ 

• If component Status ‘Scrapped’ or ‘Transferred’ is chosen, all outstanding work 
orders will be cancelled unless already reported as started. Work can still be 
reported against already started work orders until they are reported as completed. 

• For a more detailed description of this functionality, go to section 3.2.2. 

3.1.8 Rounds 
It is possible to define Rounds of related jobs that are placed on a single work order. 
Typically, jobs in a round are handled by a single discipline, but this depends on how the 
rounds are defined. 

The functions for planning and reporting on maintenance jobs are described in Chapter 4 
of this reference manual, and in Chapter 3 of AMOS M&P User Guide. 

The Rounds filter 

 
The Discipline drop-down list displays the values from the register with the same 

name, described in section 3.1.12.2. 
• 
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The Rounds window 

 
The History Template drop-down list displays values from the register described in 
section 7.7.4. 

• 

• 

• 

• 

There are three available output formats for a round: A List containing a single line 
for each job, a Compact List containing only the most important information, and a 
Work Order format which also includes the textual description of each job. 

The Reporting method drop-down list contains the two values Simple and Full. 
When work is reported against a round work order, the interface is somewhat 
different for the two options. This is described in section 4.4.3. 

The Include All Jobs when Generating Work Orders check box should be checked 
in order to generate a work order which covers all the maintenance jobs included in 
the round when the Create Work Order command is selected from the Options 
menu. 

The Options menu for Rounds 

 
The Details command from the Options menu for the Rounds window opens a 
window for a Full Description for the selected round. 

• 

• The Jobs command from the Options menu for the Rounds window opens a 
window which lists the jobs included in the round. In this window, it is possible to 
change the sequence in which the jobs appear. To move a job, make sure it is 
selected. The yellow arrow in the left part of the screen indicates which job is 
currently selected. Use the green arrows in the right part of the window to move a 
job up or down in the sequence. 
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The Create Work Order command in the Options menu for the Rounds window 
generates a new work order for the selected round. The work order that is created is 
given the status Issued. Work may be reported on a work order that has been 
issued. 

• 

3.1.9 Component Types 
If the Use Component Types parameter is set to TRUE, the Component Types register is 
used to define the types of components that are used at multiple locations. When this is 
used, information from the Component Types register is automatically inherited from 
the register, making it easier to ensure data consistency. Section 2.5 in this reference 
manual explains how to use the Component Type function. 

The Component Types filter 

 
The Only Component Classes area contains a list of the classes of components 

that are defined. It is possible to select multiple classes by holding the SHIFT button 
down while clicking the desired classes. Section 3.1.12.8 describes the Component 
Classes register. 

• 
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The Component Types window 

 
By default, the General tab card is selected. • 

• 

• 

The information in the three fields Name, Maker and Type is entered in the 
Component Types register only. When a new component is registered at a location, 
the information for these three fields is automatically inherited from the central 
register when a type number is selected for the component. 

Several of the tab cards in this window are quite similar to ones found in the 
Components window, described in section 3.1.1. 

The Jobs tab card 

The Jobs tab card shows the jobs connected to the selected component: 

 
It is possible to click the View button to enter the window used to connect maintenance 
jobs to the selected component type. 
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• When a new Component Type job is saved, the following dialog box appears: 

 
Click Yes in order to have the defined job connected to all components of the 
selected type. 

• 

• Once the Jobs window has been opened, the Options menu is updated to include 
the commands that may be used while defining a job: 

 
The first three commands in the Options menu for the Jobs window are used to 

specify parts and disciplines required for the job, and to set any relevant counters. 
There are corresponding toolbar buttons that may be used to enter the respective 
windows. 

• 

• A job has a Job Description, and this register is described in section 3.1.3. 

Parts 

The Parts tab card gives access to the window used to specify parts connected to the 
selected component. This tab corresponds to the one found in the Components window, 
which is described in section 3.1.1. 

Counters 

The Counters tab card shows the counters that have been defined for the component 
type. There is a corresponding toolbar button. 

Images 

The Images tab card makes it possible to connect images to the component. 

Components 

The Components tab card lists which components of the selected type are available. 

 
The Components tab card shows which component is in use at which installation 

for which function, and the status of each registered component of the type. 
• 

The Options menu for Component Types 
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Several of the commands are quite similar to the Options menu in the Components 
window, described in section 3.1.1. 

Details 

The command Details from the Options menu for the Component Types window gives 
access to the window called Full Description. The Details toolbar button may also be 
used to access the window. 

Maker 

The Maker command from the Options menu in the Component Types window gives 
access to the Maker Address window. This window is used to specify address and other 
relevant information of the maker of the component. 

Preferred Vendor 

The command Preferred from the Options menu for the Component Types window 
gives access to the Preferred Vendor window. This window is used to specify address 
and other relevant information of the preferred vendor of the stock item. 

Register as Component 

The Register as Component command from the Options menu of the Component 
Types window gives access to the window that may be used to register a component of 
the selected type at an installation. 

 
The Register as Component window presents a list of the defined installations 

and departments Select one from the list and click OK to register a new component 
of the selected type at the selected installation. 

• 

• If any jobs are connected to a component type in the central Component Types, 
these jobs are automatically inherited along with the type information when a new 
component is registered this way. 

Copy 

It is possible to copy information connected to a component type when a new 
component type is created. The command Copy from the Options menu for the 
Component Types window gives access to the Copy Component window.
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3.1.10 Stock Types 
If the Use Component Stock parameter is set to TRUE, the Stock Types register is used 
to define the types of components that are used at multiple locations. When this is used, 
information from the Stock Types register is automatically inherited from the register, 
making it easier to ensure data consistency. Section 2.5 in this reference manual explains 
how to use the Stock Type function. 

The Stock Types filter 

 
The Stock Types window 

 
The information in the three fields Name, Maker and Maker’s Ref. is entered in 

the Stock Types register only. When a new stock item is registered at a location the 
information for these three fields is automatically inherited from the central register 
when a type number is selected for the stock item. 

• 

The Options menu for Stock Types 

 
Several of the commands are quite similar to the Options menu in the Stock Items 
window, described in section 3.1.2. 
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Details 

The command Details gives access to the window called Full Description. There is a 
corresponding toolbar button. 

Maker 

The command Maker gives access to the Maker Address window. This window is used 
to specify address and other relevant information of the maker of the stock item. 

Preferred Vendor 

The command Preferred Vendor gives access to the Preferred Vendor window. This 
window is used to specify address and other relevant information of the preferred vendor 
of the stock item. 

Stock Grades 

The command Stock Grades gives access to the following window: 

 
You can use this window to add stock grade information to the stock type. The 
information entered here will be copied to order line items on purchase forms and is 
used to add supplementary information related to the stock item to the purchase form. 
The categories for stock grades are defined in the Tools/Configuration/Stock Grade 
Categories menu selection and the stock grades available in each category are defined in 
the menu selection File/Open Register/General/Stock Grades. 

Register as Stock Item 

The Register as Stock Item command gives access to the window that may be used to 
register stock items of the selected type at an installation. The window presents a list of 
the defined installations and departments Select one from the list and click OK to 
register new stock items of the selected type at the selected installation. 

Link to Component Type 

Stock items may be connected to components from the Components register. The 
command Link to Component gives access to the window to establish a connection 
between the selected stock item and a component. 

 
Once stock items have been connected to components, the toolbar button Used in 
Components gives access to the window that lists connections of this type.
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3.1.11 Image 
AMOS M&P makes it possible to connect images to a component. For example, these 
may be scanned images from the component documentation or video films explaining 
maintenance details. The Open Register command of the File menu contains the Image 
command for working with images. The Sources sub-menu is used to set up internal or 
external tools for displaying images; see section 3.1.11.1. The References sub-command 
is used build a library of images for use in AMOS M&P; see section 3.1.11.2. 

 
Looking at an image 

To view an image on the screen, select one from the library of image references and 
click on the View Image button. The image is then displayed in a new window. 

AMOS M&P contains an internal viewer that may be used to work with images. In order 
to zoom in on a detail of the image in the window, use the cursor to mark the part of the 
image you want to examine. Then click on the button Zoom Area, the one with the 
magnifying glass. After having zoomed in, the vertical and horizontal scroll bars may be 
used to move around in the image. 

To zoom back out, click on the button Fit to Window next to the Zoom Area button. The 
Options menu contains Zoom commands. It is also possible to right-click in the image 
to get a pop-up menu that contains the most relevant options: 

 
Select a specific zoom value from the Zoom sub-menu, or use the commands Zoom 
Area or Fit to Window, which correspond to the toolbar buttons described above. 

The illustration below shows the image window. 
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The image contains a button; read out this below. 

There is a system parameter called Open Image In New Window that controls what 
happens when a hotspot is clicked to open a new image. If the default parameter value 
FALSE is set, the new image replaces the image currently in the window. If the value is 
set to TRUE, the new image will be displayed in a new window. 

Hotspots on an image 

Once an image reference has been defined, its usability may be enhanced further by 
adding hotspots on the image. This means that the user may click a hotspot to enter a 
new window providing more information about relevant parts of the image. 

There are different types of hotspots: 

A hotspot may open the Component or Component type window in order to find 
relevant information about the entry to which the image is connected. 

• 

• 

• 

A hotspot may open the Stock Items or Stock Type window to find relevant 
information about the entry to which the image is connected. 

A hotspot may open the Stock Items or Stock Type window to find out about the 
current stock situation of the item. 

The toolbar contains two buttons that can be used when defining hotspots. They are 
called Show Hotspots and Show Workspace respectively. 

To add a new hotspot, click the New button on the toolbar. AMOS M&P automatically 
changes to the Show Hotspots mode, and the corresponding button is automatically 
pressed by the program. If any hotspots have been defined already, they are displayed as 
shaded areas on the image. 

The new hotspot appears as a shaded area in the top left corner of the image window. 
The mouse may be used to drag it to the part of the main image that you want to become 
the hotspot. Once it is in the desired location use the mouse to re-size it by dragging one 
of the eight little marking squares that indicate the size and location of the hotspot. 
Continue until the hotspot has the desired size and location. 

Right-click the hotspot and select Properties from the pop-up menu to determine which 
type of hotspot to use. This dialog box is presented: 

 
Open the Hotspot Type drop-down list and select the desired type. Next, place the cursor 
in the empty Reference text field and click the Browse button. Depending on the type 
selected, a dialog box is used to select the component, the image or the stock item to be 
opened when the hotspot is clicked. Click OK to complete the definition. The illustration 
below shows an image with two defined hotspots. 
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When hotspots have been defined on an image, click the Show Hotspots toolbar buttons 
in order to display the hotspots as shaded areas, where they may be moved or re-sized.  

If the Show Hotspots buttons has not been pressed, it is still possible to locate the 
hotspots in an image. The cursor turns into a hand with a pointing finger when placed on 
a hotspot. 

Button hotspots 

Hotspot buttons may be placed on the image. To do so, define a new hotspot and check 
the option Show as Button in the Properties dialog box. The field Button text becomes 
available, and is used to define the text to appear on the button. 

To change the font to be used for the button text, click Font and select font, style and 
size from the dialog box you enter. A button hotspot may be re-sized the same way as 
other hotspots. However, there is one difference: When the Show Hotspots button is not 
pressed, the hotspot on the image always has the form of a button. 

Browsing between image windows 

If a hotspot of the type Image Link is clicked, the image to which the hotspot is linked 
opens up in the image window, replacing the original image. However, AMOS M&P 
keeps track of which images you have looked at, and allows you to browse between 
them. The two buttons Go Back and Go Forward becomes available in the toolbar. 
These two buttons may be used to browse efficiently through the images that you have 
previously looked at in the session. 

The Workspace of an image 

A number of hotspots may be defined on an image. In order to keep track of the hotspots 
and their links, click the Show Workspace button in the toolbar. The left side of the 
window opens to show the defined hotspots: 
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When the cursor is placed on one of the hotspots in the image, the corresponding hotspot 
is highlighted in the list of hotspots at the left of the window. This makes it easy to see 
the name of the link for each hotspot.  

Connecting an image to a stock item, component or job description 

A defined image may be connected to a stock item, a component, and/or a job 
description. When such connections have been made, it is possible to view the relevant 
images directly from these registers. For example, if an image has been connected to a 
job description, it is possible to view or print out the image as a part of the 
documentation of the job to be carried out. 

This is how you connect an image to one of the three registers. 

Give the menu command File/Open Register and select Components, Stock Items 
or Job Descriptions 

• 

• 

• 

• 

• 

Use the Filter dialog box to locate the element in question. 

Select the element that is to be connected to the image in the next dialog box, and 
give the menu command Options/Images 

Click the Browse button to access the list of available images, select the one you 
want to use, and click OK. 

Click OK to establish the connection. 

Once the connection has been made, the Images toolbar button may be clicked to view 
the image from the relevant register
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3.1.11.1 Sources 
Before images can be viewed, an image source tool must be defined for the tool that is 
going to be used for viewing. AMOS M&P offers an internal viewer that can display 
bitmaps like BMP and PCX, in addition to a number of other formats. Other viewers and 
Windows programs on your PC may be defined as external viewers. 

Give the command File/Open Registers/Image/Sources to enter this window: 

 
From the Service Type drop-down list select Internal if you wish to define the internal 
viewer as an image source, and select External to define a different program. If the latter 
is selected, fill in the name of the tool in the Start Command field including the full path. 

The start command should end with the characters %IMAGE REFERENCE% which 
tells the tool that it should display the image supplied by AMOS M&P. The field 
Display Command may be used to specify a DDE command. It is necessary to know the 
names and syntax of DDE commands supported by the tool in order to use this function. 

3.1.11.2 References 
Once the image sources have been defined, a library of images in AMOS M&P may be 
built up. When the library has been established, an image reference may be connected to 
one or more relevant components, stock items, and job descriptions. 

The images that are going to be used should be stored in a specific folder. Normally, this 
should be the Graphics sub-folder in the folder where AMOS M&P has been installed. 
Make sure that the field Graphics Directory contains the name and path of the folder you 
are going to use for this purpose. This is described in section 7.7.4.4. of this reference 
manual. 
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The command File/Open Register/Image/References is used to enter the window to 
define image references. 

 
For each image a Source, a Code, a Name and a Reference are specified. The Reference 
is the full path name of the image that is going to be used later. The Browse button may 
be clicked to select the reference. 

3.1.12 General 
AMOS M&P contains a number of smaller registers that are used to store values that are 
tailored to the organisation. Typically, drop-down lists in other windows display and let 
the user select from a list of the registered values. For example, the Components window 
described in section 3.1.1 contains the Component Class drop-down list, which displays 
the classes defined in the Component Classes register. 

To open a general register, select File/Open Register and then General: 

 
Most general register windows are fairly simple, and do not contain any Options menu. 
The Edit menus contain similar commands to what is found on the second toolbar: It is 
possible to create a new record or delete an existing one, to save changes, and to use the 
cut, copy and paste functions.
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3.1.12.1 Templates 
Various documents handled by AMOS M&P require different layouts. The Templates 
general register is used to register a Code and a Description for each layout template 

 
A form definition created in PowerBuilder may be connected to a template code. When 
this is done, the user will be presented with a form that may contain drop-down list 
boxes, selection boxes, input fields and other controls on entering the Full Description 
window for an item in a register. 

Note: Data registered with a form in AMOS M&P is stored on a comma-separated format in 
so-called BLOBs (Binary Large OBjects) in the database. This means that the data from 
the form is transferred to the database in the defined field sequence. If the field sequence 
is changed, data will be displayed incorrectly to the user. Once a form has been used to 
input data, it should not be changed. 

To connect a template to a form definition, select the template in the Templates window 
and select Import Definition from the Options menu 

 
The following warning is presented: 

 
Next, a Select PBL dialog box is presented, allowing the user to select the .PBL file 
which contains the desired form definition. 
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Select the correct .PBL file and click OK to get a list of the form definitions contained in 
the selected file: 

 
Once the connection between the template and the form definition has been made, the 
user will be presented with the defined input form when entering the Full Details 
window.  The creation of layout templates is described in Appendix A of this reference 
manual. 

3.1.12.2 Disciplines 
The Disciplines register is used to define various labour functions. Once this has been 
done, costs may be tracked by disciplines, for example. It is possible to check a 
discipline as External  

 
External disciplines are indicated with the character *. For example, the filter for work 
orders contains an Only Disciplines list that will differentiate between internal and 
external disciplines: 

 
External disciplines must be used in conjunction with work orders if you wish to be able 
to purchase those services externally. 
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3.1.12.3 Counter Types 
The Counter Types register is used to define the different types of counters that typically 
are used in order to handle Condition Based Maintenance, which is described in 
Appendix B of this reference manual. You can set a daily limit for counters in order to 
try and minimise incorrect reading/inputting. 

 

3.1.12.4 Product Types 
The Product Types register is used to define different categories or types of products. 
This information may be used in searching in the Addresses register. This register 
contains the tab Products for linking the addressee to specific Product Types. This is 
described in section 3.1.4. 

 

3.1.12.5 Currency Codes 
The Currency Codes register is used to store information about which currencies are 
used in the organisation. The Currency Rates register, described in section 3.1.6, is used 
to enter and update the exchange rates between the currencies as changes occur. 

 

3.1.12.6 Quality Codes 
The Quality Codes register is used to create and store the available options for use in the 
Quality Check function during the receipt of line items. 
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3.1.12.7 Units 
The Units register is used to define the various units that are typically used for stock 
items. If the Use Stock Types parameter is set to FALSE, the values from the Units 
register are available in the Stock Units drop-down list in the Stock Items window. If the 
Use Stock Types parameter is set to TRUE, the values from the Units register are 
available in the Stock Units drop-down list in the Stock Types window. 

 

3.1.12.8 Component Classes 
The Component Classes register is used to define classes for components. Once 
component classes have been defined, the Components filter may be used to select 
components of the desired class. 

 

3.1.12.9 Stock Classes 
The Stock Classes register is used to define Class Codes and Descriptions for stock 
items. Once stock classes have been defined, the Stock Items filter may be used to select 
stock items of the desired class. The Receipt Tolerance column allows you to set a 
maximum percentage of difference between stock quantities on goods received. If the 
goods received quantity falls outside of the permitted tolerance range compared to the 
order quantity, the items cannot be entered into stock. 
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3.1.12.10 Job Classes 
The Job Classes register is used to create and store the available classes that are attached 
to Job Descriptions. When a Job Description is created, it must be given a class that 
reflects the type of work being carried out. Various maintenance window filters can use 
the available Job Classes to restrict the information presented on screen. Further 
information on Job Descriptions can be found in section 3.1.3. 

 

3.1.12.11 Price Classes 
The Price Classes register is used to store the various formulae that may be applied to 
stock item values. Price classes may be used to add varying levels of administration or 
transport costs to an item or to reflect differing international tax rates. 

 

3.1.12.12 Function Criticality 
The Function Criticality register may be used to designate a degree of criticality for 
functions. The Functions window (see section 3.1.7) contains the Criticality drop-down 
list that displays the values entered in the Function Criticality register. 

 

3.1.12.13 Q A Grades 
The QA Grades register is used to define various quality assurance grades that may be 
assigned to suppliers. The Addresses window (see section 3.1.4) contains the QA 
Grading drop-down list from which a QA grade may be selected for a supplier. 
Similarly, when an option is selected in the Stock Items window (see section 3.1.2), the 
Options menu gives access to the commands Vendors and Preferred Vendor and these 
windows also contain fields that display the quality grading. 
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3.1.12.14 Stock Grades 
The Stock Grades register is used to add supplementary information to stock items. The 
information will be copied to purchase form line items to assist with delivery of the 
stock item. 

 
The categories available in the drop down window are defined in the menu option 
Tools/Configuration/Stock Grade Categories. 

3.1.12.15 Transfer Reasons 
The Transfer Reasons register is used to define the list of reasons that might be applied 
to a transfer document at Stock / Transfer Documents.  This setting has no effect on 
any other entries in the database. 

 

3.1.12.16 Project Categories 
The Project Categories register is used to define the project categories available for use 
in connection with projects. The correct category can be selected when creating a new 
project or added to an existing project by using the Project Properties option. For further 
information on projects see section 4.3. 
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3.1.13 Maintenance 
AMOS M&P contains registers to differentiate between various aspects of maintenance 
tasks to be carried out. The relevant commands in the Maintenance menu are described 
in Chapter 4 of this reference manual and in Chapter 3 of AMOS M&P User Guide 

To open a maintenance register, select File/Open Register and then Maintenance: 

 

3.1.13.1 Criteria 
Below is an example of maintenance criteria that may be used. The Advanced tab card 
of the Work Orders filter may be used to select work orders that belong to a selected 
maintenance criterion. 

 

3.1.13.2 Types 
Below is an example of maintenance types that may be defined. The Advanced tab card 
of the Work Orders filter may be used to select work orders that belong to a selected 
maintenance type. 
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3.1.13.3 Classes 
Below is an example of maintenance classes that may be defined. The Advanced tab 
card of the Work Orders filter may be used to select work orders that belong to a 
selected maintenance class. 

 

3.1.13.4 Causes 
This register resembles the other Maintenance registers described in the previous 
sections. The Advanced tab card of the Work Orders filter may be used to filter 
according to a selected maintenance cause. 
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3.1.14 Purchase 
AMOS M&P contains registers to allow the user to define certain aspects of purchase 
forms according to their own requirements. The information entered in these registers 
will then be available in various purchase windows in the form of drop-down lists 
enabling the user to select the required item. When setting up these tables it is important 
to bear in mind that they may be used for future e-Business functions. Whilst the 
information entered is generally up to the individual organisation, it is probably 
advisable to adopt an international standard for these tables such as the International 
Marine Purchasing Association (IMPA) codes where possible. Chapter 5 of the AMOS 
M&P User Guide and chapter 6 of this reference manual contain further information on 
the purchasing functions. 

To open a purchase register, select File/Open Register and then Purchase: 

 

3.1.14.1 Order Priority 
This register is used to store the Order Priority options available within purchase forms. 
The field can be used according to individual company purchasing strategies whether a 
descriptive term is used or a numbering system. 

 

3.1.14.2 Account Code 
This register is used to store the Account Code options available within purchase forms. 
The fields can be used according to individual company purchasing and accounting 
strategies. The Account Code facility can be used to give an alternate method of expense 
reporting than the budget system. To create the account code categories available in the 
drop-down list see section 7.7.8. 

 
If you are using the Accounting module, this register will be linked to Cost Centres  and 
recorded in the Account Transactions window (described in chapter 7). 
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3.1.14.3 Delivery Terms 
This register is used to store the Delivery Terms options available within purchase 
forms. The field can be used according to individual company purchasing strategies 
whether a descriptive term is used or a numbering system. We would recommend that 
you use internationally recognised codes with a view towards future e-business usage. 

 

3.1.14.4 Payment Terms 
This register is used to store the Payment Terms options available within purchase 
forms. The field can be used according to individual company purchasing strategies 
whether a descriptive term is used or a numbering system. We would recommend that 
you use internationally recognised codes with a view towards future e-business usage. 

 

3.1.14.5 Delivery Locations 
This register is used to store the possible Delivery Locations to be used within the 
organisation. The field can be used according to individual company purchasing 
strategies whether a descriptive term is used or a numbering system. We would 
recommend that you use international port codes with a view towards future e-business 
usage. 

 

3.1.14.6 Receipt Status 
This register contains the available options for receipt status available in purchase form 
line items. 
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3.2 Open Hierarchy 
AMOS M&P can display the information stored in several of the registers in the format 
of hierarchical tree structures. The Open Hierarchy command in the File menu gives 
access to the hierarchy commands: 

 
The Hierarchy windows function in a way which is similar to Windows Explorer: 

Each window contains a tree hierarchy list on the left, where it is possible to click a 
+ icon to expand a branch and a – icon to collapse it. The area in the right part of 
the window displays details about the element that is selected in the list on the left. 
A folder icon represents each hierarchy element. The selected element icon is 
displayed in the form of an opened folder. 

• 

• 

• 

The standard Windows drag and drop functionality may be used to move an 
element in a hierarchy. Drag the folder to be moved and drop it on the folder to 
which it should be moved. The hierarchy will automatically be updated to reflect 
the move. 

At present, only the Functions hierarchy described in section 3.2.2 may be used to 
create, delete and otherwise manipulate the elements contained in the hierarchy. 
The other hierarchies may only be used to display and rearrange pre-defined 
elements. 

3.2.1 Components 
The Components command from the Open Hierarchy sub-menu of the File menu 
opens the Component Hierarchy window. There is a corresponding toolbar button. 
Section 3.2 contains general information about working with hierarchy windows in 
AMOS M&P. 

The Component hierarchy window 

 
 In the illustration above, the component called Main engine is selected in the 

hierarchy. The right hand side of the window contains information from the 
Components register about the installed component. The tabs at the top of the 
Component hierarchy window give access to all relevant component information. 

• 
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• To create a new folder in the Component hierarchy, select the folder in which the 
new folder is to be placed and click the New toolbar button. If a folder on the top 
level is selected when the button is clicked, the following message is presented: 

 
Click Yes to create the new folder on the top level, or click No to have the new 

folder created as a sub-folder in the currently selected folder. 
• 

The Options menu for the Component hierarchy 

 
 The commands available in the menu correspond to the ones found in the Options menu 
of the Component register window. They are described in section 3.1.1. 

3.2.2 Functions 
The Functions command from the Open Hierarchy sub-menu menu of the File menu 
opens the Function Hierarchy window. There is a corresponding toolbar button. Section 
3.1.7 describes the Function register, while section 3.2 contains general information 
about working with hierarchy windows in AMOS M&P. 

The Function hierarchy window 

 
In the illustration above, the function called Main engine is selected in the 

hierarchy. A component is installed in this function, and the right hand side of the 
window contains information from the Components register about the installed 
component. The tabs at the top of the Function hierarchy window give access to all 
relevant information about the installed component. 

• 

• To create a new folder in the Function hierarchy, select the folder in which the 
new folder is to be placed and click the New toolbar button. If a folder on the top 
level is selected when the button is clicked, the following message is presented: 
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Click Yes to create the new folder on the top level, or click No to have the new 

folder created as a sub-folder in the currently selected folder. 
• 

The Options menu for the Function hierarchy 

 
The Component sub-menu from the Options menu 

When the selected function in the Function Hierarchy window contains an installed 
component, the Components sub-menu in Options menu is available. The commands 
available in the sub-menu correspond to the ones found in the Options menu of the 
Components register window. They are described in section 3.1.1. 

History 

The command History in the Options menu displays history information that has been 
registered for any component while installed in the selected function. As the screen 
picture below shows, the History window will show the component number for each 
history line. 

 
Stock Transactions 

The command Stock Transactions in the Options menu displays stock transaction 
information that has been registered for any component while installed in the selected 
function. 
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Maintenance Log 

The command Maintenance Log in the Options menu displays information about 
logged maintenance that has been performed on any component while installed in the 
selected function. 

 
When a line in the maintenance log is selected, the Options menu contains 

commands that provide access to the logged information such as any registered 
History, Stock Used, Resources Used and Counter Readings 

• 

 
Archive 

The commands available in the Archive sub-menu correspond to the ones found in the 
Options/Archive sub-menu of the Components register window. They are described in 
section 3.1.1. 

Report Work 

In AMOS M&P performed maintenance work is reported by registered component. 
However, it is also possible to use the Functions hierarchy as the starting point for 
reporting work, provided a component has been installed in the selected function. When 
the Report Work command is selected from the Options menu, AMOS M&P knows 
Function and Component numbers based on which function is selected. Chapter 3 in 
AMOS M&P User Guide describes how work is reported. 
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Requisition Work 

Similarly, it is possible to select the Requisition Work command from the Options 
menu to requisition work on the component that is currently installed in the selected 
component. 

Installing and removing components in functions 

The Functions hierarchy window may be used to install and remove a component 
from a function. There are two toolbar buttons for this purpose. One of them is 
available, the other is unavailable when a function is selected. It a component is 
installed already, the Remove component button is available. Opposite, when no 
component has been installed, the Install component button is available. There are 
corresponding commands in the Options menu, called Install Component and 
Remove Component. 

• 

• The following dialog box is displayed when installing and removing a component 
in a function. The Details field at the bottom of the box may be used to enter 
relevant comments or similar notes about the component.  These Details are 
viewable at Options / Rotation Log Details. 

 
When ‘Remove sub-components also’ box is checked, removing this component 

also removes all components in sub-functions of the currently selected function and 
Rotation Log entries are made for these components, containing Status, Removed, 
Removed By and Details. 

• 

3.2.3 Locations 
The Location hierarchy may be used to define various physical locations at an 
installation where components are located. The Components window, described in 
section 3.1.1, contains a Location field and buttons with access to the list to select a 
location and hierarchy button that takes the user into the Locations hierarchy. Section 
3.2 contains general information about working with hierarchy windows in AMOS 
M&P. 
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• To define a new location, enter the Locations hierarchy and click the New toolbar 
button. In the Locations Details dialog box, enter a Code and a Name for the 
location. If the location is to become a location at the highest hierarchy level, check 
the Root Location box. 

 

3.2.4 Component Types 
The Component Types command from the Open Hierarchy sub-menu menu of the 
File menu opens the Component Type Hierarchy window. Section 3.2 contains general 
information about working with hierarchy windows in AMOS M&P. 

 
The lower right part of the window displays a list that shows in which 

installations/departments components of the selected type are presently installed. 
• 

3.2.5 Stock Types 
The Stock Types command from the Open Hierarchy sub-menu menu of the File 
menu opens the Stock Type Hierarchy window. Section 3.2 contains general information 
about working with hierarchy windows in AMOS M&P. 

 
The lower right part of the window displays a list that shows in which 

installations/departments stock of the selected type is currently available. 
• 
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3.3 Switch Department 

 
The Switch Department command from the File menu gives access to the list of the 
defined installations and departments of the organisation. Note that Switch Department 
window will only present the departments that the logged in user has access to. 

The window to define new installations and departments is described in section 
7.7.12. in this reference manual. 

• 

3.4 Export / Import 
The Export/Import command from the File menu gives access to a sub-menu 
containing the commands used for exporting data from and importing data into AMOS 
M&P databases. 

 
Chapter 8 of the AMOS M&P User Guide describes the process of exchanging data 
between a main office and installations in an organisation. Section 7.7.4.5. of this 
reference manual describes the parameters that determine file extensions for export and 
import files, and section 7.7.4.4. shows how a transfer directory is defined. 

3.4.1 Export 
The Export sub-command gives access to a drop-down menu containing choices for the 
format of the export file and a dialog box to choose a selection file for the export 
process. 
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• When the Search button next to the Selection File field is clicked, AMOS M&P 
starts looking for a selection file in the defined Transfer directory. 

Export files are given numbers, and the number is automatically incremented by 
one compared to the last export when the Export command is selected. For 
example, if the export process failed, it is possible to click the Search button and 
select an existing file name. AMOS M&P presents a reminder; click OK to precede 
and overwrite the previous file. 

• 

 
Selection file commands for import and export 

During data import or export, command files with the file extension .SEL are used to 
specify how the import or export is to be handled. The following commands may be 
used in selection files: 

InsertData <On/Off> 
This command controls whether new table entries may be added during an Import 
operation. 

StampDate <On/Off> 
If this is set to On, the new or updated table will have the field LastUpdated set to 
today's date during import. 

StampMark <On/Off> 
This command controls whether the new or updated table entries will have their 
ExportMarker field set during import. 

OverwriteOldData <On/Off> 
This command controls whether updates to already existing table entries is allowed 
during export. 

MarkedRecordsOnly <On/Off> 
This command controls whether only marked records are included during export. 

UnmarkExportedRecords <On/Off> 
This command controls whether exported records are to be unmarked on export. 

IgnoreDeleted <On/Off> 
This command controls whether deletion messages are included in the export or import. 
The default value is Off, which means that such messages are included. This command 
should be used for backwards compatibility, when exporting to AMOS M&P versions 
lower than 2.2.00. Such versions are incapable of processing deletion messages. When 
this switch is set to On, deletion messages are not exported. 

Department <Installation number/Department number> 
Controls which department is to be exported or imported. 

Examples: 
DEPARTMENT 002/01 
DEPARTMENT 003/02 
DEPARTMENT ALL (use carefully at an office site during export) 

If no DEPARTMENT command is included in the selection file, only the current 
department is processed. If you have an export file containing information from several 
departments, it is often wise to use the command DEPARTMENT ALL to allow 
everything to be imported. 
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Register <Table name> 
This command is used to specify which register (table) to export or import. The 
command may be combined with the commands listed below. 

If <SQL Select Statement> 
This command allows you to specify the criteria that the table entries must satisfy in 
order to be exported or imported. 

Note: When using ‘If’ statements, you should add the text ‘amos.’ when specifying additional 
tables within the search criteria, as below: 

Register ComponentType 
If ( ( ComponentType.LastUpdated > LASTEXPORTEDDATE ) AND 
( ComponentType.CompTypeID IN ( SELECT CompTypeID FROM 
amos.ComponentUnit WHERE ( DeptID = 235000003 ) ) ) ) OR 
( ComponentType.CompTypeID IN ( SELECT CompTypeID FROM 
amos.ComponentUnit WHERE ( DeptID = 235000003 ) AND ( ExportMarker = 1 ) ) )  

ExcludeFields <Table Field List> 
This command allows you to specify which table fields are not to be updated during 
import; all other fields are automatically included. This command cannot be used in 
combination with the command IncludeFields. 

IncludeFields <Table Field List> 
This command allows you to specify which table fields are to be updated during import. 
All other fields are automatically excluded. This command cannot be used in 
combination with the command ExcludeFields. 

Selection file examples 

Example 1: 
MarkedRecordsOnly ON 
UnmarkExportedRecords ON 
Register Component 
Register JobDescription 

Example 2: 
MarkedRecordsOnly ON 
UnmarkExportedRecords ON 
Register OrderForm 
If ( FormType In (1,3) ) And ( FormStatus In (2,3) ) 

What follows the IF command is actually an SQL statement defining the criteria that 
must be satisfied before a form can be exported. 

The FormType field may have one of three values: 

1 indicating a Purchase Order 
2 indicating a Requisition Form 
3 indicating a Query 

The FormStatus field may have one of five values: 

1 indicating Active 
2 indicating Parked 
3 indicating Filed 
4 indicating Split 
5 indicating Cancelled 

The above Register command would therefore only export order forms if they were of 
the type Purchase Order or Query with the status of either Parked or Filed. 

Example 3: 
MarkedRecordsOnly ON 
UnmarkExportedRecords ON 
Register OrderLine 
If OrderID In (Select OrderID From OrderForm Where ( FormType In (1,3) ) And 
(FormStatus In 2,3) ) 

AMOS M&P Reference Manual 5.3.00 The File Menu  •  73 



 

The above Register command would only export order lines if they are attached to order 
forms which are of the type Purchase Order or Query with a status of Parked or Filed. 

You can read the above IF statement as follows: 

Export the order line if its OrderID (that is the ID of the order to which it is attached) is 
in the set of OrderIDs in the OrderForm table satisfying the condition that the order form 
type is PurcahseOrder or Query with the status Parked or Filed. 

Example 4: 
MarkedRecordsOnly Off 
Register ComponentType 
If ( CompName Like '%pump' ) And ( VendorID In ( Select AddressID From Address 
Where Code Like '%SPEC')) 

The above Register command would only export components types where the name 
contains the text 'pump' and are delivered by a vendor who's name contains the text 
'SPEC'. 

Example 5: 
InsertData On 
OverwriteOldData On 
Register ComponentType 
ExcludeFields Misc1 
If ( CompName Like '%PUMP') 

The above Register command would only import component types where the name 
contains the text 'pump', but the field Misc1 would not be updated during the import. 

Selection file keywords 

Three selection file keywords have been implemented in AMOS M&P. These are called 
Today, LastExportedDate and LastImportedDate, and they make it possible to create 
very flexible selection files. Examples are shown below. 

Note: When using keywords enclosed within parentheses (brackets) it is necessary for there to 
be a single space between a parenthesis and the keyword. 
For example: If (  LastExportedDate  ………………….…….) 
 or If (…….………………….  LastImportedDate  ) 

Today 
If this keyword is found in the selection file, it is replaced by the current date. As all 
dates in AMOS M&P also contain a time component, the value that is substituted for the 
Today keyword depends on how it is used. For example, in '>=Today' may be replaced 
by 1998-05-14 00:00:00.00000 if the date is 14 May. If the expression '<=Today' is used 
for the same date, the replacement value is 23:59:59.99999. 

LastExportedDate 
If this keyword is found in the selection file, it is replaced with the date/time of the last 
export performed for the installation and department in question. 

LastImportedDate 
If this keyword is found in the selection file, it is replaced with the date/time of the last 
import performed for the installation and department in question. 

Here are some examples of how these keywords can be used: 

Register WorkOrder If DueDate <= Today 

Register WorkOrder If LastUpdated Between LastExportedDate and Today 

Register WorkOrder If LastUpdated >= LastImportedDate and LastUpdated <= Today 

Avoiding problems with import and hierarchies 

In order to avoid problems with hierarchies during import and export operations, you 
may use the command InitDBCmd in the [Import] section of the AMOSW.INI file. 
Below, you see examples of how you use it for the SQL Anywhere and Oracle databases 
respectively. 
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SQL Anywhere: 

[Import] 
DBMS=ODBC 
. 
. 
InitDBCmd01=SET OPTION WAIT_FOR_COMMIT = ON 

Oracle: 

[Import] 
DBMS=OR8 
. 
. 
InitDBCmd01=SET CONSTRAINTS ALL DEFERRED 

Other ways to access database commands 

You can also access database commands by pressing CTRL+SHIFT+F9. When you do, 
you enter a dialog box where you can select a command file you may select to execute 
commands. 

You can also add import and export commands in the [Import] and [Database] sections 
of the AMOSW.INI file. If you do, you number them from 01 to 99. Here is an example: 

[Database] 
DBMS=OR8 
. 
. 
InitDBCmd01=Alter Session Set Optimizer_Mode= First_Rows 

3.4.2 Import 
The Import command is parallel to the Export command described in the previous 
section, and is used to import data into an AMOS M&P database. 

3.4.3 Tasks 
The Tasks command gives access to the Export/Import Tasks window, which is used to 
define tasks to handle import and export of data. 
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• The drop-down list called ‘Type’ below the Description file is used to select the 
task type. The three available types are Import, Export and Generic. Generic tasks 
may handle various system maintenance tasks. For example, after files have been 
successfully imported, there may be a defined task to compress the imported files, 
archive them and delete the files on the directory, clearing it for the next batch of 
files to be handled. 

The format drop-down called ‘Format’ to the right of the ‘Type’ drop-down is 
used to select the format of the file:  Native, Generic or Portal. 

• 

• 

• 

• 

The two fields Pre-process and Post-process may be used to name batch files to be 
carried out before and after the selection file. The file extensions .Bat, .Com and 
.Cmd may be used. For example, a Pre-process batch file may be defined to get e-
mail files containing data to be imported by a task, and a Post-process batch file 
may contain commands to delete imported files. Such files should be located on the 
same directory as the Selection File for the task. If not, the full path of such files 
should be provided. 

The task contains information about when and how often it is to be performed. If 
the task is only to be performed on certain days of the week, make sure that the 
correct weekdays are checked. 

A defined task may be temporarily de-activated: Remove the check mark from the 
Task Active box of the desired task. The task may be re-activated again later by 
checking the box. 

3.4.4 Task Server 
The Task Server command is used to execute defined tasks. When this command is 
given, a filter dialog box is presented. The box makes it possible to select which types of 
tasks and formats that are to be processed: 

 
When the selection has been made, the tasks of the selected types are processed. Then 
the Task Server window is displayed. In this window, it is possible to delete defined 
tasks. 

 

3.4.5 Export Log 
The Export Log command opens a window with a list of the log files from export 
operations. Each log file contains log number information about when the export took 
place and who started it, the format of the export, and which selection file was used. The 
Post Process Status field contains the number 1 for successful transactions and 0 for 
unsuccessful ones. If you find unsuccessful transactions then you should investigate the 
possible causes. 
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3.4.6 Import Log 
The Import Log command is parallel to the Export Log command described in the 
previous section, and is used to show the log of import operations. 

3.4.7 Portal Log 
The Portal Log command is used to record and display error messages and related 
information concerning portal importing. 

 
Clicking on the look-up button alongside a Form No. will open the original form. In 
some cases the message can be much longer than the field can accommodate. If you 
would like to see the whole message you should move the cursor so that it is on the 
message and a balloon containing the full error message will appear as shown below: 
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There are two parameters associated with the portal log entitled Show ‘Error Messages 
During Portal Import’ and ‘Store Imported XML Document In Portal Log’. These 
parameters are described in section 7.7.4.5. 

The Options menu for the portal log contains the menu entry ‘Show XML’. Clicking this 
will display the stored XML document, for the selected portal log record, in your default 
web browser. 

3.5 Printer Set-up 

 
The Printer Set-up command from the File menu presents a list of the defined printers. 
The default Windows printer is used for printouts unless a different printer is selected 
from the Printer Set-up window. 

Click the Set-up button in order to enter the Properties dialog box for the selected 
printer. The options available in this box depend on the printer and printer driver 
selected.  

3.6 Print 
The Print command from the File menu prints out the contents of the currently active 
window on the default Windows printer. To print on a different printer, select the 
Printer Set-up command before starting the printout. There is a corresponding toolbar 
button. 

3.7 Exit 
Select the Exit command from the File menu in order to shut down the database and 
close AMOS M&P If there are open windows containing unsaved data, the user is 
prompted about this and given the opportunity to save the data.
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4 The Maintenance Menu 

This chapter covers the commands in the Maintenance menu. 

 

4.1 Work Orders 
AMOS M&P uses work orders to describe which jobs and other tasks need to be carried 
out. The system is set up to handle a work order flow, which typically consists of five 
steps: 

A new work order is generated when the previous work order for the defined job 
has been completed The default status of a new work order is set to Requested 

• 

• 

• 

• 

• 

The Planning window is used to schedule when the jobs are to be carried out, 
which resources are to be used, etc. Once this is done, the status changes to 
Planned. This is described in section 4.2.1.2. 

The status of work orders have been changed to Planned, the actual work orders are 
issued and a maintenance plan may be printed. 

As the maintenance work is performed, it is reported on the various work orders. 
Work is reported until the status can be changed to Completed. 

The final step is to control the work reports and file them for the records. 

There are several system parameters that may be set to automate and modify this typical 
work order flow. The three types are: 

• Periodic work orders, which are generated for jobs with a defined periodic 
frequency, for Condition Based Maintenance (CBM) or for counters 

• Round work orders. 

• Work orders generated when work is requisitioned when the need arises. 

For example, there are system parameters for indicating default priority and status of 
each type of work order, as well as the default output format and if Controlled and 
Completed work orders of the various types are to be Auto-filed. The parameters are 
described in section 7.7.4.  
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4.1.1 The Work Orders Filter 
The Filter dialog box for Work Orders contains the two tab cards, Basic and Advanced: 

 
The Basic tab card contains the parameters normally used to filter out the work orders to 
work with. For example, it is possible specify CBM Criteria to be Acknowledged and/or 
Unacknowledged, to filter Only Job Classes or Only Disciplines and select from the 
Planning area to pick out work orders according to when they are due. Work orders 
assigned to projects will only be included if you check the ‘Show Project Jobs’ box. 

 
The Advanced tab card contains more filter options Note that AMOS M&P will use all 
the selections on the two-tab card when filtering work orders. 

4.1.2 The Work Orders window 
The Work Orders window provides a list of all the work orders in the system. From this 
window, a work order may be selected and work may be reported on it. The window is 
also used to change the current status of the work order. 

In the Work Orders window, at the bottom of the screen there is a list of work orders 
matching the filter criteria specified. If one of these is selected, the details of that work 
order are displayed in the various other fields in the window.  
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• To tag work orders, check the box all the way to the left of the work order. If a 

group of work orders is tagged, it is possible to use a menu command to handle all 
the tagged work orders. The Edit menu also contains the options Select All and 
Deselect All. 

• The status of a selected work order may be changed by opening the Status drop-
down list and selecting the proper status from it. 

• If the work order belongs to a project, the project number will be displayed 

• The Report Work button in the secondary toolbar is used to enter the window to 
report work performed on a work order that has been issued; see section 4.4. 

• The icons in the secondary toolbar may be used to enter Details about the work 
order or enter windows to specify Requested Parts and Requested Disciplines. The 
Details button gives access to a window for a description of the work order. 

• The information for a work order also contains a check box Locked. For new work 
orders generated automatically by AMOS M&P, this box will always be 
unchecked. This means that the system may adjust the estimated due date based on 
counters for example. Work orders you generate manually are locked when 
defined, but you may uncheck the box if the due date needs to be moved for some 
reason. 
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The pop-up menu 

 
To access the pop-up menu in the Work Orders window, select the work order in the list 
and click on the right mouse button. The pop-up menu contains the commands from the 
Edit and Options menus: 

Click on a command to give it. 

4.1.3 Printing Work Orders 
To see what jobs to perform, use AMOS M&P to print jobs that are due. It is possible to 
print lists of jobs from the Work Orders window. Tag the work orders that are to be 
printed. When the Print button is clicked, the following dialog box is used to select how 
the work plan should look: 

 
If no work order has been tagged before the Print button is clicked, an extended Filter 
dialog box is presented. It contains the same options as the regular Work Orders filter, 
plus the Output options from the dialog box displayed above.
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4.1.4 The Work Orders Options menu 
The Options menu is added to the main menu bar once the Work Orders window has 
been opened. It contains the following commands: 

 
Details 

The Details command from the Options for the Work Orders window gives access to a 
window with a Full Description of the selected work order. There is a corresponding 
toolbar button. 

 
The screen picture above shows a description that has been based on a template The 
History Template drop-down list in the Work Orders window is used to specify the 
template. A description of the location of templates is found in section 7.7.4.3., while 
Appendix A describes the creation of new templates. 
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Additional info 

The Additional info command from the Options menu gives access to this window: 

 
The Additional Info window contains three text fields that are used to provide additional 
textual information about the Effect and Cause of the selected Work order, and the 
Action Taken. 

Images 

The Images command from the options menu allows you to see which component/part 
images are associated with a particular Work Order. It is possible to add and delete 
related images from this window. To view the selected image, choose View Image from 
the revised Options menu. The Images register is covered in section 3.1.11. 

 
Job Description 

A defined job may contain a Job Description with a textual explanation that is printed 
out to provide instructions for how a work order is to be carried out. The Job 
Descriptions register is described in section 3.1.3. The Job Description command from 
the Options menu gives access to this window:  
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Job Description Images 

The Job Description Images command from the Options menu allows the user to see 
which work related images are associated with a particular Work Order. It is possible to 
add and delete related images from this window. To view the selected image, choose 
View Image from the revised Options menu. The Images register is covered in section 
3.1.11. 

 
Required Parts 

The Required Parts command from the Options menu gives access to the window that 
is used to register which parts are being used in the selected work order. There is a 
corresponding toolbar button. 

 
Read more about reporting work in section 4.4. 

Required Disciplines 

The Required Disciplines command from the Options menu gives access to the 
window that is used to register which disciplines are involved in the selected work order. 
There is a corresponding toolbar button. 

 
Read more about reporting work in section 4.4. 
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Included Jobs 

If the selected work order is defined as a round the command Included Jobs is made 
available in the Options menu. The command may be selected to get an overview of the 
jobs that are included in the round. The function for defining rounds is described in 
section 3.1.8. 

Maintenance Log 

Work performed on work orders is logged in the Maintenance log to keep track of parts 
and resources used for example. There is a separate command for the log in the 
Maintenance menu, and it is described in section 4.9. 

Reschedule Log 

Work orders that have been rescheduled can be recorded in the reschedule log. If you 
want to use the reschedule log you need to set the parameter ‘Log Job Rescheduling’ to 
True. If you also want to record the reason for rescheduling the job you should set the 
parameter ‘Require Reason For Job Rescheduling’ to True. Both of these parameters are 
described in section 7.7.4.5. 

Report Work 

The functions for reporting work are described in section 4.4. 

Issue 

Work orders that have been planned may be issued from the Work Orders window. It is 
possible to issue multiple work orders in a single operation by checking the ones to be 
issued: 

 
Use the menu command Options/Issue, or click the corresponding toolbar button to 
issue the required job(s). In the Issue Work Orders dialog box that appears select the 
preferred Output Format and how the output is to be sorted. 

Control 

Unless a system parameter has been set so that completed work orders are filed 
automatically, the Work Order window must be used to control the work orders and file 
them. From the Work Orders window, tag the work orders to be marked as Controlled 
and give the menu command Options/Control or click the corresponding toolbar 
button. 

Copy 

The Copy command from the Options menu allows you to make a copy of an existing 
work order. The new work order will be given the next available number in the series. 
When presented with the dialogue box, choose whether to copy the required parts and/or 
disciplines when you make the copy. 

Create Order Form 

If you are viewing a work order that you would rather purchase (as a service) you should 
select Create Order Form from the Options Menu. This will open a selection window 
where you can choose which of the three form types you wish to create. There is also a 
checkbox to use if you want to list the newly created form. When the form is created it 
will be given the next form number in the sequence and the work order details will be 
included as a line item attached to the form. 
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4.2 Work Planning 
Unless certain work order flow system parameters at the installation have been set 
differently, generated work orders will have the status Requested and not Planned. In 
order to activate such work orders, and also work orders that have been requested 
manually in the window Requisition Work (see section 4.5), the Work Planning window 
must be used to plan the work orders. This window is also used to re-schedule and 
otherwise follow up on work orders. 

4.2.1 The Standard Work Planning Interface 
AMOS M&P is supplied with a choice of work planning interfaces. The standard 
interface is included without charge and is discussed in the following section. The 
enhanced interface, which offers greater functionality and flexibility, can be purchased 
as a plug-in module and is covered in section 4.2.2. 

4.2.1.1 The Work Planning Filter 
The Filter dialog box for the Work Planning window is the same that is used for the 
Work Orders window. This filter is described in section 4.1.1. 

4.2.1.2 The Work Planning window 
The work-planning window looks like this: 

 
These are the areas found in the Work Planning window: 

• The second toolbar contains a drop-down list with the various possible statuses a 
work order may have. Each status is represented by a specific colour. Once the 
menu has been opened, it is possible to let the mouse pointer rest on a colour to see 
a tool tip with the name of the status for each colour. 

• On the left hand side is a list of the work orders matching the criteria that were 
specified in the filter window. 

• To the right of the work order list there is a graphic representation of a timeline. 
Each work order is represented by a colour coded horizontal bar on this timeline. 

• On entering the work-planning window, the Gantt chart scrolls to Today. When a 
work order title is clicked, the Gantt chart automatically scrolls to the associated 
work order, and selects it. 

• It is possible to click a column header in the Gantt chart to have it sorted by that 
column. 
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• The upper, left part of the window contains several columns with additional 
information about the work orders. Use the mouse to drag the line separating the 
data columns and the graphical timeline sideways, depending on what is to be 
displayed. 

 
• The first tab card in the lower part of the window shows the details of the work 

order that is selected in the timeline. Note that a single line may represent several 
jobs (for example, if the work order represents a round).  

• The Selected List tab card is the second of the three cards. It is possible to select 
multiple work orders in the window and work on them as a group. Hold down the 
Ctrl key while clicking on the work orders to select. 

• The Disciplines tab card is the third one. It shows an overview of the disciplines 
for which work has been planned The figures in the Work column represent the 
total number of hours planned for each discipline. The timeline to the right of the 
three tab cards shows the number of scheduled hours for the involved disciplines 
for the selected work order. 

 
The F5 key may be used to update the Disciplines tab card. • 

4.2.1.3 The Work Planning Options menu 
The Options menu is added to the main menu bar once the Work Planning window has 
been opened. It contains the following commands: 

 
If multiple work orders have been selected (by holding down the Ctrl button while 
clicking), the Options menu will look like this: 
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Required Parts 

The command Required Parts from the Options menu gives access to the window that 
displays the parts that have been connected to the selected work order. There is a 
corresponding toolbar button. 

 
Required Disciplines 

To specify additional disciplines for the selected work order, give the menu command 
Options/Required Disciplines. There is a corresponding toolbar button. 

 
To add a new line, click the New button, select the discipline from the first dropdown 
list and specify the number of hours. It is also possible to specify the estimated cost in 
the same dialogue box. Close the box and click the Save button to save the data. 

Included Jobs 

If a round has been attached to a work order, the command Included Jobs is available in 
the Options menu. Give it to access the list of jobs that are included in the round. 

Change Status to 

The command Change Status to in the Options menu is used to change the status of 
one or more work orders in the timeline. 
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Change Values 

The command Change Values in the Options menu is used to change values of one or 
more work orders in the timeline. 

 
Settings 

To access the window for setting up the calendar, make sure the Work Planning 
windows is open and give the menu command Options/Settings. The dialog box shown 
below is used to specify what the timeline should look like. 

 
Note that if the box Autoscale has been checked, the number of pixels per day is set to 
zero, and AMOS M&P automatically scales the timeline to display the defined work 
orders. 

Refresh Disciplines 

The command Refresh Disciplines may be used to refresh the corresponding tab card at 
the bottom of the window. This has the same effect as pressing the F5 key. 

4.2.2 The Enhanced Work Planning Interface 
The Enhanced Work Planning Interface offers greater functionality and flexibility than 
the standard interface. It is possible to carry out almost all maintenance planning and 
reporting through the enhanced interface. It is also anticipated that future expansion of 
the enhanced interface will provide further benefits. 

4.2.2.1 The Enhanced Work Planning Filter 
The Filter dialog box for the Work Planning window is similar to the one that is used for 
the Work Orders window. This filter is described in section 4.1.1. The main difference is 
that you can search for project jobs by individual project (either on their own or with all 
other work orders) or by individual project section (only section jobs are shown).
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4.2.2.2 The Enhanced Work Planning Window 
The enhanced work planning window looks like this: 

 
These are the areas found in the Work Planning window: 

• The second toolbar contains a drop-down list with the various possible statuses a 
work order may have. Each status is represented by a specific colour. Once the 
menu has been opened, it is possible to let the mouse pointer rest on a colour to see 
a tool tip with the name of the status for each colour. 

• On the left hand side is a list of the work orders matching the criteria that were 
specified in the filter window. 

• To the right of the work order list there is a graphic representation of a timeline. 
Each work order is represented by a colour coded horizontal bar on this timeline. 

• On entering the work-planning window, the Gantt chart scrolls to Today. When a 
work order title is clicked (selected), the Gantt chart automatically scrolls to the 
start date of the associated work order. 

If you move the cursor over a work order, the cursor changes from a pointer to a box 
with arrows on either side. At the same time as the cursor changes, a text box appears 
containing details of the work order. Here is an example: 
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Once the cursor has changed, it is possible to move the selected block or work order to a 
new position on the time line, using the ‘drag and drop’ technique. Left click and hold 
the mouse while the double arrowed cursor is over the work order you wish to move. 
You should notice that small black squares appear at each corner of the work order to 
signify that it is now selected. A new text box, entitled ‘Move Activity’, will appear 
above the work order. This informs you of the start and end dates where the work order 
(represented by a box outline) is, as you drag the work order one way or the other. When 
the dates shown in the text box are to your satisfaction, release the mouse button and the 
work order is now rescheduled. If you have the Reschedule log enabled the alteration 
will be recorded with or without a reason depending on how the parameters have been 
set. See section 4.1.4 for more information on the reschedule log. 

   
It is also possible to vary the duration of a work order in a similar way to the 
rescheduling option shown above. Move the cursor to one side of the work order you 
wish to alter. The cursor should change to a single arrow pointing one way or another. 

 
Once the cursor has changed, it is possible to alter the length of the selected block or 
work order along the time line, using the ‘drag and drop’ technique. Left click and hold 
the mouse while the single arrowed cursor is over the work order you wish to alter. A 
new text box, entitled ‘Change End Date’, will appear above the work order. This 
informs you of the end date and duration of the work order as you drag it one way or the 
other. When the date and duration shown in the text box are to your satisfaction, release 
the mouse button and the work order is now altered. Note that if you move both the start 
and end dates the alterations will be classed as a rescheduling. 

   
The Details Tab 

 
The lower part of the Enhanced Work Planning window contains the details of the 
currently selected work order. The areas with a white background may be modified. 
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The Selected List Tab 

The Selected List tab card is shown below: 

 
It is possible, as shown above, to select several work orders to be worked on at the same 
time. To do this you can either hold down the Ctrl key while clicking on the required 
work orders or by clicking and dragging a rectangular box which covers the work orders 
to be included, as shown below. 

 
The Disciplines Tab 

The Disciplines Tab is shown below: 

 
The Disciplines Tab gives you an overview of the work planned for each discipline. The 
timeline contains a box for each work order according to discipline(s) required. The 
number of required hours appears to the right hand side of each work order. This makes 
it clear to see whether there are manpower shortages or conflicts of scheduling. If you 
move the cursor over a work order, a text box appears informing you of the work order 
number.  
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4.2.2.3 The Enhanced Work Planning Options Menu 
 

 

The commands in between the 
lines are also available in the 
Work Orders Options Menu 
described in section 4.1.4 

The Enhanced Work Planning Options Menu is very similar to the Work Orders Options 
Menu. The menu selections from ‘Details’ down to ‘Control’ are all available within that 
menu. See section 4.1.4 for further explanation. 

Change Status to 

   
The Change Status To menu option allows the status of the selected work order to be 
changed to one of the listed alternatives. The yellow button on the toolbar is a shortcut 
to the same function. It has a small arrow next to it that, when clicked, changes into a 
drop down window (shown above) with the equivalent work order statuses in the same 
order as they appear in the menu. There is a further shortcut option for altering the status 
to ‘Planned’ by pressing the F8 key. 
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Change Values 

 
When you have a number of work orders grouped together into a selected list, it is 
possible to alter the above values to apply to all grouped work orders. There is also a 
toolbar button to access the same window. 

Scale 

 
The scale option allows you to jump to today’s date, regardless of the time scale in use, 
and to change the way the timeline is displayed. The options Month, Week and Day alter 
the amount of time displayed in the timeline window by changing the space allocated for 
the selected time period and also takes the timeline to the current date. There are 
corresponding toolbar buttons. The Work Order Tracking Accuracy parameter can also 
be set to allow display and tracking of work orders to the nearest 15 minutes if required. 
See section 7.7.4.5 for details on this parameter. 

Settings 

 
The Settings window allows for further customisation of the timeline window. The 
Work Order Tracking Accuracy parameter can also be set to allow display and tracking 
of work orders to the nearest 15 minutes if required. See section 7.7.4.5 for details on 
this parameter. 

Refresh Disciplines 

The refresh Disciplines option allows you to update the Disciplines Tab screen without 
having to close and re-open the Enhanced Planning Window.
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4.2.3 The various Work Order statuses 
A work order changes status at different points in the process. AMOS M&P registers a 
work order as started the first time you report work based on it. Here is a list of the 
various statuses a work order may have: 

Status What has happened 
Requested Work orders generated for periodic jobs are normally given 

this status (unless a system parameter has been set to give such 
jobs the status Planned), and this is also the status of work 
orders that have been requested manually in the Requisition 
Work window. 

Planned Work orders with a status of Requested, Pending or Postponed 
may be set to Planned if the work may start when the Due Date 
has been approved. If certain system parameters have been set, 
periodic jobs will automatically be set to Planned.  

Issued Work orders with the status Planned may be issued and printed 
out. 

Postponed If for any reason a job needs to be postponed, the status may 
be changed to this from jobs with the current status of 
Requested, Pending or Planned. 

Pending Jobs depending on a specified condition, such as Shutdown 
required, may be set to Pending. Jobs with the current status 
Requested, Postponed, or Planned may be changed to Pending. 

Cancelled This status may be set if it is necessary to cancel a work order. 
Completed If a work order report specifies that the work has been carried 

out, the status should be changed to Completed. 
Controlled Unless system parameters specify that Completed work orders 

be filed automatically, they must have their status changed to 
Controlled first.  

Filed The work order has been closed and stored; it may be viewed, 
but no further changes can be made. Only Completed jobs may 
get the status Filed. 
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4.3 Projects 
The Projects function allows extraordinary or emergency maintenance work to be 
grouped together under a project name and sub-divided into sections. This enables the 
user to keep closer track on related maintenance tasks within a major project situation 
such as damage repair or re-fit. 

When you first open the Projects window you will need to add projects, sections and 
jobs. The projects window will initially appear quite empty until you have begun 
entering information. 

The following screenshot shows a project that has already been created. 

 
The creation of new projects and sections is carried out by clicking on the ‘New’ toolbar 
button when the area of focus is the hierarchy (left-hand) pane. Creation of new jobs 
within a section is carried out by clicking on the ‘New’ toolbar button while the area of 
focus is in the bottom left-hand list of jobs pane. To focus on one area or another just 
left-click with the mouse while the cursor is in the desired area of the projets window. 

The remainder of the window is the same as the work orders window described in 
section 4.1.2 with a line at the top allowing you to add your own job number and title to 
the work order. 

Clicking on the new button opens the following window: 

 
Select project or section (note that you cannot create a section unless you have already 
created a project) and click on OK. Once you have created a section, the create job will 
become active (providing that you are highlighing a project section). 
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If you chose to create a project you will see the following window: 

 
Enter the required information for the project you want to create. The Project No. and 
Title fields should contain information meaningful to your organisation. Installation, 
Project Manager, Category and Status can be selected from the various drop down 
windows. Created, Start and End are all date fields and can be set by double clicking in 
the field and selecting the required date from the pop-up calendar. The Locked checkbox 
can be used to fix the estimated duration of a project. Access to this box is controlled by 
an entry in the ‘Fields’ tab of Access Control, described in section 7.7.2. This feature 
could be useful for comparing estimated duration against the actual duration upon 
completion of the project. The pane on the right can be used to attach account categories 
and codes to the project. 

If you chose to create a section you will see the following window: 

 
The Section No. and Section Name fields should contain information meaningful to your 
organisation. 

When you have created a project with at least one section and you have selected the 
required section (should be highlighted in blue), you can click on new in order to add 
jobs to it. 

In order to make it easier to add jobs to the correct section of a project, when there are 
many sections to choose from, the currently selected section has the following clipboard 
icon  instead of the normal list icon .  

Click on the new button and select job from the dialogue box to obtain the following 
window: 

 
If you click on Yes you will be allowed to select any existing work order. 

If you click on No the work order area of the screen will be emptied of information and 
you will be able to create a manual work order as described in section 4.1.2. Note that 
any manually created project job will be issued the next available work order number to 
uniquely identify it. 
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When you are in the projects window the Options menu available contains exactly the 
same choices as the one found in the work orders window with the addition of the 
following: 

 
Project Properties and Section Properties are only available when you have highlighted 
the appropriate area of the hierarchy pane. When you click on either of the properties 
options you can alter the details of  the project or section in the same types of window 
that you used to create them. 

 Access control is used to open the following window: 

 
Each project has its own, dedicated, access control feature that can be used to allow or 
deny different levels of access to any defined group . 

All the other menu entries function in exactly the same way as the ones in the work 
orders options menu except for the ‘Create Order Form’ menu item. 

When you want to sub-contract project jobs to an external supplier, click Create Order 
Form and the following window will open: 

 

External disciplines  
that have been used 
for jobs within the 
selected project will 
appear here. 
 

If you want to sub-contract project jobs it is important that the disciplines selected to 
carry out the jobs are defined as external in the Discipline Register, see section 3.1.12.2. 
When you open the create order forms window above, you can select the required 
external discipline from the left-hand window. AMOS M&P will list external all 
disciplines that have been used for the jobs contained within the selected project. 

When you have selected the discipline and form type, check the box if you want to list 
the form, click on OK and a new purchase form will be created containing individual 
line items for each job scheduled to be carried out by the selected discipline. The form 
will be given the next automatically generated form number and you can fill in the 
remaining details to complete the form ie. Vendor, Budget, Payment Terms etc. 
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4.4 Report Work 
Once the jobs have been performed, progress is reported back to AMOS M&P. 
Otherwise, AMOS M&P will keep issuing reminders. 

AMOS M&P uses the report to update the maintenance schedule, and the stock and 
budget information. AMOS M&P also documents the compliance with warranty 
requirements and safety regulations. 

• For one-time tasks that are known about in advance where there is no job defined, 
make and report a Requisition work order. Read about this in section 4.5. 

• In some cases, maintenance tasks are handled on the spot and reported after they 
have been completed. 

• When reporting jobs done out-of-turn, the report should be marked as 
“unexpected” so AMOS M&P can help evaluate the maintenance program fairly. 

4.4.1 Different strategies for Reporting Work 
Reporting work may be approached from one of the following angles: 

• If the menu command Maintenance/Report Work is given without any open 
windows, AMOS M&P presents the following dialog box: 

 
• The system parameter Default Preference When Reporting Work determines 
which default option is checked: Function, Component or Work Order. Use the 
Search button to select the Function, Component or Work Order and click Next to 
enter the Report Work screen. 
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• For example, if Component is selected when the Search button is clicked, the first 
step is to select the relevant component. When Next is clicked, a list containing the 
item Unplanned Maintenance is presented. In addition, the issued work orders for 
the jobs connected to the selected component: are included.  

When the desired work order has been selected, click ‘Next’ to enter the Report 
Work window. 

• 

• 

• 

It is also possible to select Options/Report Work while in the Components screen. 
The same dialog box shown above will be presented. Similarly, the command is 
available from the Function hierarchy. 

Finally, work may be reported from the Work Orders screen. 

4.4.2 The Report Work window 
The Report Work window looks like this: 

 

4.4.3 The tab cards in the Report Work window 
The Report Work window contains four tab cards with information. If work is reported 
on a round, a fifth tab card is added. The tab cards are described below.  

The Details tab card 

• The job should normally be marked as unexpected if it did not appear on the 
printed maintenance plans, that is, if it is a regularly scheduled job that had to be 
performed out of turn.  

• A Type, Class and Cause may be selected. Click the small down arrow to open the 
list and click on the choice. 

• When all the information on the other tab cards such as History, Stock Used and 
Resources Used have been completed, remember to save the Work Order Report. 

Note: The Reporting Options frame contains the three check boxes History, Stock Used and 
Resources Used. There are corresponding AMOS M&P parameters that are used to set 
which of these boxes are checked by default. If an option box is checked, it is necessary 
to fill in data on the corresponding tab card. If the tab card is to be left empty, it is 
necessary to un-check the corresponding box in order to be allowed to exit the window. 
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The Resources Used tab card 

Use the Resources Used tab card to report time used to complete maintenance jobs. This 
card can display Disciplines or Employees depending on how AMOS M&P is set up. 
Typically, the system will be set up to register resources by discipline. AMOS M&P will 
also update the budget information. 

 
The Stock Used tab card 

If parts from stock were used to complete the job that is being reported on, fill out the 
Stock used tab card to keep your stock and budget information up-to-date. If you have 
used stock items that are defined as perishable, you will have to select the correct expiry 
date from the ‘Expiry Date’ look-up list. 

 
Note: If AMOS M&P is set up to take Depreciation into account, you can differentiate 

between the use of new and used stock items by selecting the appropriate level of 
Depreciation from the drop-down menu in the column furthermost to the right in the 
above screen.   
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The History tab card 

The appearance of the history window can vary from installation to installation, and 
from job to job. Click the History tab to begin working on the History tab card. Here is 
an example of what the History tab may look like if a template has been applied: 

 
Simple reporting of rounds 

A Round consists of several jobs grouped together. When reporting work on a defined 
round and the Report Method is set to Simple (see section 3.1.8), the Jobs tab card is 
added, making it possible to check off which defined round jobs have been completed 

 
The first time work is reported against a simple round work order the Completed box is 
unchecked for all the jobs listed. It is then possible to check the jobs than have actually 
been completed, and save the work order. When more jobs belonging to the same work 
order have been completed, the reporting may continue until all the jobs have been 
checked off as completed. 

The toolbar also contains two buttons that may be used to check all the jobs as 
completed, or to mark all the jobs as not completed: 

 
There are corresponding commands in the Edit menu. 
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Full reporting of rounds 

The Reporting Method (see section 3.1.8) may also be set to Full. When work is 
reported against such a work order, the user is first presented with a Round Summary 
window: 

 
• The amount entered in the Total Time is automatically distributed equally between 

the not completed jobs connected to the work order.  

• Similarly, the amount in the Misc. Expenses is distributed between the not 
completed jobs. 

• The Resources Used tab card may be used to specify by whom the work has been 
performed. The values entered are also distributed between the jobs not yet 
completed. 

• The Down Time (Hrs), entered in the Round Summary window, will be assigned 
unchanged to each not completed job. 

• When the values to be distributed have been entered, the Next> button is clicked to 
move to the next window described below. 
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• The box Mark Work Order as Completed at the top should be checked the last time 
the dialogue box is used to report work against this work order. 

• It is possible to report on a round work order several times, until all the included 
jobs are checked as completed. The Completed column in the bottom right corner 
of the window will show which jobs have been completed already when work has 
been reported previously. 

• The jobs included in the round are displayed in the list at the bottom of the 
window. Select the job to report work on, and fill in the various tab cards. When 
the job is completed, remember to check the box Job Completed on the Details tab 
card. 

4.4.4 The Report Work Options menu 
The Options menu is added to the main menu bar once the Work Orders window has 
been opened. It contains a single command: 

 
If transaction codes have been defined (see the next paragraph), the command may be 
selected to specify proper transaction codes for the work order. 

Section 7.7.4.7 describes the options that may be set for transaction codes, while section 
7.7.7 shows how values may be specified for defined transaction codes.
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4.5 Requisition Work 
Sometimes it is necessary to perform maintenance work that is not defined as a job 
because it happens so rarely or unpredictably: For example, an additional refrigeration 
unit is installed, or the ship is taken into dry-dock. AMOS M&P helps to plan and 
document this work as well.  

For once-off tasks like this, create a Requisition work order for the component on which 
work is to be done, describing the work, the parts needed, and the time to be used. Later, 
report the work back to AMOS M&P by entering completion data for the work order. 

4.5.1 The Requisition Work window 

 
Give the menu command Maintenance/Requisition Work or click the corresponding 
button in the toolbar to see the Requisition Work form. There is a corresponding toolbar 
button. 

• Enter the Title of the work order in the WO No. field to describe the work to be 
carried out. 

• By entering the date for ‘Planned Start,’ the Requisition automatically generates an 
entry that can be viewed in the Work Planning screen, at Maintenance / Work 
Planning. 

• The default priority of such a Request for Work is 1. 

• If the work is unexpected, check the box Unexpected Work. 

• Be sure to fill in the three free text fields for Effect, Cause and Action Taken in 
order to provide a good description of why the work order has been issued
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4.6 Generate Work Orders 
To generate work orders for newly defined jobs and requests for work, it is necessary 
first to plan them. Then issue the work orders to show what work needs to be done in the 
coming period. Once a work order for a periodic job has been generated for the first 
time, AMOS M&P will automatically generate the next work order for the same job 
once the status of the previous one has been set to Completed. 

4.6.1 Generating Work Orders 
To generate work orders, give the menu command Maintenance/Generate Work 
Orders or click the corresponding toolbar button. The following dialog box is 
displayed: 

 
• Check the relevant boxes in the area Generate Work Orders for. 

• Check the box Print List of Generated Work Orders if you want to do so, and click 
OK to generate the work orders. Click OK when you are asked to confirm that you 
really want to generate work orders. 

Work orders based on jobs that are defined with a periodic frequency, are handled 
automatically by AMOS M&P once the system has been ‘kick started’ by generating the 
first work order: Once the status of this work order has been set to Completed, the 
system generates the next work order. 

On some occasions it is necessary to create a new work order in between regular due 
dates of the defined frequency. For example, a job may be defined to be carried out 
twice a year, and major maintenance is being planned between the previous and the next 
due date. AMOS M&P makes it possible to schedule an additional work order for that 
job in between the regularly planned work orders. To do so, select the menu command 
Options/Create Work Order while the job in question is selected in the Jobs window.
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4.7 Counters 
Each job has information about when it should be performed: This can be a frequency, 
either daily, weekly or monthly, or the job can be performed when some counter reaches 
a predefined level. For example, if an engine is to be checked every 1200 hours, AMOS 
M&P will start counting hours again as soon as it is reported that the engine has been 
checked. When 1200 hours approaches, the job “check the engine” will appear when 
print job lists for the coming period are printed or the window for planning work is used. 

AMOS M&P counts time by itself, but some other types of counters must be updated 
manually. For example, if there are maintenance jobs that must be performed when the 
ship has docked a certain number of times, there will be a counter for the number times 
the ship has docked which is updated at each new harbour. 

If the installation uses automatic Condition-Based Maintenance (CBM) functions 
described in Appendix B, then a job may be scheduled when a monitor or sensor detects 
a predefined condition in a component and passes this information to AMOS M&P. For 
example, a sensor might detect when the temperature in a cooled unit rises above 10º 
Celsius, or when an arm on a rotating unit has made 36000 rotations. 

The Counters sub-menu contains two commands: 

 

4.7.1 Update 
The command Maintenance/Counters/Update brings up the following filter dialog 
box: 

 
The Search button may be used to select a specific component. The Counter Type drop-
down list contains the defined counter types. The register for defining counter types is 
described in section 3.1.12.3. 

The Update Counters window displays the counters that match the criteria specified in 
the filter. For each counter, the Current Value field may be updated along with the Date 
Read. 
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4.7.2 Overview 
The command Maintenance/Counters/Overview brings up the following filter dialog 
box: 

 
The filter resembles the one for the Update Counters command described in the 
previous section, but it is also possible to select a component from which the counter is 
supposed to inherit values. It is also possible to filter the information by Component or 
Function Criteria. 

The Counter Overview window looks like this: 

 
This window only displays information on the current value for the selected counters; 
none of the fields may be updated here.
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4.7.3 Counter Log 
The command Maintenance/Counters/Counter Log brings up the following filter 
dialogue box: 

 
The filter is the same as that used in Update counters described in section 4.7.1. 

 
The Counter Log is used to store and view all counter updates. 

4.8 History 
The command Maintenance/History may be used to select the work orders for which a 
history has been registered. This is done on the History tab card in the Report Work 
window; see section 4.4.3. 

The Maintenance/History command brings up the following filter dialog box: 
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When the filter selections have been made, click OK to bring up the list of work orders 
containing history information: 

To see the Details window for the selected work order select Details from the Options 
menu or click the corresponding toolbar button. 

 
This is an example of the Details screen: 

 

4.9 Log 
AMOS M&P automatically logs four types of data during the use of various 
maintenance functions. The types are: 

• History 

• Stock Used 

• Resources Used 

• Counter Readings 

These types correspond to the tab cards in the Report Work window described in section 
4.4.3. 

When the command Maintenance/Log is selected, the following filter dialog box is 
presented: 
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Click OK when the filter has been filled in to open the Maintenance Log window: 

 
The entries are listed at the bottom of the window. The top of the window shows some 
detailed information for the highlighted list entry.  

4.9.1 The Options menu for the Maintenance Log 
Once the Maintenance Log window has been opened, one of the list items at the bottom 
of the window may be selected. The Options menu is added, and the commands are 
described in this section. 

   
There are corresponding buttons in the secondary toolbar: 

If nothing happens when a command is given or a button is clicked, there was no data 
for AMOS M&P to display. 

History 

See section 4.8. for a description of the History of a work order 

Stock Used 

The Stock Used command from the Options menu brings up the following window: 
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The Stock Transactions function is described in section 5.4. 

Resources Used 

The Resources Used window looks like this: 

 
Counter Readings 

The last category of information in the Maintenance Log will display the status of any 
defined counters for the component of the selected line. If no counters have been defined 
for the component in question, the window is empty: 

 

4.9.2 Sorting the Log 
Click on the appropriate column titles to sort the maintenance log entries by (for 
example) date, component, function or work order number
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5 The Stock Menu 

This chapter covers the commands in the Stock menu: 

 

5.1 Wanted 
The Stock Wanted window gives you a complete overview of your current stock 
situation and supplies you with the information required to make accurate purchasing 
decisions. 

When you select the Stock/Wanted menu option, you are presented with the following 
filter window: 

 
Click on OK if you want to list all stock, or enter details in one or more fields first if you 
want to restrict the list to items of particular interest. The filter can be used to restrict the 
information you receive by Stock Item Number (individual number or a 
range),Alternative Number, Name, Maker or Maker’s Ref, Preferred Vendor, Stock 
Class or Stock Status. The visible items can be further restricted by checking the box to 
show ‘Display Wanted Quantities greater than zero only’. Checking the ‘List 
Outstanding Quantities’ will provide an extra column in the display window showing 
requisitioned quantities. 
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The upper section of the Stock Wanted window contains information for the currently 
highlighted stock item. This information is derived mainly from the Stock Items window 
described in section 3.1.2. 

The lower section is divided into columns, two of which are modifiable. If you want to 
order stock items manually, you can simply scroll down through the list and enter the 
required quantities for each stock item in the Wanted column. Any stock items that are 
below the minimum stock level are highlighted in red. 

You can also mark the required quantities that are for use with a specific component by 
entering its number in the For Component column. If a stock item is already associated 
with a single component number, that number will appear automatically when you 
update the quantity wanted. 

There are two parameters that control the way the ‘For Component’ works: 

The parameter ‘Component Search Range in Stock Wanted’ can have the values 
‘Restrict’ or ‘Any’. If set to ‘Restrict’, the look-up filter next to the ‘For Component’ 
column will only show components associated with the stock item. If set to ‘Any’, all 
components will be listed. 

The parameter ‘Clean-up ‘For Component’ in Stock Wanted’ can have the values 
‘TRUE’ or ‘FALSE’. If set to ‘TRUE’, the ‘For Component’ column will be cleared 
once forms have been generated. If set to ‘FALSE’, the last component number entered 
in the column will remain until altered. 

These parameters are described in section 7.7.4.5. 

The Options menu for Stock Wanted 

 
Note:  The functions contained in both the Options and Edit menus can be accessed by clicking 

the right-hand mouse button.
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View Stock Item 

The View Stock Item command takes you to the same window that can be accessed 
through the Open register/Stock Items menu option covered in section 3.1.2. 

 
Show Outstanding Forms 

The Show Outstanding Forms window gives you access to information regarding active 
forms of type Query, Requisition, Purchase Order and Transfer Documents. 

 
This screen is purely for information purposes and is therefore un-editable. 

Used in Components 

The Used in Components window shows a list of all components in which the selected 
stock item is used.  
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The non-shaded columns are editable and new component associations can be added or 
old ones deleted according to requirements. The quantity of the selected stock item in 
use on any particular component can be altered if needed. The stock item/component 
drawing number and position number can also be altered from this screen (if you have 
the required system authority) as an alternative to using the Components/Parts screen 
described in section 3.1.1. 

Generate Forms 

When you select the Generate Forms option from the Options menu you are presented 
with the following dialogue box. 

 
Select the type of form you would like to create and whether you would like to list the 
newly created forms after they have been created. Click on OK to proceed. 

The Create Forms filter window 

 
The Create Forms filter window can be used to restrict form creation to a specific range 
of stock items, a particular stock class, a preferred vendor or a combination of any of the 
above. Click on OK to proceed. 

If you checked the List newly created forms box earlier, you should see a screen similar 
to the one below. 

 
The Forms window is described further in chapter 6. 
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Calculate Wanted Quantities 

When you first click on the Calculate Wanted Quantities menu item in the Options menu 
you will be presented with the following filter screen. 

The default setting for the Calculate Wanted Quantities window 

 
The filter allows for the restriction of calculated items by Number, Maker, Preferred 
Vendor or Stock Class. The radio buttons in the bottom left corner of the window allow 
you to alter the target quantity. If Reorder Quantity is selected the application will 
simply calculate which items require ordering and set the wanted quantity to the Reorder 
quantity as shown in the Stock Items window. If Minimum or Maximum is selected, the 
application will calculate the quantity required to bring the stock level up to the 
respective amount. If you choose to un-check the Display Wanted Quantities > 0 Only 
checkbox you will get a screen display which contains all the stock items in the 
specified range whether they require ordering or not. 

In the example screen display below the default setting of Calculate Wanted Quantities 
(shown above) was used. 

 
Note:  AMOS M&P calculates whether a stock item requires ordering by adding outstanding 

orders to current stock and then subtracting those stock items that are reserved against 
work orders. The resulting figure (quantity on hand) is then compared to the reorder 
level figure. If the quantity on hand is less than or equal to the reorder level, a 
requirement is indicated when the menu item Calculate Wanted Quantities is processed.
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5.2 In/Out of Stock 
Most stock transactions are related to either a maintenance action or a purchase form, 
and AMOS M&P captures these transactions and displays them for you with the Stock 
Transactions window. 

However, in some circumstances you may need to register stock in or out of stores 
manually. 

Select the In/Out of Stock function from the Stock menu to bring up the following 
screen. 
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AMOS M&P Reference Manual
Stock Items Filter
er the stock item number if known, otherwise click on the icon to the right to bring 
he stock items filter and select the number from the list. The default location will 
matically be shown in the Location window. An alternate location can be specified 

ne is available. Enter the required amount in the Quantity field. 

 Transaction Date will show the current date. This can be altered if a transaction has 
n carried out recently but not yet entered into the system. To alter the date you can 
ble click the date window and select the correct date from the calendar facility that 
ns. 

k items may be added to, or removed from stock for a variety of reasons. One of the 
owing transaction types must be selected when using the In/Out of Stock function. 

• Purchased  (Qty. is increased) 

• Used   (Qty. is decreased) 

• Returned unused (Qty. is increased) 

• Lost   (Qty. is decreased) 

• Found   (Qty. is increased) 

• Sold   (Qty. is decreased) 

• Transferred in  (Qty. is increased) 

• Transferred out  (Qty. is decreased) 

• Delivered back  (Qty. is increased) 

• Lent out  (Qty. is decreased) 

• Trashed  (Qty. is decreased) 

e stock item is defined as ‘perishable’ and you are removing items from stock, the 
iry date will be imported if there is only one to choose from, or you will have to 
ose the correct date from a list if there are several expiry dates. If you are adding 
shable stock, you will have to enter the expiry date manually. Double click on the 
iry date field to use the calendar facility. 
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The remaining fields can contain further information regarding Work Order No., 
Component No., Reference or Budget Code if required. 

The fields at the bottom of the window contain information on the selected stock item’s 
location, stock levels and quantity on order. 

If you wish to record several stock transactions at the same time, click the New Entry 
button and fill in the fields as before. Please note that all stock item transactions must be 
of the same type if you are going to use the same form. 

5.3 Control 
At regular intervals, you should take inventory to ensure that the actual physical stock in 
store matches the theoretical stock shown by AMOS M&P. This could be annually, 
monthly, weekly or any frequency as determined by your company. 

The Stock Control filter 

 
Click on OK to list all stock items (these will be ordered by stock location 
alphabetically). If you wish to restrict the display to one or more stock locations, you 
can enter the required information in the upper part of the filter window. If you would 
rather restrict the display to one or a range of stock items, you can enter details in the 
lower part of the window. Click on OK to proceed. 

The Stock Control window 

 
If you require a printout of the stock list, select Print from the File menu. 

Once the stock items have been counted you can enter them by clicking on the ‘Actual’ 
quantity and then typing the new quantity (this will replace the original figure). If you 
have a range of quantities to input, you can start at the top and each time you press enter 
the cursor moves down to the next row automatically. 

Remember to save the new quantities when you have finished entering them. If you 
attempt to close the Stock Control window without saving, you will be prompted to do 
so. Note that if you are altering the quantities for perishable stock items you will have to 
supply an expiry date (if increasing quantity) or choose an existing expiry date (if 
decreasing quantity.
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5.4 Transactions 
Since AMOS M&P automatically updates your stock records, based on work reported in 
Maintenance and on goods marked received in Purchase, there is not much work to do in 
Stock Transactions. 

You can view automatically recorded transactions and correct them or add additional 
information if necessary. You can also see what items are recorded both in and out of 
stock through Maintenance and Purchasing functions. 

When you first click on Stock/Transactions, the Stock Transaction Criteria filter is 
displayed. 

 
Click OK to list all stock transactions or enter your selection criteria to restrict the list to 
the item or items of particular interest. 

The Stock Transactions window will open. It will look similar to the one below. 

 
If there are many transactions listed in the lower part of the window, you can select the 
one you are interested in by clicking on it with the mouse to display the complete 
transaction details in the upper part of the window. This allows you to alter incorrect 
information or to add extra details regarding a stock transaction. Remember to save any 
alterations made. Expiry dates will have to be selected or entered when adjusting stock 
quantities for perishable items. 

The Transactions window Options menu: 
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Transaction Codes can be used to connect stock transaction expenses to specific budget 
dimensions such as a particular project or an individual user. They are covered further in 
sections 7.7.4.7 and 7.7.7. 

Reverse Transaction can be used to reverse a transaction that has been made in error or 
for returning incorrectly delivered goods. 

5.5 Transfer Documents 
There may be occasions when there is a surplus of certain stock items at a particular 
Installation that are needed at a different Installation. Using the Stock/Transfer 
Documents function allows you to create a transfer document for these items and 
ensures correct stock level updates at both installations. 

When you first click on the Transfer Documents menu option, you will be presented 
with the following filter dialogue box: 

 
The filter default settings are to ignore Approval type and to include documents of status 
Unsubmitted, Submitted, Pending, Partly Transferred and In Transit. If you want to list 
other documents, you should check the required box or boxes. 

The following screen display was obtained using the default filter settings. 

 
The Number and Title fields are free text fields and can be used to identify and describe 
the transfer documents however you choose. 

The Recipient Inst. field is grey and cannot be altered. The value is set to the current 
installation. 

The Donating Inst. May be selected from the drop-down list. The list should contain all 
installations in your organisation. If you are unsure of the donating installation, you 
should leave this field blank so that the shore-based office can select the donating 
installation. 

The Reason field is a drop down list. You should select whether the transfer is planned 
or unplanned from the list. 

When you are in the Transfer Documents screen, the Options menu becomes available. 
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The items that you can select from this menu depend on the status of the currently 
selected record and whether you are from the donating or receiving installation. 

 
The Details menu item brings up a free text screen where you can enter any explanatory 
details regarding the transfer document  

If you click on Line Items, you enter the Transfer Line Items window (shown below). 
This window allows you to select which stock items are to be included in the transfer 
document. 

 
To add a new line item click on the ‘new’ icon on the toolbar or select New Record from 
the Edit menu. 

Type in the stock item number and quantity that you want to transfer. If you do not 
know the stock item number, click on the magnifying glass icon to go to the stock items 
filter dialogue box. 

Whilst you are in the Transfer Line Items window, the Options menu changes to allow 
further options. 

 
Each line item within a transfer document has a Details screen, accessed through the 
Options menu, that is a free text area to add relevant line item information. 

If the Show All option is selected (preceded by a tick) all line items, including items that 
have been deleted from the transfer form, will be displayed. 

The Create Order Form option allows you to generate order forms for highlighted or 
tagged line items with most of the order form information already entered. A separate 
order form will be created for each preferred vendor. 

Once all line items have been added and the transfer document is complete, you must 
save the information in the usual way. 
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After you have saved the Transfer Document, you can select Submit… from the Options 
menu. 

 
The Submit window allows you to accept or reject submission of the transfer document. 
The current date and identity of the person logged onto the system are used by default. 

Once a Transfer Document has been submitted, someone with the required system 
authority can grant approval. Select Change Approval… from the Options menu. 

 
The Grant Approval window (like the Submit window) allows you to accept or reject 
approval of the Transfer Document. Once again, the current date and identity of the 
person logged on are entered by default. 

If you mistakenly approve the wrong document or need to reverse an approval, you can 
select Change Approval… from the Options menu once more. 

 
The Revoke Approval window (like the Grant Approval window) allows you to accept 
or reject revoking of approval of the Transfer Document. The current date and identity 
of the person logged on are set by default. 

 Revoking the approval of a Transfer Document does not record the identity of the 
person who carried out the instruction nor does it record the date on which the approval 
was revoked, it simply re-sets the approval status to the un-approved condition. 

Once the recipient installation has created, submitted and approved a Transfer 
Document, the donating installation will receive a copy of the same Transfer Document. 
When the donating installation opens their own Transfer Documents window, the 
request for transfer will be shown and will have the status ‘Pending’. (See below) 

 

AMOS M&P Reference Manual 5.3.00 The Stock Menu  •  124 



 

When, as the donating installation, you highlight a Transfer Document with status 
‘Pending’, the Options menu allows you to select Transfer. 

 
If you are going to transfer the amount shown on the Transfer Document, you can select 
Fill from the Options menu to automatically update the transferring column to the same 
as the requested column. If you are not sending the complete amount, you can enter each 
quantity individually. 

When the Transfer Document is correctly filled out, you should save the information 
(you will be prompted to do so if you forget). When you save the document, you will be 
asked if you wish to mark the document as ‘Transferred’. 

 
If you do not intend to take any further action on the document (if the document is 
complete or you do not have the required items) you should click on Yes. If you are 
making a partial transfer now (with the intention of completing the transfer quantity at a 
later stage) you should answer No, as this will allow you to re-enter the Transfer 
Document in order to complete it. 

Once the donating installation has marked a Transfer Document as ‘Transferred’, the 
recipient installation will see that the Transfer Document has been marked as ‘In 
Transit’. 

When the transferred items arrive at the recipient installation, access the Transfer 
document in the usual way and highlight it. Providing you have selected a document 
with status ‘In Transit’, you can then select receive from the Options menu. 

 
Once again, the options menu can be used to select ‘Fill’ to automatically match the 
Receiving quantity to the Transferred quantity, or you can enter the figures manually. It 
is possible to receive/reject and to attach a budget code to the transferred items if 
required. 
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When the Transfer Document is complete, you should save the information in the usual 
way. Once the quantity received matches the quantity transferred you will be prompted 
to mark the Transfer Document as ‘Received’. 

 
Once a Transfer Document has been marked as received, no further action can be taken 
against it. 

Just to re-cap, Transfer Document progress takes the following steps: 

1. Transfer document Created  Recipient status - Unsubmitted   
     Donating status - (not shown) 

2. Transfer document Submitted  Recipient status - Submitted  
     Donating status - (not shown) 

3. Transfer form Approved  Recipient status - Submitted  
     Donating status - Pending 

4. Goods Transferred   Donating status - Transferred  
     Recipient status - In Transit 

5. Goods Received   Donating status - Received  
     Recipient status - Received 

Note: The visible status of a transfer document is dependent upon the Installation from which 
you are viewing the information (Recipient installation or Donating installation).
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6 The Purchase Menu 

This chapter covers the commands in the Purchase menu: 

 

6.1 Forms 
AMOS M&P uses Forms for purchasing stock items. Different form types and statuses 
can and should be used, but this will depend on the internal processes and policies 
within your organization. 

A standard use for the three types of form could be: 

A requisition form is created at a remote installation to request supply of stock. The 
requisition is then received at a central office where it is converted to a query and sent to 
vendors for quotations. When the quotations have been received, the central office 
converts the form to a purchase order and sends it to the selected vendor for supply. 

6.1.1 The Forms Filter 
The Forms filter allows you to specify exactly what kind of information you wish to 
view. If you leave the filter unaltered and click OK you will retrieve the default option 
of all ‘Active’ and ‘Parked’ forms currently in the database. If you want to retrieve more 
specific information you should modify the filter accordingly. 
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6.1.2 The Forms Window 
The Forms window provides a list of all the purchase forms (Query, Requisition Form 
and Purchase Order) available in the system. From this window, a new form can be 
created or an existing one can be altered. It is also possible to select one or more forms 
for processing through the usual purchase functions. 

The forms window is divided horizontally with a list of the filtered forms appearing in 
the lower section. Selecting a form causes the relevant information for that form to be 
displayed in the upper section. 

 
If you want to process several forms at a time you should ‘tag’ the required forms by 
clicking in the checkbox at the left-hand side of each form. If you want to select all the 
filtered forms, or de-select them, there are corresponding commands in the Edit Menu. 

6.1.3 The Forms Options Menu 
Once the Forms window has been opened, there is an Options menu added to the menu 
bar: 

 
The commands available in this menu are covered in the following sections. 
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6.1.3.1 Details 
The Details command from the Options menu opens the Full Description window for 
the selected form. This screen can be used for adding general information to a purchase 
form and can also be used in conjunction with a pre-formatted template if required. 

6.1.3.2 Additional Info. 
The Additional Info. Screen displays the user names of those people who have created, 
approved or ordered the selected form. User defined fields can be added to this window 
to allow you to add company specific information. Read about User-Defined fields in 
chapter 7. 

 

6.1.3.3 Line Items 
The Line Items screen displays the individual stock items contained within the selected 
form. The individual line items are displayed in the lower part of the window whilst the 
upper part displays the details of the highlighted line item. 

 

AMOS M&P Reference Manual 5.3.00 The Purchase Menu  •  129 



 

 

Line Items – Options Menu 

Whilst viewing the line items of a form, the Options Menu changes to the following: 

 
Line Items – Details 

The Details command from the Options menu opens the Full Description window for 
the selected line item. This screen can be used for adding general information to a 
purchase form line item and can also be used in conjunction with a pre-formatted 
template if required. 

Line Items – View Stock Item 

Selecting View Stock Item from the Options Menu opens the Stock Items window for 
the selected line item. The Stock Items window is described in section 3.1.2. 

Line Items – View Component 

Selecting View Component from the Options Menu opens the Component window for 
the selected line item. The Componentss window is described in section 3.1.1. 

Line Items – Images 

It is possible to attach and view images to Purchase Form Line Items using the standard 
AMOS images interface. The images can also be attached to the order form if required. 

Line Items – Quality Check 

Selecting Quality Check from the Options Menu opens the window shown below. In this 
window it is possible to attach one or more comments to each line item regarding the 
quality of the goods that have been received. There is an option for printing the 
information entered here in the event that you wish to make a reclamation claim for 
faulty goods. This function is also available when receiving goods, when quality checks 
would normally be made. The Quality Codes field contains the information entered in 
the Quality Codes register described in section 3.1.12.6. 

 
 

AMOS M&P Reference Manual 5.3.00 The Purchase Menu  •  130 



 

Stock Grade 

This displays the supplementary stock information which is copied to the line item if 
specified at Stock Type or Stock Item level. These codes can be altered in this window if 
required. 

Line Items – Show All 

Selecting Show All from the Options Menu displays all the line items that were 
originally included on the form, including line items that have been cancelled and those 
that have subsequently been split to other forms. 

Line Items – Split 

Purchase forms may not always be organized in the most optimal way. To combat this 
AMOS M&P allows you to split line items to other forms, both new and existing, whilst 
retaining the original information for reference purposes. 

Selecting Split from the Options Menu displays the window shown below. If you want 
to split the currently highlighted line item to another form you should choose the 
relevant options from the Form Splitting window. 

If you want to split the line item to a new form you should choose sub-form (the form 
number will have a letter added to the end of it) or new form (the next form number 
available will be used). If you want to split to an existing form (to consolidate similar 
items into one order) you will have to select the existing form from a list. 

 
If you want to transfer the line item details screen at the same time, you should check the 
Copy Form Detail checkbox. 

When you split a line item to a sub form or a new form the original purchase form will 
contain a reference to the form number to which the line item was split. Likewise the 
new form will contain a reference to where the line item came from. This makes it 
possible for you to keep track of  ordered items even though they may no longer be on 
the original form you created.  

Line Items – Sort Items 

This facility re-numbers the line items in a purchase form and should be used in the 
event of line items being cancelled or split to other orders. If you have 5 line items and 
decide to cancel line item number 3, using the Sort Items facility will renumber the 
cancelled line item to number 5 and close the gap on the remaining ‘Live’ items by 
renumbering them from 1 to 4. 
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Line Items – Set Component 

The Set Component feature can be used to set a single component number against 
multiple line items. Check the line items you wish to set a component for and then select 
Set Component from the Options Menu. You can enter the component number manually 
or use the browse facility to select the number from a list. 

 
Line Items – Set Discount 

The Set Discount feature can be used to set a single discount amount against multiple 
line items. Check the line items you wish to set the discount for and then select Set 
Discount from the Options Menu. Enter the amount in the % Discount field and click on 
OK. 

 

6.1.3.4 Quotations 
The Quotations screen is where you enter details of vendors quotations when they have 
been received. Once all the quotations have been received you can use the comparison 
tools from the Quotations/Options menu to enable you to choose the price or delivery 
time that suits your needs. 
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Quotations – Options Menu 

Whilst viewing the quotations associated with a form, the Options Menu changes to the 
following: 

 
Quotations – Line Items 

The Quotations – Line Items screen displays the same lines as the form to which the 
quotation belongs. This enables you to attach individual prices and delivery times to 
each line item, which allows AMOS M&P to calculate and compare quotations. 

 
Quotations (Line Items) – Options Menu 

Whilst viewing the line items of a quotation, the Options Menu changes to the 
following: 

 
Quotations (Line Items) – Order Line 

Selecting Order Line from the Options Menu displays the purchase form order line for 
the quotation line that you are currently viewing 

Quotations (Line Items) – Show All 

Selecting Show All from the Options Menu displays all the line items that were 
originally included on the quotation such as line items that have subsequently been split 
to other forms. 

Quotations – Images 

This allows you to attach images to the quotation for viewing purposes only. 

Quotations – Note To Vendor 

This is a details screen intended for use with e-portals to send information regarding the 
quotation to the vendor. 

AMOS M&P Reference Manual 5.3.00 The Purchase Menu  •  133 



 

Quotations – Vendor’s Note 

This is a details screen intended for use with e-portals to receive information regarding 
the quotation from a vendor. 

Quotations – Terms and Conditions 

This is a details screen intended for use with e-portals to receive the terms and 
conditions of a quotation. 

Quotations – Calculate 

Selecting Calculate from the Options Menu opens the following window. The “Quoted 
Price” displayed is the total price of the quotation, line item quantity multiplied by price 
minus discount, from the highlighted supplier. The correct operation of the Calculate 
function depends upon quotation prices and discounts being entered at line item level. 

 
Quotations – Compare 

Selecting Compare from the Options Menu opens the following window. Each line item 
of the quotation is displayed with columns for each of the Vendors that are being 
considered and an extra column at the far right hand side that displays the cheapest price 
(or shortest delivery time) for each line item. The correct operation of the Compare 
function depends upon quotation prices and discounts being entered at line item level. 
The display can compare quotations based on prices or delivery times through use of the 
Compare Quotations Options Menu. 

 
Quotations (Compare) – Options Menu 

Whilst viewing the Compare Quotations window, the Options Menu changes to the one 
of the following: 

   
This menu toggles between the two states shown above depending on which state is 
currently active. 

Quotations (Compare) – Del. Time 

Selecting Del. Time changes the Compare Quotations window to the delivery time 
comparison function. 

Quotations (Compare) – Price 

Selecting Price changes the Compare Quotations window to the price comparison 
function. 
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Quotations (Compare) – Split 

Selecting Split from the Options Menu displays the following window.  

 
This window is the same as the form splitting window used to split line items in 
Purchase/Forms/Line Items with the additional checkbox to ‘Use Quotation Prices’. 

Quotations – Select 

Selecting Select from the Options Menu displays the following window. Note that 
selecting both Quotation Prices and Vendor Prices 

 
Selecting a quotation means that you are approving the highlighted line for the basis of a 
purchase. Depending on a number of parameters several actions can be set to occur 
when you select a quotation including form type conversion, form status conversion and 
close quotation. See section 7.7.4for more information on parameters. 

6.1.3.5 Deliveries 
Deliveries are forms used to distribute goods in transit to remote locations such as ships. 
They can be seen as a form of temporary goods received note that will follow the stock 
items until they have been officially received at the ordering installation  

 
Deliveries can be added to a single transport document or may be split over several 
documents.  Once added to a transport document the delivery is classed as consolidated. 
Deliveries that have not been assigned to a transport document are classed as 
unconsolidated. 
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Deliveries – Options Menu 

Whilst viewing the Deliveries window, the Options Menu changes to the following: 

 
Deliveries – Line Items 

Selecting line items from the options menu displays the details of what is included in the 
delivery. 

 
Deliveries (Line Items) – Options Menu 

Whilst viewing the line items of a delivery, the Options Menu changes to the following: 

 
Deliveries (Line Items) – Fill Delivery 

Selecting the Fill Delivery option will cause the Quantity column of the Delivery Line 
Items window to fill with the purchased quantities. You can use this facility to quickly 
enter the line item quantities if you are certain that they are correct. This can be useful if 
there are many line items. 

Deliveries (Line Items) – Set ‘Located’… 

If you want to update the ‘Located’ field for multiple line items you should select the 
required lines and then use the following window to insert the desired information. 

 
Deliveries – View Transport Document 

Whilst adding deliveries to transport documents you can select View Transport 
Document from the Options menu to see the current status, such as weight, number of 
packages and total cost. Useful if you have a limit on the weight of the delivery due to 
transport constraints. 
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6.1.3.6 Vouchers 
Vouchers are the types of form that AMOS M&P uses to attach invoices or credit notes 
to purchase forms. When you select vouchers from the Purchase/Forms/Options menu 
the next available number is assigned to the voucher and the purchase form to which it 
belongs is listed in the window title bar. If the voucher is for the whole purchase form or 
it is the last in a number of forms you should check the ‘Final Invoice’ box.  

 
Vouchers – Options Menu 

Whilst viewing the Vouchers window, the Options Menu changes to the following: 

 
 

Vouchers – Line Items 

Each voucher contains the same line items as the purchase form to which it belongs. If 
you have several vouchers against a single purchase form, the quantity received to date 
will be updated each time a new voucher is created. This makes it easy to see when a 
final invoice should be created. 
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Vouchers – calculate Net Amount… 

If you want to add together the net amount of all line items on a voucher, select 
‘Calculate Net Amount’ from the Vouchers/Options menu and AMOS M&P will do the 
job for you and update the net value of the selected voucher with the resulting figure. 

 

6.1.3.7 Budget 
Select budget from the Options menu to view the budget details for the selected form. 

 
 

6.1.3.8 Note To Vendor 
This is a details screen intended for use with e-portals to send information to the vendor 
about the purchase form. 

6.1.3.9 Vendor’s Note 
This is a details screen intended for use with e-portals to receive information from the 
vendor about the purchase form. 
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6.1.3.10 Terms and Conditions 
This is a details screen intended for use with e-portals to receive the vendor’s terms and 
conditions regarding the purchase form. 

6.1.3.11 Change Approval… 
If you want to grant approval or revoke approval for a purchase form, select Change 
Approval from the Options menu. The condition of the following window depends on 
the existing approval state of the form. 

 

6.1.3.12 Receive… 
Selecting Receive from the Options menu opens the following window: 

 
If there are many items, and you believe that most of the order has arrived you should 
check the ‘Receiving the complete P.O. box’ to open the receive window with the totals 
already entered. You can alter the ones that are incorrect. If you do not  check this box, 
you will have to enter each total individually. 

 
Receive – Options Menu 

Whilst viewing the Receive window, the Options Menu changes to the following: 

 
Receive – Quality Check 

The Quality Check window allows you to make comments about the quality of goods 
received. There is a checkbox in the print forms window that allows you to print 
reclamation claims to send to the supplier. 
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The Quality Codes register is used to store the possible codes available in the drop down 
window. This register is described in section 3.1.12.6. 

 
Note that more than one quality check can be registered against each receipt if required. 

6.1.3.13 Convert… 
Selecting Convert from the Options Menu allows you to alter the form status and/or 
form type. The conversion can be carried out on a single form or on multiple forms if 
they are tagged. 

 

6.1.3.14 Estimate Cost… 
Selecting ‘Estimate Cost’ from the Options menu calculates the total value of the 
selected purchase form based on the quantities, prices and discounts for the line items of 
the form. 

 

6.1.3.15 Copy… 
If you want to copy a purchase form you can select ‘Copy’ from the Options menu and 
fill in the details shown below instead of having to type all the information in again. 
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6.2 Transport Documents 
Transport Documents are used to group goods that have come into a central location on 
different purchase forms that need to be forwarded to remote installations. A form with 
many line items may be split over several transport documents and a transport document 
may contain line items from several purchase forms. 

6.2.1 The Transport Documents Filter 
When you click on Purchase/Transport Documents the following filter will open. 

 
If you want to see all transport documents, click on OK otherwise enter some of the 
details to restrict the information retrieved. 

6.2.2 The Transport Documents Window 
The Transport Documents window is used to collate the information regarding shipment 
of goods from a central location to remote destinations. 

Installations that are expecting stock items can view the transport documents destined 
for delivery to see what will arrive, where it will be sent, when it will arrive and who the 
freight forwarder is. 

If you want to create a new transport document, click on the new button on  toolbar. The 
following window will appear: 

 
The document number of a transport document is not automatically generated so you 
can use your own numbering system to identify it. Enter as much information as 
possible to make the transport document easier to understand and to assist your remote 
locations to see when things will arrive. 
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6.2.3 The Transport Documents Options Menu 
Once the Transport Documents window has been opened, there is an Options menu 
added to the menu bar: 

 

6.2.3.1 Details 
The Details command from the Options menu opens the Full Description window for 
the selected transport document. This screen can be used for adding general information 
to a transport document and can also be used in conjunction with a pre-formatted 
template if required. 

6.2.3.2 Additional Info. 
The Additional Info. Screen is used to attach extra transportation details to the 
document. 

 

6.2.3.3 Consolidated Deliveries 
Consolidated deliveries are made up of purchase form line items that have been attached 
to Transport documents and are therefore accounted for. Unattached line items are 
classed as unconsolidated deliveries. 
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Consolidated Deliveries – Options Menu 

Whilst viewing the Consolidated Deliveries window, the Options Menu changes to the 
following: 

 
Consolidated Deliveries – Line Items 

Displays the line items that were included on the purchase form. 

 
Consolidated Deliveries (Line Items) – Options Menu 

Whilst viewing the Consolidated Deliveries – Line Items window, the Options Menu 
changes to the following: 

 
Consolidated Deliveries (Line Items) – Fill Delivery 

Selecting ‘Fill Delivery’ automatically inserts the purchased amount into the quantities 
column of all the line items in the delivery. 

Consolidated Deliveries (Line Items) – Set Located 

If you want to update the ‘Located’ field for multiple line items you should select the 
required lines and then use the following window to insert the desired information. 

 
Consolidated Deliveries – View Form 

This option displays the original purchase form for the selected delivery line item. 

Consolidated Deliveries – Remove 

This option removes the selected delivery line item from the transport document listed in 
‘Document No.’ and the line item becomes unconsolidated. 
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6.2.3.4 Unconsolidated Deliveries 
Unconsolidated deliveries are made up of purchase form line items that have not yet 
been attached to Transport documents. Attached line items are classed as consolidated 
deliveries. 

 
Unconsolidated Deliveries – Options Menu 

Whilst viewing the Unconsolidated Deliveries window, the Options Menu changes to 
the following: 

 
Unconsolidated Deliveries – Line Items 

Displays the line items that were included on the purchase form. 

 
Unconsolidated Deliveries (Line Items) – Options Menu 

Whilst viewing the Consolidated Deliveries – Line Items window, the Options Menu 
changes to the following: 
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Unconsolidated Deliveries (Line Items) – Fill Delivery 

Selecting ‘Fill Delivery’ automatically inserts the purchased amount into the quantities 
column of all the line items in the delivery. 

Unconsolidated Deliveries (Line Items) – Set Located 

If you want to update the ‘Located’ field for multiple line items you should select the 
required lines and then use the following window to insert the desired information. 

 
Unconsolidated Deliveries – View Form 

This option displays the original purchase form for the selected delivery line item. 

Unconsolidated Deliveries – Attach 

This option attaches the selected delivery line item to the transport document listed in 
‘Document No.’ and the line item becomes consolidated. 

6.2.3.5 Recalculate Totals 
When you have altered the contents of a transport document you can use the 
‘Recalculate Totals’ function to update the ‘Total Cost’ field which shows the 
transportation costs of the shipment. 

6.3 Contracts 
Contracts give you the option of specifying pre-arranged contract purchasing with your 
vendors. You can have one contract per vendor at any given point in time. 

Note that there are several registers for use within contracts called ’Delivery Terms’, 
’Payment Terms’ and ‘Delivery Locations’. These registers can be found in section 
3.1.14. 

The Contracts ‘General’ tab: 

 
The contracts ’General’ tab is used to set up the basic information for each contract. 
Most of the information to be entered is ‘free text’ except for where there are drop down 
windows or date fields.  
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The ’Template’ drop down window is used to attach user defined templates to the details 
screen visible through the Contracts/Options menu. 

The Contracts ‘Contract Items’ tab: 

 
The ‘Contract Items’ tab is where you can enter contract sub-sections. You create a new 
subsection using the buttons at the top right-hand side of the window. The details for the 
sub-sections are entered in the ‘Item Details’ tab in the lower half of the screen. 

The contract sub-section can have ‘Volume’ or ‘Flat Rate’ discount rates. If ‘Flat Rate’ 
is selected, you enter the amount of discount in the single box to the left. If ‘Volume’ is 
selected, you are then presented with the following window variation: 

 
Using the buttons at the bottom of the new window, you can add a variety of different 
discount rates for different quantities. 

 
The ‘Stock Links’ tab allows you to attach Stock Classes to the contract by using the 
buttons inside the ‘Stock Classes’ section of the window. Stock Types are added to the 
contract on the right hand side, again using the buttons within the section. The ‘View’ 
button takes you to the ‘Stock Items’ window of the selected stock number. 
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The Contracts ‘Delivery Locations’ tab: 

 
The Delivery Locations tab allows you to attach possible delivery locations to the entire 
contract using the buttons to the right of the window. There can also be positive or 
negative price factors included to account for additional delivery costs. 

When you use the ‘Generate Forms’ function, the application will select the cheapest 
contract option if the stock item is attached to more than one contract. If the chosen 
contract has more than one delivery location specified, you will be prompted to choose 
one by the following screen: 

 
The first field contains the number of the automatically selected contract. When you 
click the search icon, you will be presented with a list of all possible delivery locations 
attached to the contract. Choose one and click OK to proceed. The purchase form will 
now be issued against the contract. 
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7 The Tools Menu 

 
This chapter covers the commands in the Tools menu: 

7.1 Budget 
The budget functions in AMOS M&P are described in Chapter 6 of the AMOS M&P 
User Guide  

The Budget filter 

 
The Class drop-down list contains the three defined budget classes Purchase is for 

purchased items, and amounts are transferred from purchase orders. Stock is for the 
Spare Parts budget class, and amounts are transferred from Stock Transaction. The 
Maintenance class is for tracking resources spent on maintenance, and amounts are 
transferred from the maintenance log 

• 
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The Budget window 

 
 

The budget consists of a number of budget codes that are defined by the 
organisation. The text below explains the various available budget code options. As 
the screen picture above indicates, it is possible to scroll sideways in the Budget 
window. For example, a Warning column may be reached by scrolling all the way 
to the right using the scroll bar at the bottom of the window. To enter the Budget 
Overview window, double-click the desired budget code. 

• 

The Options menu for Budget 

 
Details 

The Details command from the Options menu in the Budget window opens the Full 
Description window, which may be used for a full text description of the selected budget 
code. If a default Budget Code layout is specified, the window will display this layout 
instead. 

Overview 

The Overview command from the Options menu in the Budget window opens the 
Budget Overview window for the selected budget code. The illustration below shows a 
budget code based on the Manually allocated budget model. 
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• The Warning field may be used to enter a percentage. When the specified warning 
level has been reached, red numbers will be displayed for the budget code. A value 
of 90% will produce a warning when 90% of the specified budget has been spent. 
A value of 110% will have the program displaying a warning when the budget 
code has been overspent by 10%. The warning will be displayed as an asterisk (*). 

• 

• 

• 

• 

• 

• 

The Revised field may be used to enter the date for a revision of a budget code. 
The By drop-down list may be used to specify who has made the revision. 

The Access drop-down list contains the two values Open and Restricted. If the 
latter is selected, only user groups to whom access has been granted may update 
the selected budget code. Access for user groups is described in section 7.7.2. 

The Budget Model drop down list contains three options. Different budget codes 
may be based on separate budget models. 

Budgeted amount is used to specify a sum for the entire year.  

Evenly allocated budget distributes the budget sum evenly over each period.  

Manually allocated budget makes it possible to enter the budget sum directly in 
the Budget Overview window, with separate amounts for each month of the budget 
year. 

Specification 

AMOS M&P contains optional functionality that allows an organisation to enter budget 
specifications for the budget codes. Three system parameters control this option, called 
Use Specification for Stock/Purchase/ Maintenance Budget respectively; see section 
7.7.4.5. If the parameters are set to TRUE, the corresponding budget specifications are 
used to update budget figures for the respective budget classes  

 
The Budget Specification window is used to add items that are to be charged to the 
selected budget code.  

• 
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Prognosis 

After the original budget has been established, it may be necessary to make adjustments 
to the budget. The Prognosis function makes it possible to create new, updated versions 
of the budget based on actual consumption and turnover. 

To enter the Budget Prognosis window, select a budget code and give the menu 
command Options/Prognosis. The following window opens: 

 
• A Prognosis budget is controlled by the same mechanisms as the regular budget: 

described in this section. For example, a budget code uses one of the three budget 
modes. These are Budgeted amount, Evenly allocated budget and Manually 
allocated budget. 

• If the Specification parameters have been set to TRUE, specifications amounts are 
used to calculate a budget prognosis. To do so, select the prognosis to work with 
and give the menu command Options/ Specification. Then enter a specification 
the way described above. 

• When working with prognoses, it is possible to copy the relevant specification 
from the previous versions. For the first prognosis created, data are copied from the 
budget code itself. For subsequent prognoses, data are copied from the previous 
version. To copy data, give the menu command Options/Copy Specification  

 
Recalculate 

The Recalculate command from the Options menu in the Budget window may be used 
to recalculate the budget at any time while working on the budget. The command brings 
up the following dialog box: 

 
It is possible to perform this operation for selected departments for a specified 
financial year and/or for a specific budget code. Click OK to have AMOS M&P 
perform the recalculation for the selections made.  

• 
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Convert 

A user with the sufficient access level can convert the status of one or more checked 
budget codes in the Budget window. The menu command Option/Convert enters this 
dialog box: 

 
A budget code is given the status Preliminary when it is created, typically at an 
early stage in the budget process. The status is the changed to Approved when this 
stage has been reached. If a budget code is to withdrawn from the budget on a 
temporary or permanent basis, the status can be changed to Parked. A budget 
Prognosis may not be changed once the status has been set to Approved. 

• 

• It is possible to change the status of multiple budget codes in the same operation by 
checking the desired budget codes. The command Select All from the Edit menu 
may be used to tag all of the budget codes in order to batch convert them. 

Copy 

In order to make it easier to create realistic budgets, AMOS M&P contains a function to 
copy budget information. Select Copy from the Options menu in the Budget window to 
enter this dialog box: 

 
The drop-down lists at the top of the dialog box are used to specify the source and 
destination for the copying operation. 

• 

• 

• 

The two drop-down lists in the frame Range to Copy may be used to specify a 
range of budget codes to be included. 

If the Copy budget figures box is checked, the field Adjust budget values by field 
becomes available. This may be used to insert a percentage value by which each 
amount in the target budget will be increased compared to the source budget. 
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7.2 Account Transactions 
If you have a license which includes the Accounting module, you will be able to access 
this menu option. This gives you the possibility to list selected transactions and alter 
them if unlocked. You can also generate manual transactions using this feature if you 
have the correct level of access control. Manually created transactions can be used to 
correct locked transactions that are incorrect. 

The Account Transactions filter allows you to search for individual transactions, all 
transactions recorded against a Cost Centre or Account Code or all transactions between 
two Transaction dates: 

 
As you can see from the window shown below, you can create Account Transactions 
connected to various documents. 
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7.3 Forecast 
The Forecast sub-menu contains commands for Stock and Workload analysis. These 
features can be used to obtain information for future stock and workload requirements. 
These forecasts can vary depending on input information. 

 

7.3.1 Stock Analysis 
The Stock Analysis filter allows the user to create stock forecasts for individual or 
multiple part numbers over a variable length of time. If the Simulate new orders field is 
ticked, the system will also forecast when to order replacement parts due to forecast 
usage. 

 
The Stock Forecast Analysis window looks like this: 

 
The top area of the window contains the part number, name, and stock control figures 
from the Stock Items Register window. There is an extra field called stocked forecast 
that is used to inform the user how many items are forecast to be available at the time of 
the analysis. 
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The first two columns on the left hand side contain the forecast transaction date and 
quantity. If the date is shaded grey then the transaction is forecasted usage, if shaded 
yellow then it is a suggested order. 

Further details for projected transactions are visible in the remaining columns marked In 
and Out. 

7.3.2 Workload Analysis 
The Workload Analysis filter allows the user to create workload forecasts for individual 
staff disciplines over a variable length of time and with a variable number of working 
days per week. 

 
The Workload Forecast Analysis window looks like this: 

 
The top row of the window contains the discipline type, whether the discipline is 
external or internal, hours available, forecasted workload and percentage of available 
hours required to fulfil the workload. 

The lower part of the window contains details of the forecasted workload.
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7.4 Reports 
The command Tools/Reports brings up the report browser that may be used to select 
pre-defined and user defined reports: 

 
The reports are structured in folders. To view the reports in a folder, simply click on it. 
When a folder is selected, the defined reports of that category are shown in the list on 
the right.  

To print a report, simply double-click the printer icon for the desired report. This brings 
up a dialog box containing controls that may be used to further specify what the report 
should contain. The box is different for each report. Here is an example from the report 
Stock Items Status: 

 
Once the dialog box has been used to specify the report parameters it is possible to 
click Print Preview to preview the report on the screen before it is printed. For 
example, the preview may look like this: 

• 
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• The Zoom toolbar button brings up a dialog box to select the zoom level. The four 
buttons to the right of the Zoom button may be used to browse the report pages: 
First Page, Previous Page, Next Page and Last Page. 

It is also possible to include user-defined reports in the hierarchy. This means that 
the user may see more reports than the standard ones. Such user-defined reports are 
printed the same way as standard reports. Appendix A of this reference manual 
contains a description of how user defined reports may be added to the report 
hierarchy, and how layouts and reports may be defined and modified in 
PowerBuilder or InfoMaker. 

• 

The table below lists the pre-defined reports that are installed with AMOS M&P. 
Report Category Reports 

Stock Items Stock Items – Above Stock Max 
Stock Items – Below Stock Min 
Stock Items – Details 
Stock Items – Inventory Control 
Stock Items – List by number 
Stock Items – Most Used 
Stock Items – Not Used 
Stock Items – Order By Cost 
Stock Items – Order By Location 
Stock Items – Order By Vendor 
Stock Items – Reorder 
Stock Items – Status 
Stock Items – Transactions 
Stock Items – Value 

History Reports History – Details 
History – Details Archive 
History – List 
History – List Archive 
History – List Order by Discipline 

Forms and Requisitions Form List order by Type 
Purchase Order Form List Ind. Currency 
Purchase Order Form Expediting 
Purchase Order Form List Base Currency 
Query Form List 
Requisition Form List 
Wanted Stock Items 

Address Reports Addresses – Code 
Addresses – Full Detail 
Addresses – Labels 
Addresses – Name 
Addresses – Not Used 
Addresses – QA Graded 

Employee Reports Employees – Address List 
Employees – Full Detail 
Employees – List by Code 

Component Reports 
 
 
 
 
 
 
 
 
 
 

Components – 
Components – (Required) 
Components – Availability 
Components – Class Code 
Components – Class Code (Required) 
Components – Class Code Order by Location 
Components – Code 
Components – Details 
Components – Information Status 
Components – Jobs 
Components – Maker 
Components – Name 
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Component Reports Components – Order by Condition Status 
Components – Parts 
Components – Parts Order by Location 
Components – Rounds 
Components – Rounds Included 
Components – Rounds Not Included 
Components – Run Time List 
Components – Serial No. 
Components – Serial No. Order by Location 
Components – Type 
Components – Vendor 

Jobs Jobs attached to components – Details 
Jobs attached to components – List by code 
Jobs description – List 

Budget Reports Budget Codes – Details 
Budget Codes – Graph 
Budget Codes – List 

Transport Documents Transport Document Details 
Transport Document List 
Transport Documents by Forwarding Date 
Transport Documents by Received Date 

Maintenance Reports Equipment Spares Consumption 
Equipment Spares Consumption Archive 
Equipment Types – Most Failures 
Equipment Types – Most Failures Archive 
Function Availability 
History Totals 
History Totals Archive 
Maintenance by Counter Left 
Maintenance Done 
Maintenance Done Archive 
Maintenance Expenses 
Maintenance Expenses – Discipline 
Maintenance Expenses Archive 
Maintenance Expenses Archive – Discipline 
Rescheduled Jobs 
Survey Due by Date Due 
Survey Due by Misc 2 
Trend Maintenance Costs (Hours) 
Trend Maintenance Costs Archive (Hours) 
Trend Mean Down Time 
Trend Mean Down Time Archive 
Trend Mean Time to Repair 
Trend Mean Time to Repair Archive 
Trend Misc. Expenses 
Trend Misc. Expenses Archive 
Trend Number of Failures 
Trend Number of Failures Archive 
Trend Total Down Time 
Trend Total Down Time Archive 
Trend Total Time to Repair 
Trend Total Time to Repair Archive 
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7.5 Select View 
This option is to allow the user to quickly switch between alternative screen set ups 
using the new user interface. It can also be reached by pressing the F6 key on the top 
row of the keyboard. 

 
See section 7.10 for instructions on how to set up the different Views and for further 
details on the ‘Outlook’ style interface. 

7.6 Hand Terminal Interface 
In order for AMOS M&P to support several standards, a general file format has been 
developed. In order for AMOS M&P to support all the hand terminal formats that exist, 
a converter application has to be written. One such application is already developed, and 
its source code is available for developers. 

 
When the Hand Terminal Interface command has been selected from the Tools menu, 
the dialogue box shown above is presented. The Select Department button may be 
clicked to select the department, and the Select Hand Terminal File to select the file to 
import. It is possible to set the default directory for Hand Terminal Files – see section 
7.7.4.4. Once the desired file has been selected, click the Read Hand File button to start 
the import of data from the selected file. 
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File format 

The supported file format is fairly simple. Hereafter called HTD, it is somewhat similar 
to the .Ini file format found on the Windows platform. 

In general, the file format syntax is like this: 

[Section] 
Variable = Value 

The first section in the HTD file is the header, which tells AMOS M&P what version 
and the number of the transaction that is expected to be found in the .Htd file. 

[Header] 
Version=1 
Transaction=X 

This states that the .Htd file is version 1, which is the only format AMOS M&P 
currently supports. 

The Transaction number is important. This tells how many Transaction sections that are 
to be found in the .Htd file. 

[TransactionX] 
PartNo=< Alfa-numeric value > 
Type=< in (O, I, C) > 
Date=<YYYY-MM-DD> 
Quantity=<Numeric value> 

O = out of stock 
I = insert into stock 
C = Stock Count 

The date format must be in the given format. 

File Sample 

[Header] 
Version=1 
Transactions=2 

[Transaction1] 
PartNo=AE-100-001              
Type=O 
Date=1998-02-24 
Quantity=1 

[Transaction2] 
PartNo=AE-100-003              
Type=I 
Date=1998-02-24 
Quantity=12 

Hand terminal interface application 

This application takes two arguments, Directory and Filename. 

The directory tells the application where it should store the .Htd file, the filename tells 
the application what name it should give the .Htd file. If a directory is not specified, the 
current directory is used. If no filename is specified, Updates.htd is used. 

This application assumes that the hand terminal is connected to the keyboard input port 
of the PC. When the Read from Hand Terminal command button is clicked, keyboard 
polling starts. Polling is simply done by putting the keyboard input focus into a hidden 
single line edit control, and by adding code to the keyup event of that window. 

The polling may be terminated by clicking either the Stop or Close command button. 
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The polling is automatically stopped when the hand terminal unit has sent the 
Termination sequence and an .Htd file is stored with the given name in the given 
directory. 

 
It is possible to verify that the correct data is transmitted by inspecting the window 
control at the bottom of the window ( DataWindow ). 

AMOS M&P interface 

The interface is found in the Tools/Hand Terminal Interface menu command, which 
present the user with the following dialog box:  

 
Pre-set values are set for the user convenience, which the user may change. The user is 
allowed to select a different department. The current department is selected by default. 
The user is able to select an .Htd file. Updates.htd is selected as default, assumed to be 
found in the Installation Directory. 

By clicking on the Read Hand Terminal File command button, the file is read and the 
database is updated accordingly. The user will be presented with error messages if any 
error occurs. All changes in the database will then be undone.
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7.7 Configuration 
The Configuration sub-menu contains commands that give access to windows used to 
configure AMOS M&P: 

 

7.7.1 Users 
When a user logs into AMOS M&P, a database user called AMOS is automatically used 
behind the scene. This is done in order to access the table of application users to check 
that the user logging in is indeed a user with a valid password 

Each AMOS M&P user is given a user ID and a password, which are validated at login. 
Furthermore, it is possible to create user groups, and access to the various functions in 
the application is determined by the user group. For example, access to user-defined 
reports may be granted only to users belonging to a specific group, which is explained in 
section 7.7.2. 

The Users filter 
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The Users window 

 
To create a new user, click the New button and fill in the various fields. The entry 
in the Password field is not displayed in open text. 

• 

• 

• 

• 

The Employee drop-down list will display the contents of the Employees register 
described in section 3.1.5. 

The upper right area shows the groups that the selected user is a member of. A user 
may be a member of multiple groups. Please note that it is not possible to check or 
uncheck the Active box in the Users dialog box; this must be done from the Groups 
window described in the next section. 

If a user has ‘Locked Out’ their account the disabled checkbox will be checked, to 
enable the account uncheck the box. The disabled checkbox can also be used to 
disable the highlighted user if required by checking it. 

The Options menu for Users 

 
Move User References 

There is a corresponding toolbar button for this command. In previous versions of 
AMOS M&P, users were registered by department. This has been changed, and users are 
currently connected to one or more groups. 

This facility may be used to “clean up” a database. Select the user that is to be removed, 
and click on the toolbar button or give the command from the Options menu. From the 
dialog box, select the user to which the references are to be moved: 

 
Once the references have been moved, the user may be deleted. 
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Change Password 

The change password function opens the following window.  

 
The old password will be masked for security reasons . The new password must be typed 
into both of the lower boxes in order to change the existing password. 

Depending on how the parameters affecting passwords have been setup, you may 
encounter one of the following error messages when attempting to change a password. 

  
Either comply with the instructions in the error messages or alter the respective 
parameters described in section 7.7.4.5. 

Mailbox Access 

The mailbox access feature works in conjunction with the workflow module and is used 
to add multiple users to group or departmental mailboxes. 

7.7.2 Groups 
Defined users may belong to one or more user groups, and access to various AMOS 
M&P modules and functions may be set separately for each user group. A user group 
may be granted access to a selected department. 

The Tools/Configuration/Groups command gives access to the Groups window: 

 
• The Approval Limit field contains a drop-down list with the defined values in the 

Approval Limit register (see section 7.7.3). 

• If the Global Access field is checked for the selected group, it has access to all 
defined installations and departments. When checked, the Options/Department 
Access command is not available. 

The Options menu for Groups 
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Members 

The Members window is used to specify the members of the selected user group: 

 
Click New to add a new member, and click the Search button (the one with the 
magnifying glass) to see the list of defined users to select one. Once a user has 
been added to a group, the access may be temporarily restricted by removing the 
check mark in the Active field. 

• 

Access Control 

 
Actual access to AMOS M&P functions and modules is set for various user groups. To 
determine the level of access for a specific user group, make sure the group is selected in 
the Groups window, and give the command Options/Access Control or click the 
corresponding toolbar button to enter this window: 

• In the Access Control window, there are five tab cards: Registers, fields, Functions, 
Reports/Modules, and Combined. 

• There are several toolbar buttons that may be used to work in the Access Control 
window. The first two are Select All and Deselect All, and the third is Invert 
Selection. The fourth button in the picture below is called Copy from Group. When 
this is clicked, the list of defined groups is presented. Click the group to copy from 
and click OK. There is a corresponding Copy from Group command in the 
Options menu. 

• On the Registers tab card, there is an alphabetical list of the various registers of 
AMOS M&P. For each register, it is possible to specify which types of access the 
selected group has. The four access types are Read, Edit, Insert and Delete. 

• The Fields tab card contains check boxes that decide whether the selected user 
group has access to the fields listed. 

• The Functions tab card contains check boxes that may be used to indicate whether 
the selected user group is allowed to execute a specific function or not. 

• The Reports/Modules tab card is used to specify which reports the selected group 
has access to. 

• The Combined tab card combines the access levels and the right to execute 
functions. For example, all the five boxes are typically checked for the line 
Complete System in order to grant the System Administration group all the 
necessary rights. 
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Access Control Personnel 

This option (if visible) is to grant access to the various parts of the AMOS Express 
personnel module when used in an integrated system with AMOS M&P 

Job Class Access 

Defined user groups may be granted access to specific job classes. To do so, make sure 
the correct group is selected in the Groups window, and give the command Options/Job 
Class Access or click the corresponding toolbar button to enter this window: 

 
When a new item is added to this window (click the New toolbar button), the 

drop-down list will display the defined job classes. The selected user group may 
have access to multiple job classes. 

• 

Stock Class Access 

Defined user groups may be granted access to specific stock classes. To do so, make 
sure the correct group is selected in the Groups window, and give the command 
Options/Stock Class Access to enter this window: 

 
When a new item is added to this window (click the New toolbar button), the 

drop-down list will display the defined stock classes. The selected user group may 
have access to multiple stock classes. 

• 

Cost Centre Access 

This option (if visible) is part of the accounting module for AMOS M&P. You must use 
this window to add the cost centres that you want each group of users to be able to 
access. 

Department Access 

A user group, which has not been granted Global Access, may be granted access to one 
or more departments. To grant such access, make sure the correct group is selected in 
the Groups window and select Department Access from the Options menu to enter the 
following window: 
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To grant access to multiple departments, click the New toolbar button and select an 
additional department from the list. 

 

7.7.3 Approval Limits 
It is possible to define a set of Approval Limits to define the maximum amount a given 
group is allowed to approve. The limits are defined in the selected Base Currency Code. 

The command Tools/Configuration/Approval Limits gives access to the following 
window: 

 
• The Approval Limits are automatically sorted in ascending order the next time the 

window is opened. 

7.7.4 Parameters 
When the Parameters command is selected, the user is presented with the following 
screen: 

 
The above screen shows the System Administrator view. This view gives the user access 
to all areas of the system.  User with lower levels of access will not have such great 
levels of access.  In order to understand the implications of this, it is necessary to first 
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understand the issues of hierarchy and scope. 

AMOS M&P has a hierarchical view of an installation and is based on the fact that the 
system has been programmed to handle corporate entities as well as partnered 
organisations. The layers of this hierarchy correspond to the physical and operational 
divisions within the organisation itself. 

A company is seen as comprising one or more Installations. Now whether these 
represent factories, office sites, offshore platforms or ships, the defining factor is that 
they are often geographically separated entities within the same organisation. Each is 
individually responsible for its own operations and technical administration.  

Each Installation is in turn made up of one or more departments. For example, a ship 
could be divided into departments like Engine Deck and Safety while a production plant 
might have Production and Transport departments. Here the division typically represents 
groups at the same site who are separate cost centres and therefore are responsible for 
their own maintenance expenses. 

Alternatively, they may work with different sets of equipment, like, production versus 
transportation machinery. On the other hand, they may, for any number of other reasons, 
require specific follow-up or budgeting. 

AMOS M&P is designed to handle the requirement for installation and departmental 
separation, allowing the system to cater to each groups needs, like special component 
number schemes or division of stock information.  

The configuration parameters have therefore been given a scope within which they 
apply. This scope can be either: 

For a single department • 

• 

• 

For all departments in a single installation 

For the entire organisation 

In addition to providing scope, this hierarchy also provides for the inheritance of 
parameters. Therefore, if the system does not find a particular parameter setting for the 
current department, it automatically looks up the hierarchy to the installation directly 
over the department in the hierarchy. If no specific parameter value has been set for the 
installation, then the system will look for and use the value that has been set at the 
global level. 

It is therefore a simple matter to handle exceptions in the system, like a different 
component numbering scheme for a particular department. The system administrator 
needs simply first define the numbering scheme at the global level for the whole 
company, and then define a specific one for that department in question. 
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7.7.4.1 The Parameters Interface 

 
The Parameters interface contains the control room for AMOS M&P and changes made 
here have deep consequences for the way that the system is run.  It is worth taking time 
to familiarise yourself thoroughly with the logic behind and consequences of changes 
made in this section.  The following sections give you a basic idea of each of the 
parameters, but due to the complexity of the possible combination of results, it is not 
practical to document every single parameter fully. 
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You should also be aware that some pre-set options do not show their apparent setting in 
the ‘Value’ field. This is because the value field shows a database field, as opposed to its 
intended function name.  This is illustrated in the example below, where the ‘Value’ 
setting of  ‘DETAIL’ corresponds in reality to ‘Work Order.’ 

 

7.7.4.2 Auto-Numbering 

 
This set of parameters can be divided into two types: Masks and Rules. Masks are used 
to control how certain fields are displayed by the system, and which characters may be 
typed when entering information into these fields (e.g. input mask).  Rules are used to 
control the format of the system-generated numbers. 

In some cases, only a Mask may be defined, as with the definition of the appearance of 
component numbers. Other numbers allow the definition of both a Mask and a Rule, as 
is the case of work order numbers – the rule controls how the number is generated by the 
system, while the mask controls how the number is presented. 

In the Mask fields, the following characters can be used to control which characters are 
valid for each position in the number: 

! - Any alphabetic character - automatically uppercased by the system. • 

• 

• 

• 

• 

^ - Any alphabetic character - automatically lowercased by the system. 

A - Any alphanumeric character. 

X - Any character 

# - Any numeric character 

Any other character appearing in the mask will be displayed in the input field as un-
modifiable positions. 

The work order, purchase form and transport document numbers have both a mask and 
rule as they are system generated numbers which can have their appearance controlled 
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Please note that in the example above, the field Form Number Mask ends with two X-es 
to facilitate the entry of form numbers that have been split by AMOS M&P. For 
example, a purchase order may be split into two or more sub-forms, and in that case, 
AMOS M&P adds the character A to the form number. The two X-es in the Form 
Number Mask allow the user to enter this modified number. 

Creating new rules 

AMOS M&P offers help in generating new auto-numbering rules for the relevant fields. 
When a search button next to a Rule field is clicked, a new window is opened for that 
Rule field. For example, the Form Number Rule window looks like this: 

 
To start building a rule, click on one of the Functions on the left. The lengths of the 
functions are pre-defined, and cannot be changed. Several functions may be used in 
the same rule. Once a function has been selected, the grey field in the upper part of 
the window displays the selected function. 

• 

• 

• 

• 

The Format field makes it possible to specify whether the numbers should be 
preceded by zeroes or not. The expression at the top of the window will show 0 if 
Leading zeroes has been selected, and # if Leading blanks is used. If the wrong 
format is shown for a function, click the function again to remove it from the 
expression, select the desired format, and click the function once more to re-insert 
it in the expression. 

The second half of the expression consists of values from the listed Columns. For 
these, it is possible to specify a Length from the field. The length should be 
specified before the Column name is clicked. 

Once the rule has been entered, it possible to click the Test button to see how the 
rule will work. 

 
The defined Rule will be displayed according to the Mask defined for the field for 
which the Rule is being created. 

• 

If the Rule does not produce the intended result, it is possible to click the Clear Last 
button to remove the last part of the expression under construction, or click the Clear All 
button to start fresh to rebuild it. 
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7.7.4.3 Default Templates 
A number of tables in the system contain a memo field otherwise known as the detail 
page or full-page description. These memo fields are present in the component stock 
item, address, job description and order form tables among others.  

AMOS M&P provides a feature called Templates (also called Layouts), which makes it 
possible to define how the memo field should be presented onscreen. Using templates, 
the memo field can be given the appearance of a specialised input form. These templates 
are usually attached to the memo field by using the Edit/Change Template menu 
command. However, a template may be attached to a memo field automatically on 
creation of a new table entry, and these parameters make that possible. 

The parameter screen contains an entry for each table containing a memo field, and 
makes it possible to select from the already defined template list which template is to be 
used for each register Appendix A describes how new layouts may be created in 
PowerBuilder. 

The default settings for all these fields are Empty. 

7.7.4.4 Directories  

 
A number of important directories for the system are defined here. 

CBM Directory 

Defines the location where CBM day files are to be found by the system. The use of 
Condition Based Maintenance is covered in Appendix B. 

Default setting: Empty. 

Graphics Directory 

Defines where graphic files are located.  If this parameter is not set correctly, it can 
cause problems when you try to display graphic files on the screen. 

Default setting: Empty. 

Hand Terminal Directory 

Defines where files generated by hand terminals are stored. This function is described in 
section 7.6. 

Default setting: Empty. 
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Installation Directory 

Defines where the system itself is installed.  If this parameter is not set correctly, it can 
cause problems with the Import/Export module. 

Default setting: Empty. 

Report Directory 

AMOS M&P allows you to tailor the appearance of the standard work order, planned 
maintenance work order, purchase order, requisition form, query and transport document 
printouts.  This parameter defines the directory where these tailored reports are located. 

Default setting: Empty. 

Transfer Directory 

Defines the location where selection files and import files are to be found, and where 
generated export files are to be placed. 

Default setting: Empty. 

7.7.4.5 Options 
This is the most general category of parameters, and contains a variety of switches and 
values varying from file extensions for the Import/Export module to whether 
maintenance is to reported back at the employee level or at the group (or discipline) 
level.  

Budget 
Budget at Line Item Level 

This parameter has four possible values: 

• Never 

• Seldom 

• Often  

• Always 

If Never is selected, there will be no Budget at Line Item Level check box in the Forms 
window. If it is set to Seldom, there is an un-checked box, while the box is checked if 
Often is selected. If the Always option is selected, there is no option in the Forms 
window, since the option is always used. 

Default setting: Never. 

Financial Year Early Start 

This parameter can be set to true to allow for the early start of the financial year. Many 
US companies start their financial year in October. 

Default setting: False 

Month-End Close Period (Days) 

This parameter may be used to specify when monthly accounts are closed. For example, 
a value of 5 means that the accounts are closed 5 days before the end of the month. 

Default setting: 0. 

Start Date For Financial Year 

This parameter allows the start of the financial year to be set according to varying 
worldwide practices:  e.g., the UK starts its financial year on April 6th and France on 
January 1st. Once this date is set, it can be very complicated to change.  

Default Setting:  January 1st 
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Track Maintenance Expenses 

This system switch controls the activation of the tracking of maintenance expenses by 
the Budget module. 

Default setting: TRUE. 

Track Purchase Expenses 

When set to TRUE, this parameter activates the tracking of purchase expenses by the 
Budget module.  If tracking is turned on, the system will check that budget codes 
entered are valid. It will automatically register financial transactions against the 
specified budget and will signal the user in the case a budget is exceeded by a pre-
determined warning value. 

Default setting: TRUE. 

Track Stock Expenses 

Similar to the previous parameter, this system switch controls the activation of the 
tracking of stock/inventory expenses by the Budget module. 

Default setting: TRUE. 

Use Specification for Purchase Budget 

This parameter allows you to specify whether Specifications are to be used to update 
budget figures for the Purchase budget class. 

Default setting: FALSE. 

Use Specification for Stock Budget 

This parameter allows you to specify whether Specifications are to be used to update 
budget figures for the Stock budget class. 

Default setting: FALSE. 

Use Specifications for Maintenance Budget 

This parameter allows you to specify whether Specifications are to be used to update 
budget figures for the Maintenance budget class. 

Default setting: FALSE. 

Use Voucher to Update Budget 

This parameter lets you specify whether vouchers can be used to update the budget. 

Default setting: TRUE. 

General 
Column Width – Truncate Column Width To Version 

This parameter is used to ensure column width compatibility through various versions of 
AMOS M&P and should be set to the lowest version that your organisation is using. The 
default options here will vary depending on the software version number. 

Note: It is important that all your installations of AMOS M&P are of a compatible 
version to ensure that there are no replication errors due to different column widths. 

Default Settings – Budget Code Status 

This parameter controls the initial setting for a new budget in general.  The default 
setting is ‘3.’  The figures correspond to the following: 

1 Parked 

2 Preliminary 

3 Approved 
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Default Settings – CBM Work Order Status 

When the CBM (Condition Based Maintenance) module is active, this setting controls 
the Initial Status of Work Orders.  The default setting is ‘6.’  The figures correspond to 
the following: 

1 Requested 

2 Planned 

6 Issued 

Default Settings – Depreciation Level 

When the Depreciation feature is activated, this setting controls the initial status of Stock 
Items. The default setting is ‘1,’ which corresponds to level 1, which is normally ‘new,’ 
or 0% depreciation. Up to 5 levels of depreciation can be set. 

Default Settings – Form Type 

A Purchasing module parameter, this value controls which type of form is to be created 
(i.e. requisition form, query or purchase order) during automatic form creation.  In a 
shipping scenario, it is normally the case that vessels create requisition forms while 
shore side offices create purchase orders. Default setting: Purchase Order. 

Default Settings – Location for Stock Items 

It is possible to define and use multiple stock item locations. If several locations have 
been defined in the Locations hierarchy, one can be defined as the default location, 
automatically attached to each newly created stock item. 

Default setting: Empty. 

Default Settings – Output Format for new Job Related to Components 

One of three output formats may be selected in AMOS M&P List, Compact List and 
Detailed. List gives only one line per selected job Compact list gives a few lines 
containing the most important information, while Detailed contains the full job 
description 

Default setting: COMPACT LIST. 

Default Settings – Output Format for new Rounds 

One of three output formats may be selected in AMOS M&P: List, Compact List and 
Detailed. List gives only one line per selected job, Compact list gives a few lines 
containing the most important information, while Detailed contains the full job 
description. 

Default setting: COMPACT LIST. 

Default Settings – Output Format for Work Requisitions 

One of three output formats may be selected in AMOS M&P: List, Compact List and 
Detailed. List gives only one line per selected job, Compact list gives a few lines 
containing the most important information, while Detailed contains the full job 
description. 

Default setting: DETAILED. 

Default Settings – Periodic Work Order Status 

This is used to set the initial status of automatically created periodic work orders. 

Default setting: Requested. 

Default Settings – Priority for new Job Related to Components 

A job can be given a priority of up to three digits, and the organisation may decide 
which priorities they wish to assign. 

Default setting: 5. 

Default Settings – Priority for new Rounds 
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A round can be given a priority of up to three digits, and the organisation may decide 
which priorities they wish to assign. 

Default setting: 5. 

Default Settings – Priority for Work Requisitions 

A round can be given a priority of up to three digits, and the organisation may decide 
which priorities they wish to assign. 

Default setting: 4. 

Default Settings – Requisition Work Order Status 

This is used to set the initial status of manually created work orders. 

Default setting: Requested. 

Default Settings – Round Work Order Status 

This is used to set the initial status of automatically generated round work orders.   

Default setting: Requested. 

Default Settings – Status for New Components 

This field is used to set the status of new components introduced in the system. The 
possible options are: (None), In Use, Available, Repair, Scrapped and Transferred. 

Default setting: Available. 

File Extensions 

These four settings allow you to set the DOS file extensions used in AMOS M&P. 

The default settings are as follows: 
EXP – Export Files, Import Files 
HTD – Hand Terminal Files 
OK – Successfully Imported Files 

File Extension for Export Files 

The system maintains a sequence number for both import and export operations.  Since 
these sequence numbers are used to name the files created by these operations, it is 
important to be able to differentiate between files created by export and ready for 
transfer to another site and those received which are ready to be imported.  This is done 
by defining different file extensions for the various files handled by the Import/Export 
module. 

This parameter defines the extension for export files generated by the system. 

Default setting: EXP. 

File Extension for Hand Terminal Files 

A hand terminal may be used to record stock transactions. The data from the hand 
terminal may be exported in the form of a file, which may then be imported to AMOS 
M&P stock levels. This parameter specifies the file extension for such hand terminal 
files. 

Default setting: HTD. 

File Extension for Import Files 

As a complementary parameter to the parameter File Extension for Export Files, this 
value defines which extension identifies files ready to be imported by the system. 

Default setting: EXP. 

File Extension for successfully Imported Files 

As a complementary parameter to the previous one, this value defines which extension is 
to be given to import files that have been successfully imported by the system. 

Default setting: OK. 
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Account Lockout Threshold 

This parameter determines the number of unsuccessful log-in attempts a user can make 
before being locked out of the application. If the parameter is set to zero the lockout 
system will be disabled. A positive number above zero should be entered if you want to 
use this feature. If you are using this feature you will be informed of the number of any 
unsuccessful log-on attempts that have been made against your user name once you log-
on successfully. 

Default setting: 0 

Ask User to Confirm Deletions 

When this parameter is set to TRUE, the user is asked to confirm the deletion of a 
record. If set to FALSE, no question is asked, and the record will be deleted when Save 
is selected.  

Default setting: TRUE. 

Base Currency Code 

AMOS M&P makes it possible define a base currency at the global, installation and 
department level. At the global level, this value determines the base against which 
Current Rates are recorded. In addition, it is also possible to define the default currency 
to be used when recording transactions and presenting reports for the various 
installations and departments 

Default setting: USD. 

Note: If sites are to exchange information from the currency rates table then it is necessary for 
them to have the same global base currency defined. 

Create Component Archive On Transfer In 

This parameter when TRUE allows the creation of Archive tables in receiving 
installations in order for the recipients to view component information created in 
previous installations. Options are TRUE or FALSE. 

Default setting: Empty (no value selected) 

N.B. This parameter should be set to the same value as the ‘Delete Component Archive 
On Transfer Out’ parameter. 

Current Installation 

This is one of the most important parameters in the system. All database entries in the 
system are stamped with unique internal numbers. These numbers are built up of two 
parts the installation number and a running counter. The installation number ensures that 
no two sites can generate the same internal number. The Current Installation parameter 
is used to define the Installation id part of the internal numbers. 

Note that once a Current Installation number has been defined and data is entered into 
the database, no other installation can ever be assigned that number as this would lead to 
duplicate internal numbers. In addition, once an installation is assigned its Current 
Installation number then this value should not be changed. This does not restrict the user 
from changing the id of the Installation as it appears in the Installation list, since this is 
only simple a visible identifier for this installation within the organisation. 

Default setting: 001. 

Delete Component Archive On Transfer Out 

This parameter when TRUE allows the deletion of Archive tables in donating 
installations when the component is transferred out. Options are TRUE or FALSE. 

Default setting: Empty (no value selected) 

N.B. This parameter should be set to the same value as the ‘Create Component Archive 
On Transfer In’ parameter. 

Editor Font 
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This parameter controls the display font for all ‘details’ screens.  It is also reflected in 
printouts of these screens. Click on the magnifying glass icon to access the font selection 
window. Choose the type, style and size of the font you require and click ok to select. 

Fonts can be implemented at a Global, Installation or Departmental level. 

Default setting:  none (system displays Arial.) 

Enforce Password History 

This parameter controls how many previously used passwords for each user are retained 
in the system. When you are prompted to change your password, controlled by the 
‘Maximum Password Age’ parameter, you must enter a password that does not match 
one of the previously used passwords stored in the database. This also applies to the 
manual ‘Change Password’ feature covered in section 7.8. Setting this parameter to zero 
will disable this feature. 

Default setting: 0 

Hand Terminal Reader 

This option may be used to specify the interface program that is used to transfer data 
from a hand terminal to AMOS M&P. This function is described in section 7.6. 

Default setting: Empty. 

Hide Inaccessible Menu Entries 

This parameter prevents menu items that are not available to a user, due to his belonging 
to a group that does not have access to this function, from displaying.  If this parameter 
is left as ‘FALSE,’ unavailable menu items will continue to appear greyed out. 

Default setting: FALSE 

Logo Bitmap Used In Report Printout 

If you want to include your company logo on printed reports you should use this 
parameter to navigate to the file you want to use. The supported file types are: 
.bmp   .gif   .jpg   .jpeg   .rle   .wmf 

Default setting: Empty 

Maximum Password Age 

This parameter determines the maximum allowed age, in number of days, of all 
passwords. This feature is disabled if the value is set to zero. 

Default setting: 0 

Minimum Password Length 

This parameter determines the minimum allowed length, in number of characters, of all 
passwords. This feature is disabled if the value is set to zero. 

Default setting: 0 

Open Image In New Window 

This parameter determines how a new image is displayed when an image hotspot has 
been clicked. If the value is set to FALSE, a new image will be opened in the currently 
open window, and replace the image which is there. When the value is set to TRUE, a 
new image will be opened in a separate window. This functionality is parallel to the one 
found in the My Computer program in Windows 95. 

Default setting: FALSE. 

Printer Task to Use When Printing Labels 

This parameter is used to select a Printer Task to use when printing labels from the 
Stock Items window. 

Default setting: NONE. 
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Reload DDDW When Opened 

DDDW stands for Drop-Down Data Window, which in plain English are the drop-down 
lists of currency codes, disciplines units job classes etc. present in the system. The 
contents of these drop-down lists in a window or dialog box are built when the window 
or dialog opens up, and are not rebuilt unless the window is closed and reopened.  As a 
result, newly added items to the drop-down tables do not appear in a list until the 
window containing this list is closed and reopened. 

By setting this parameter to TRUE, the system will rebuild drop-down lists each time 
the list itself is opened by clicking on the drop-down arrow.  Please note that this will 
slow down display of the list, but guarantee that the list is at all times complete. 

Default setting: TRUE. 

Show Error Messages During Portal Import 

This parameter, if set to FALSE, allows Portal Import to continue uninterrupted in the 
event of errors occuring during import. Any errors encountered are written to the portal 
log and can be viewed later. If the parameter is set to TRUE you will receive an error 
message each time an import error occurs and further data import will be stopped until 
the error message is cleared by the user. 

Default setting: FALSE 

Single Window Instance 

This parameter controls whether or not you can have the same data window open several 
times. If set to true, a data window such as Components or Work Orders will only be 
allowed to open once. Any attempts to open the same window again will not work. If 
you want to view different information within the same window you can use the filter 
command to do so. 

Default setting: FALSE 

Start In Department 

This parameter allows you to control which department the system logs automatically 
into when you start the system. When setting this parameter, you can select from a list of 
the defined departments. 

Default setting: 001/01. 

Store Imported XML Document In Portal Log 

This parameter, when set to TRUE, allows you to see the imported XML document 
associated with the selected error message in the Portal Log, accessed via the Options 
menu. If set to FALSE, there will be no Options menu available and no XML documents 
will be stored. 

Default setting: FALSE 

Use Component Types 

This parameter may be set to TRUE when the Component Types function is used in an 
organisation. This functionality makes it possible to define types of components at the 
head office. All components used at the various sites may then be assigned to the correct 
component type and data about the component type is automatically inherited. 

Default setting: FALSE. 

Use Stock Types 

This parameter may be set to TRUE when the Stock Types function is used in an 
organisation. This functionality makes it possible to define types of stock at the head 
office. All stock used at the various sites may then be assigned to the correct stock type, 
and data about the stock type is automatically inherited. 

Default setting: FALSE. 
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Maintenance 
Auto-File Completed CBM Work Order 

If this value is set to TRUE, CBM work orders are filed automatically when the status is 
set to Completed. If the value is set to FALSE, it is necessary to manually file such work 
orders. 

Default setting: FALSE. 

Auto-File Completed Periodic Work Order 

If this value is set to TRUE, automatically generated periodic work orders are filed auto-
matically when the status is set to Completed. If the value is set to FALSE, it is 
necessary to manually file such work orders. 

Default setting: FALSE. 

Auto-File Completed Requisition Work Order 

If this value is set to TRUE, manually requisitioned work orders are filed automatically 
when the status is set to Completed. If the value is set to FALSE, it is necessary to 
manually file such work orders. 

Default setting: FALSE. 

Auto-File Completed Round Work Order 

If this value is set to TRUE, automatically generated work orders are filed automatically 
when the status is set to Completed. If the value is set to FALSE, it is necessary to 
manually file such work orders. 

Default setting: FALSE. 

Auto-File Controlled CBM Work Order 

If this value is set to TRUE, CBM work orders are filed automatically when the status is 
set to Controlled. If the value is set to FALSE, it is necessary to manually file such work 
orders. 

Default setting: FALSE. 

Auto-File Controlled Periodic Work Order 

If this value is set to TRUE, automatically generated periodic work orders are filed 
automatically when the status is set to Controlled. If the value is set to FALSE, it is 
necessary to manually file such work orders. 

Default setting: TRUE. 

Auto-File Controlled Requisition Work Order 

If this value is set to TRUE, manually requisitioned work orders are filed automatically 
when the status is set to Controlled. If the value is set to FALSE, it is necessary to 
manually file such work orders. 

Default setting: TRUE. 

Auto-File Controlled Round Work Order 

If this value is set to TRUE, automatically generated work orders are filed automatically 
when the status is set to Controlled. If the value is set to FALSE, it is necessary to 
manually file such work orders. 

Default setting: TRUE. 
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Allow Negative Value Of Counters 

This parameter, when set to TRUE, will allow a user to enter a lower counter value than 
the one previously recorded. This facility can be used to correct values when counters 
are changed or if an error has been made during the reading or inputting of the previous 
amount. Note that this may affect certain counter based maintenance procedures. If the 
parameter is set to FALSE a user will be prevented from entering a lower amount and an 
error message will appear. 

Default setting: TRUE 

Auto Inherit Counters 

If this parameter is set to TRUE, components installed in sub-functions will 
automatically inherit counter updates from the component installed in the respective 
parent function. 

Default setting: False 

AutoFilter WO By Discipline 

When set to TRUE, the list of work orders is automatically restricted to the discipline 
that the user who is currently logged on belongs to.  

Default setting: FALSE. 

Automatically Reschedule Work Orders 

This parameter is useful during the process of establishing the AMOS M&P database in 
the organisation. By setting the value to FALSE, the program will not automatically 
generate work orders as components, counters and jobs are defined. This makes the 
process of entering such information more efficient. When this is completed, the 
parameter value is changed to TRUE, and the Maintenance/Generate Work Orders 
menu command is given in order to ‘kick-start’ the generating of work orders. 

Default value: TRUE. 

Calculate Estimates for Component Jobs 

This parameter may be set to Average or to Never. If set to Average, the program 
automatically updates the component job estimates. The values for Total Duration and 
Total Cost are estimated based on the duration and the cost of required parts and/or 
resources that have been reported 

Default setting: Never. 

Default Preference When Reporting Work 

This parameter determines which default value is checked in the Report Work dialog 
box which appears when the command Maintenance/Report Work is selected. The 
possible values are Component, Function and Work Order. 

Default setting: COMPONENT. 

Log Counters For Non-Counter Based Jobs 

 If this parameter is set to ‘TRUE’, reporting work against non-counter based jobs will 
require a mandatory counter value to be entered, providing that the component has a 
counter association. 

Default setting: FALSE 

Log Job Rescheduling 

This parameter, when set to TRUE, enables the rescheduling log. Every time a work 
order is rescheduled the reschedule log will be updated with information regarding the 
rescheduling. If the parameter is set to FALSE there will be no recording of 
rescheduling information in the log. 

Default setting: FALSE 
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Log Work With Employee 

This switch makes it possible to select the level at which to record work carried out.  
This may be either at the employee level, where reported work is attributed to a specific 
worker.  In some organisations, it may be more suitable to register maintenance done per 
discipline (e.g. mechanic, electrician, etc.) instead.  If this parameter is set to FALSE, 
reporting will be done using Disciplines instead of on an individual employee basis. 

Default setting: FALSE. 

Maintenance Log Modification Warning 

This parameter, when set to TRUE, ensures that accidental modifications to the 
maintenance log cannot be made. If the user tries to alter information in the maintenance 
log a warning message alerting the user will appear. If set to FALSE the user can modify 
information without warning. 

Default setting: FALSE 

Report History by default 

This parameter controls whether the Report History option when reporting maintenance 
is switched on or off by default. 

Default setting: TRUE. 

Report Resources by default 

This parameter controls whether the Report Resources Used option when reporting 
maintenance is switched on or off by default. 

Default setting: TRUE. 

Report Stock Usage by default 

This parameter controls whether the Report Stock Used option when reporting 
maintenance is switched on or off by default. 

Default setting: TRUE. 

Require Reason For Job Rescheduling 

This parameter, when set to TRUE, enforces the user to input a reason for job 
rescheduling. If set to FALSE there is no requirement to enter a reason. Note that this 
parameter is ineffective if the parameter ‘Log Job Rescheduling’ is set to FALSE. 

Default setting: FALSE 

Restrict Replanning Of Started Work Orders 

If set to TRUE, it is not possible to re-plan (to move) a work order in the work planning 
timeline once the Started date has been set. This occurs the first time a user reports 
maintenance work against the work order. 

Default setting: FALSE. 

Seconds Between each CBM Check 

This parameter allows you to control the frequency at which the system checks for CBM 
activity. 

Default setting: 180. 

Stock reservation trigger 

This parameter controls whether stock items required for work orders are shown as 
reserved whilst the work order continues to be active (Status), or whether the stock items 
are reserved only during the ‘window’ time period prior to the due completion date of 
the work order (StatusWindow). 

Default setting: StatusWindow 
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View Counter From Functions Perspective 

This parameter controls whether the Update Counters facility covered in section 4.7.1 is 
filtered and viewed from a functions perspective rather than a component perspective. 

Default setting: False 

Work Order Tracking Accuracy 

This parameter controls the level to which Work Orders are tracked.  The two possible 
parameters are ‘Date Only’ and ‘Date/Time’. Date Only lets you plan work by date 
whereas date/Time lets you plan to the nearest 15 minutes. 

Default setting:  Date Only 

Purchase 
Auto-Calculate Form Estimate 

This parameter is used to determine if the form estimates are automatically calculated 
and updated if the amount is changed. If the parameter has been set to FALSE, it is 
possible to perform the calculation manually by selecting Estimate cost from the 
Options menu. 

Default setting: FALSE. 

Auto-File Fully Received Form 

If this parameter is set to ‘TRUE’, forms that have been fully received will be filed 
without prompting. 

Default setting: FALSE 

Auto-Fill Delivery Details 

This parameter is used to automatically transfer Forwarder and Destination details 
within the Deliveries function in Purchase/Forms. 

Default setting: FALSE 

Auto-Set ‘Budget Date’ 

If this parameter is set to TRUE, the field Budget Date is set to the current date (Today) 
when a user prints an original purchase order. If setting the Budget Date to Today means 
that the budget code is not valid on that date, the form will not be printed. 

Default value: FALSE. 

Auto-Update Multi-Vendor Details from Line Item 

This parameter allows the system to update the details for all vendors that sell a 
particular item, with details entered in a Line Item. 

Default value:  TRUE 

Auto-Update Stock Details from Line Items 

This parameter allows the system to update Stock Details with details entered in a Line 
Item. 

Default value: TRUE 

Billing Address 

The Billing Address parameter is where the code for the address where purchase 
invoices should be sent is maintained. When you enter the Billing Address filter you will 
be presented with the Addresses window from which you can chose the correct address. 
The chosen address will be shown as an eight digit code. 

Default value: Blank 
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Clean Up ‘For Component’ In Stock Wanted 

This parameter, when set to TRUE, will clear any entries made in the ‘For Component’ 
column of the Stock Wanted window once the desired forms have been generated. If the 
parameter is set to FALSE the component number in the ‘For Component’ column will 
be set as the default value for that stock item and will be automatically entered in the 
column each time the Stock Wanted window is opened. To select a component to be 
used as default you should use the ‘look-up’ facility. The parameter ‘Component Search 
Range in Stock/Wanted’ determines whether you are presented with a list of components 
associated with the selected stock item or a list of all existing components when using 
the ‘look-up’ facility. This parameter can be found in the Parameters/Options/Stock 
section. 

Note: If a stock item has only one component associated with it, the component number 
will be automatically inserted into the ‘For Component’ column regardless of the value 
of this parameter. 

Default setting: TRUE 

Close Quotation After Query Select 

This parameter, when set to TRUE, will automatically save all changes and close the 
quotations window once the user ‘Selects’ a vendor. If the parameter is set to FALSE the 
user will have to save changes and then exit the window in the normal way. 

Default setting: FALSE 

Commodity Purchase 

If this parameter is set to TRUE, Purchase Forms (of all types) can be grouped according 
to Stock Class. This allows organisations to process each form according to stock class 
instead of having forms with multiple stock classes. 

Default setting: FALSE 

Component Search Range in Order Lines 

When adding a line item to a form in the Purchasing module, the stock number for the 
item to be purchased must be entered. Then define which specific component to 
purchase it for. 

By default this parameter is set to Any which has the effect that if you press the Search 
button (the one with the magnifying glass) next to the line item Component field, a 
complete list of components is presented.  

However, AMOS M&P allows you to attach a list of stock items to a component if you 
wish, tying for example spare parts to a piece of equipment.  By setting this parameter to 
Restrict, only those components to which the selected stock item is attached are listed.  

Default setting: Any. 

Create New Form On Form Conversion 

If this parameter is set to true, performing the following conversion will create a new 
form containing the order information and the existing one will take the status Filed. 

Note: If you wish to utilise this feature you should specify separate number series for 
each type of form to avoid having duplicate numbers for different forms. 

Default setting: FALSE
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Form ‘Generic Queue’ field 

This parameter facilitates the interface between AMOS M&P and other systems used to 
handle purchasing and/or accounting data. When the option When Printed is checked, 
the Forms Queued For Transfer indicator is set when an original purchase order is 
printed. When the option When Approved is checked, a form is queued for transfer 
when it is approved.  

When you click on the Search button, the Set Option dialog box looks like this. 

 
Default setting: 0 (no value checked). 

Form Status After Query Select 

This parameter allows for the automatic status conversion of  Query forms through the 
Purchase/Forms/Quotations window using the Select function. 

 
Default setting: Unchanged 

Form Type After Query Select 

This parameter allows for the automatic form type conversion of  Query forms through 
the Purchase/Forms/Quotations window using the Select function. 

 
Default setting: Unchanged 

Level of Approval 

AMOS M&P supports three methods of form approval:  

None • 

• 

• 

Signing 

Actual approval 

With None selected, approval is not required before an original purchase order can be 
printed. With Signing selected, someone with password authority to approve forms can 
approve the form using any legal user name. With Actual Approval selected, someone 
with password authority to approve forms can approve the form using only their own 
user name. 

Default setting: None. 
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Lock Approved Purchase Orders 

If this parameter is set to TRUE, any purchase orders that have been approved are 
locked for all editing. This includes all the line items for the form. The Functions tab 
card of the Access Control dialog box (see section 7.7.2) contains the field Edit 
Approved Purchase Orders. If the field is checked, members of the selected group are 
allowed to edit a locked purchase order. Once a purchase order has been locked, it is not 
possible to use the Convert function to convert it to a different type of form. 

Default value: FALSE. 

Lock Approved Requisition Forms 

If this parameter is set to TRUE, any requisition forms that have been approved are 
locked for all editing. This includes all the line items for the form. The Functions tab 
card of the Access Control dialog box (see section 7.7.2) contains the field Edit 
Approved Requisition Forms. If the field is checked, members of the selected group are 
allowed to edit a locked requisition form. Once a requisition form has been locked, it is 
not possible to use the Convert function to convert it to a different type of form. 

Default value: FALSE. 

Lock Exported Requisition Forms 

If this parameter is set to TRUE, any requisition forms that have been exported are 
locked for all editing. This includes all the line items for the form. The Functions tab 
card of the Access Control dialog box (see section 7.7.2) contains the field Edit Locked 
Requisition Forms. If the field is checked, members of the selected group are allowed to 
edit a locked requisition form. Once a requisition has been locked, it is not possible to 
use the Convert function to convert it to a different type of form. 

Default value: FALSE. 

Lock ‘Ordered’ Form Fields 

If this parameter is set to TRUE, it is possible to lock fields in order forms with the 
status Ordered. The Functions tab card of the Access Control dialog box (see section 
7.7.2) contains the field Edit Locked Form Fields. If the field is checked, members of 
the selected group are allowed to edit locked form fields. When the parameter is set to 
TRUE, the fields Budget Date, Budget Code, Ordered, Estimate and Currency are grey 
and inaccessible for editing, as is Options/Estimate Cost. 

Default value: FALSE. 

Note: Even if Restrict is selected, you can still enter the number of any component by hand if 
you wish. 

Multiple Departments In Order Forms 

This parameter, if set to TRUE, determines whether Order Forms originating from other 
departments can be viewed and modified from the current department. The Department 
drop down window in the Purchase/Forms Filter window will be available to select the 
desired department. This does not allow for the creation of new Order Forms and the 
number of departments available depends on the users global access rights. 

Default setting: False 

Restrict Original PO Printing 

If set to TRUE, this parameter restricts the printing of original purchase orders without a 
valid budget code or an estimate. 

Default setting: FALSE. 

Set Date Automatically During Receipt 

This parameter is used to control whether the Receipt Date field of a purchase order is 
filled in automatically during receipt. When set to FALSE (which is the default) then the 
user must enter the receipt date manually. 

Default setting: FALSE. 
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Use Latest Delivery Date of Order Lines 

When adding items to an order form, the system automatically fills in the latest delivery 
date from information contained in the stock item register if this is set to TRUE. 

Default setting: FALSE. 

Use Quotation ‘Discount Given’ 

This parameter is used to determine whether the field Discount Given in a Quotation is 
to be used by the function Options/Calculate to calculate the Quoted Price. If set to 
TRUE, this function will reduce the Quoted Price by the percentage specified in the 
Discount Given field. 

Default setting: FALSE. 

Use Vendors' Price 

When adding items to an order form, the system automatically fills in the line item 
details from information contained in the stock item register. If the vendor of the order 
form is known, the system by default looks up the item price in the multi-vendor list and 
uses that price in the line item.  However, this behaviour is only suitable if you are 
keeping you multi-vendor prices up to date.  

By setting this parameter to FALSE, the system will instead use the last purchased price 
in the line item. 

Default setting: FALSE. 

Use Work Flow 

If this parameter is set to true, the Purchase/Forms/Options drop down window 
expands to include the Workflow function. The Workflow function allows users to pre-
define and automate the process sequence of purchase forms. 

Default setting: FALSE 

Validate Order Form Dates 

If this parameter is set to true, all dates entered on purchase forms will be checked to 
make sure they follow a logical date sequence. 

Default setting: FALSE 

Stock 
Allow Removal of more Items than in Stock 

This parameter controls whether a user is allowed to use or remove a greater quantity of 
an item than is actually registered as being available in stock.  This is relevant in some 
installations where a strict reporting of stock movement is not practised, or when stock 
items may be removed directly from transit storage or received shipments before they 
have been registered as received in stock. 

Default setting: TRUE. 

Approval Required For Stock Transfer 

This parameter determines whether approval is required for transfer of stock items 
between installations. If the parameter has been set to TRUE, a receiving installation 
will not be able to see a transfer document until the status has been set to Approved at 
the donating installation. 

Default setting: TRUE. 
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Component Search Range in Stock/Wanted 

When modifying a quantity in the Stock/Wanted window, the component number that 
the stock item is required for may be entered. If there is only one component associated 
with the stock item then that number is automatically inserted in the ‘For Component’ 
column. If, however, there are several components associated with the stock item, you 
can use the ‘look-up’ filter (magnifying glass) to choose the component number you 
require. 

If this parameter is set to Any, clicking on the look-up button causes a complete list of 
all components to be shown. If this parameter is set to Restrict, only the components 
associated with the stock item will be shown.  

Default setting: Any. 

Note: Even if Restrict is selected, you can still enter the number of any component by hand if 
you wish. 

Inherit Full Description From Parent 

If this parameter is set to TRUE, ‘child’ stock types that do not have a full description of 
their own will automatically inherit that of the ‘parent’ stock type. If the description for 
the ‘child’ stock type is subsequently altered it will be saved as the new description for 
the ‘child’ stock type only. 

Default setting: FALSE 

List All Transfer Documents 

If this parameter is set to TRUE, the installation may list all the transfer documents that 
have been submitted from all installations. This may be quite useful at the main location 
if the parameter Approval Required for Stock Transfer has been set to TRUE. At the 
main installation, it will then be possible to list all the transfer documents in order to 
evaluate which should be approved. 

Default setting: FALSE. 

Propose Work Order Required Parts 

Allows the system to suggest values when performing an In / Out of Stock transaction 
for a Work Order. 

Default setting: FALSE 

Record Stock Usage When Reporting Work 

Parameter restricts the ability to report stock usage against a work order, in order to stop 
double reporting of stock usage, both in reporting Work Orders and In / Out of Stock 
functions. 

Default setting: FALSE 

Stock Price Logged 

This parameter indicates whether you want the average or last stock price to be used 
when calculating stock values. 

Default setting: AVERAGE 

Use Stock Class Access 

This parameter, when set to TRUE, allows you to restrict the various stock classes that 
can be accessed by each group of users. The access control is to be found in the menu 
option Tools/Configuration/Groups/Options/Stock Class Access. Note that if you want 
to restrict a groups Stock Class Access, you must define the stock classes available to 
every group otherwise a group without defined stock classes will only be able to access 
stock items with unspecified stock class. 

Default setting: FALSE 
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Use Stock Item Depreciation 

This parameter, which must be set before any stock items are entered into the system, 
tells the system whether to use stock item depreciation.  Depreciation levels are set at 
Tools / Configuration / Depreciation Levels. 

Default setting: FALSE 

7.7.4.6 Sharing 
Although some information may appear to be available from only within a single 
installation or department, all information is actually stored in the same set of database 
tables regardless of which installation or department they belong to. For the system to be 
able to show information belonging to a particular department, it has been necessary to 
stamp all table entries with a marker indicating which department they belong to. This 
mechanism works well for departmental types of information such as components, stock 
items job descriptions etc., but does not suit for information to access at a more global 
level e.g. addresses disciplines, job classes and the like. 

This set of parameters, one for each table in the database, control how the information 
contained/owned by one department is shared out such that it can be accessed by other 
departments. 

There are also three special parameters controlling how the work order form and 
transport document counters are shared between departments. 

For example, an address register has been established in Inst/Dept 001/01, all addresses 
will have been stamped as owned by that department. Unless sharing is defined, these 
addresses will only be accessible from Inst/Dept 001/01. To share these addresses such 
that all departments have access to them, select to modify the Global Sharing 
parameters.  Then choose the Sharing tab and on the parameter entry reading Addresses, 
specify Inst/Dept 001/01 from the list of defined departments.  The addresses will now 
be accessible from every department.  

The same feature can also be used to share information across all departments of a 
particular installation by defining sharing at the Installation level, or even at the 
department level thereby sharing a single set of data between two departments. 

As described at the beginning of this section, parameter values are inherited downwards 
from the global to the department level.  For example, if a user logs onto to Inst/Dept 
002/03, the system first checks to see whether sharing has been defined for department 
002/03. If nothing is defined, the system then checks to see whether sharing has been 
defined for installation 002. If nothing is defined, the system then checks to see whether 
sharing has been defined at the global level.  If no sharing definitions are found, the 
system then defaults to fetching information stamped as owned by department 002/03 
(e.g. the current installation and department). 

If you intend to use the component transfer facillity within AMOS M&P, you will need 
to ensure that global sharing is allowed for the following tables: 

Address   Component Class  
Component Type  Counter Type 
Discipline   Employee 
Image Reference  Image Reference/Hotspots 
Image Reference Links  Image Source 
Job Class   Job Description 
Maintenance Cause  Maintenance Class 
Maintenance Criteria  Maintenance Type 
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7.7.4.7 Transaction Codes 
The Transaction Codes parameters may be used to connect expenses to an element such 
as a Project or a Responsible. The transaction codes are not directly connected to the 
budget. Click the magnifying glass for a transaction code you are defining to get a dialog 
box to specify which status the transaction code should have: 

 
The Transaction Codes window looks like this: 

Default values may be set for transaction codes. 
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7.7.4.8 User Defined Fields 
In many of the data objects in the system have a number of fields with no predefined 
function or title, and can be used as required in order to meet company or department 
specific needs.  These are called User Defined Fields, and may be found on most data 
screens throughout the system. 

This set of parameters allows the user to define the screen leader texts of the user-
defined fields when shown onscreen. Unless they are in use, such fields should be 
empty. 

 

7.7.5 Number Series 
Several items registered in AMOS M&P are automatically numbered by the system. 
Among other things, new Work Orders and Components are assigned numbers by the 
system. 

Two main factors determine the use of such numbers. The menu command 
Tools/Configuration/Number Series gives access to the Number Series window 
described below. This window is used to initialise the various number series. The Auto-
Numbering tab card in the Options dialog box (described in section 7.7.4.2) may be used 
to define input masks to determine which characters may be used when registering data 
of the different types and rules to determine how numbers are generated by AMOS 
M&P. 

The Number Series filter 

 
The Inst/Dept drop-down list may be used to specify a department, and the Series 

Type list contains the different types of number series available in the system. 
• 
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The Number Series window 

 
The columns Week, Month and Year will display how many numbers have been 
issued in the respective number series in these periods. 

• 

• 

• 

The Year Reset column is used to enter the number to which a number series will 
be reset at the start of a new year. Normally, the value is set to 0, but there are 
situations where it is relevant to choose a different value. For example, different 
department may have different series for issued Forms. The main office may use 
numbers from 0, while one installation may use the Year Reset value 1000, and 
have the system assign numbers from that starting point at the beginning of the 
New Year. 

It is possible to sort the contents of the window by clicking header field of the 
column by which you want to sort. Click it once more to toggle the sorting between 
descending and ascending.
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7.7.6 CBM References 
Condition-based Maintenance (CBM) provides a means of integrating various 
equipment measurements and monitoring systems with the maintenance features of 
AMOS M&P. Appendix B in this reference manual gives an overview of the CBM 
functionality. 

 The CBM Reference filter 

 
Each CBM piece of equipment is given a System ID and a Code. The Type drop-
down list in the Filter dialog box contains the two defined types of CBM 
references, which are Job and Counter. 

• 

The CBM References window 

 

7.7.7 Transaction Codes  
The Transaction Codes parameters may be used to connect expenses to a specific budget 
dimension, like Responsible or Project. These parameters are described in section 
7.7.4.7. 

Once transaction codes have been defined, the menu command 
Tools/Configuration/Transaction Codes is used to access the window to enter values 
for the defined codes: 

 
The drop-down list at the top of the window is used to select the transaction code 
category to enter values for. 

• 

• 

• 

Transaction codes may have the status of Not Used, Optional or Mandatory, as 
described in section 7.7.4.7. 

The Options menu of the Components window contains the Transaction Codes 
command, which may be used to select a transaction code and a value for a 
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selected component This is described in section 3.1.1. It is also possible to access 
the Transaction Codes window by clicking the corresponding command button 
from the window In/Out of Stock described in section 3.1.2. 

7.7.8 Account Code Categories 
The Account Code Category window enables the user to define unique numbers and 
labels for account codes that are used in the ‘Account Codes’ register covered in section 
3.1.14.2. These codes can later be used for accounts reporting. The Sequence number 
must be numerical while the label field is free text. The Type drop down window is used 
to set the account type. 

 

7.7.9 Cost Centres 
Cost Centres allows you to create and administer Cost Centres. The checkbox for ‘Has 
Stock’ defines the initial type of account applicable to the cost centre, when receiving 
goods for example. The ‘Active’ checkbox can be used for temporary cost centres such 
as a project and can be unchecked once the cost centre is no longer required. The 
‘Parent’ drop down window allows you to create a hierarchy of cost centres. 

 

7.7.10 Stock Grade Categories 
The Stock Grade Category window allows you to create and maintain the categories 
available in the Stock Grades register. 

7.7.11 Depreciation Levels 
The Depreciation Levels window enables users to define their own rates of depreciation 
independently of depreciation time periods. This is particularly useful where regional 
accounting methods demand such flexibility. 
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7.7.12 Installations/Departments  
AMOS M&P contains functions that make it possible to handle complex organisations. 

The command Tools/Configuration/Installations-Departments gives access to the 
following window:  

 
When the New command button is clicked, AMOS M&P presents a dialog box 
which allows the user to select whether to create a new Installation or a new 
Department in the currently selected Installation: 

• 

 
There are two separate Comments fields available for any suitable textual 
information the organisation wants to connect to the selected installation or 
department. 

• 

• The command File/Switch Department is used to select which department is to be 
currently active. The command is described in section 3.3. 

7.7.13 e-Business Portals 
AMOS M&P allows for purchasing functions to be channelled directly to e-Business 
portals. The following window allows the user to input the required information in order 
to set up the portal transaction. 
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• The Description field allows the user to give a name to each available portal. 

• The Portal ID field contains the membership identification number issued by the 
portal provider to identify where the transaction request comes from. 

• The Format field takes information from the e-Business Formats option in the 
tools/configuration menu described in section 7.7.14. 

• Export and Import Directory fields contain the source and destination file details 
on the local PC. Clicking on the magnifying glass icon brings up a window that 
allows the user to browse through the local machine in order to locate the correct 
directory. 

7.7.14 e-Business Formats 
The e-Business Formats window  

 
• The Description field contains the name of the portal provider. 

• The Driver field contains the name of the pfd (portal format driver) file usually 
pre-installed to customer requirements. If the file is missing or incorrect you 
can navigate to the correct file by using the ‘look-up’ button at the right hand 
side of the column. 

• Export and Import Function fields contain the necessary commands to activate 
the required function from the driver file. If these fields are empty and you 
have the correct driver file installed you should click on the ‘look-up’ buttons 
at the right of these columns and the application will automatically import the 
function files from the driver file. 

• The Version field contains the identification code for the driver you are using. 
Driver files may be periodically updated and you can check this code to ensure 
that you are using the most up to date drivers. 

7.7.15 Workflow 
Configurable work flow is a feature that allows you to recreate the steps that your 
company work flow takes in each stage of a process. For the examples shown below, we 
have used a ’Purchase’ scenario. 

The work flow process can be divided into the following six categories: 

Actions   A list of all possible purchase actions 

Statuses   A list of all possible purchase form statuses 

Status Action  A list of actions that can be performed against a status 

Resulting Status  The status that follows a performed Status Action 

AMOS Action  The equivalent action to be carried out by AMOS 

Access to action  Who has access to a particular action 
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Use the menu option Tools/Configuration/Work Flow to access the ’Work Flow 
Configuration’ window. 

The following screen shows the Actions tab. This is where the list of all possible actions 
is maintained. They are user defined and should be used to mimic your own company 
processes. 

 
Use the secondary toolbar or the Edit menu to add and delete actions. 

Once actions have been defined you can go to the ‘Statuses’ tab shown below. 

 
The Status column is where the list of all possible statuses is maintained. Once again, 
they are user defined and should be used to mimic your own company statuses. 

Again, use the secondary toolbar or the Edit menu to add and delete actions. 

The middle column of the Work Flow Configuration window is where you link the 
status action (taken from the list on the ‘Actions’ tab) to the Resulting Status (taken 
from the ‘Status’ column). Use the buttons at the bottom of the column to add or delete. 

The upper right column is used to assign AMOS actions that reflect what would 
normally happen in the middle column. Use the buttons at the bottom of this column to 
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add and delete actions. 

The lower right section has a check box of all ‘Groups’. This can be used to define who 
has access to view and edit the information at each stage in the process. 

Once you have configured the workflow process you can select ‘Work Flow’ from the 
‘Options’ menu whilst looking at purchase forms to use the configuration you have 
created. 

The following screen shows an example of what you may see when using work flow to 
process a purchase form. If there are multiple actions listed, you can select the one you 
want to use and add a comment. Click on OK and the purchase form will be 
automatically progressed to the next stage in the work flow procedure. If you wish to 
assign the form to a new mailbox, you should select the users mailbox from the Assign 
To drop down window. 

 
Options – Convert Work Flow Status 

There is a conversion window for users who wish to convert to using workflow. In the 
menu option Tools/Configuration/Workflow/Options/Convert Work Flow Status there is 
a window to allow you to apply different initial workflow statuses to each type of 
purchase form status. 
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7.7.16 Printer Tasks 
AMOS M&P makes it possible to tailor reports, and to add these reports to the report 
hierarchy. A full description of these options is found in Appendix A in this reference 
manual. 

Once reports have been defined and added to the report hierarchy, it is possible to define 
printer tasks to handle the printing of the report on a selected printer. The Report settings 
window, which is described in section 7.7.17.1, contains a tab card called Misc. to name 
a printer task for a selected report. This is done in the Printer Task field 

 
The command Tools/Configuration/Printer Tasks opens the corresponding window. 
Each task must be given a name, and it is also possible to add a comment describing the 
task further: 

 
Once the task has been named and saved, the Options menu command Printer Task 
Configuration becomes available: 

 
The Task Configuration window opens, and the name of the selected task appears in the 
title bar of the window. 

If no printer names appear when the drop-down list in the Identification field is opened, 
it is necessary to select System Printers from the Options menu in order for AMOS 
M&P to add the printer definitions available on your PC into its own database 

 
When this command is selected, it takes some time for AMOS M&P in order to import 
the necessary information. After the process is completed, the desired printer may be 
selected from the drop-down list. An icon appears to the left of the field to indicate the 
type of selected printer. For example, there are different icons for local and network 
printers. 
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The Comments field is optional, but may typically be used to describe the selected 
printer. 

• 

• 

• 

Use the Copies field to specify how many copies are to be printed in the selected 
printer task. 

It is possible to click the Search button next to the Paper Source field in order to 
get a window to select the paper source. This window displays the defined paper 
sources in the selected printer. 

 

7.7.17 Extension Features 
In addition to the pre-defined reports found in AMOS M&P, it is possible to create tailor 
made reports for the organisation. This is done in one of the tools PowerBuilder or 
InfoMaker. When the report has been created and stored in a .Pbl library file it is 
possible to include the user defined report in the AMOS M&P report hierarchy 
described in section 7.4. 

A description of how to create reports, to include them in the report hierarchy and grant 
access to them is found in Appendix A of this reference manual. 

7.7.17.1 ‘Reports’ Menu 
The command Tools/Configuration/Extension Features/Reports Menu gives access 
to the hierarchy of user-defined reports: 

 
The report hierarchy works similar to other hierarchies in AMOS M&P. The + 

and – buttons may be clicked in order to expand and collapse hierarchy levels. 
Corresponding commands are found in the Options menu. 

• 
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7.7.17.2 ‘Modules’ Menu 
The command Tools/Configuration/Extension Features/Modules Menu opens the 
window to work with external programs and user-defined Power Builder modules: 

 
If you make any alterations to the Modules menu, you must re-start AMOS M&P to 
show the changes. 

When there are modules or programs available and you have the correct access level 
within the system, the Tools menu will contain an extra entry called Modules, which 
will have a sub-menu containing the modules available to you as below: 

 
You can organise the modules in any way you choose by using ‘drag and drop’ methods 
to create a hierarchy structure. 

7.7.17.3 Access Modules 
Access Modules allows the user to create new types of user-defined modules within the 
Reports/Modules function of Access Control, see section 7.7.2. 

 
The Module Contents command from the Options menu gives access to the window to 
select the reports or external programs that are to be available for the particular module. 

 
It is also necessary to grant the relevant user-groups access to the reports or programs in 
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the module. 

 
In the above examples, checking the box by the side of the entry ‘External programs’ 
within Access Control will allow the selected user access to the programs or reports 
shown in the Module Contents window. 

7.7.18 Update System License 
In order for AMOS M&P to function, a valid system license must be available. The 
license file contains information about the organisation, about which modules have been 
purchased, and so on. 

If the system presents an error message stating that the system licence must be updated, 
a new system licence file must be obtained from the AMOS M&P distributor. In order to 
update the license, give the menu command Tools/Configuration/Update System 
License to enter the SQL File dialog box. Use standard Windows techniques to locate 
the folder with the .Sql file, and double-click it to update the license. 

 

7.8 Change Password 
To change the password of the user who is currently logged on, give the command 
Tools/Change Password. The following dialog box is presented: 
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Enter the existing password in the first field and the new password in the second and 
third fields. Since the actual passwords are not displayed for security reasons, it is 
necessary to enter the new password twice to ensure that there are no spelling mistakes.  

If you typed the old password incorrectly you will see the following window: 

 
If the two new password fields do not match, the following dialog box is presented: 

 
Depending upon the parameter settings that have been implemented by your 
organisation, you may also see the following error messages: 

 
The above message informs you that the ‘Enforce Password History’ parameter is set to 
2 and therefore prevents you from entering the 2 previously used passwords. 

 
The above message informs you that the ‘Minimum Password Length’ parameter is set 
to 5 and you must therefore enter a password of at least 5 characters. 

Note that you should ensure that all users belong to groups that  have access rights to 
change password if you intend to use the advanced security options. Set this through the 
menu option Tools/Configuration/Groups/Options/Access Control. The checkbox for 
change password can be found on the Functions tab. 
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7.9 View PSR Reports 
The pre-defined reports of AMOS M&P are described in section 7.4. It is possible to 
create electronic versions of a printed report. To do so, preview the report as described 
in the previous section, and then give the command Edit/Save As. Select Powersoft 
Report from the Save as type drop-down list in the Save As dialog box: 

 
After the preview version of the report has been saved, it is possible to give the menu 
command Tools/View PSR Reports in AMOS M&P in order to see the report on the 
screen, as shown in this screen picture: 
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7.10 Options 

7.10.1 The General tab 
Under the menu Tools/Options, the General tab provides options allowing you to 
personalize the appearance and behaviour of the AMOS M&P user interface. 

Control of access to these features can be found within the Access control entry ‘user 
options’ which has been added to the Access Control ‘Functions’ tab. 

 
Please refer to the screen shot on the next page for visual references. 

• The Task bar option controls whether the Task Bar and Window Title-bar are 
displayed. 

• The Menu bar option controls whether the left hand side Menu Bar is visible. 

• The Toolbar tips option controls whether a text description appears when the 
mouse cursor is positioned over an icon on either the Standard Toolbar or the 
Window Toolbar. 

• The Toolbar text option controls whether toolbar icons are displayed with a text 
description below them. This feature can be particularly useful for new users. 

• The Confirm on Exit option controls whether the application requests 
confirmation prior to exiting. 

• The Windowing mode option gives the user the choice of opening windows as 
Maximized or Cascaded. All open windows must be closed to activate this 
option. 

• The Standard toolbar position option controls the onscreen position of the 
Standard Toolbar i.e. Top, Bottom, Left, Right or Hidden.  

• The Window toolbar position option controls the onscreen position of the 
Window Toolbar i.e. Top, Bottom, Left, Right or Hidden. 
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As can be seen in the above illustration, the Standard and Window toolbars are in the 
default position (they can be moved elsewhere on screen or removed altogether). In 
addition, the Menu and Task Bars have been activated. The Task Bar displays a tab for 
each open window allowing the user to quickly switch between windows. When the 
Task Bar is active, the Window Titlebar also becomes active in order to easily identify 
the current window. 

The Menu Bar contains large buttons which provide access to commonly used functions 
within the application. There are five separate tabs (Main, Maintenance, Stock, Purchase 
and tools) which each contain buttons to various parts of the application. 

 Tab Name  Buttons Available 

Main   Components 
    Addresses 
    Switch Department 
    Component Hierarchy 
    Function Hierarchy 
    Exit 

 Maintenance  Work Orders 
    Work Planning 
    Requisition Work 
    Update Counters 
    History 
    Log 

 Stock   Items 
    Wanted 
    In/Out of Stock 
    Control 
    Transactions 

 Purchase  Forms 
    Transport Documents 
    Contracts 

 Tools   Budget 
    Reports 
    Help 
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7.10.2 The Views tab 
AMOS M&P has the facility to save frequently used screen configurations, otherwise 
called ‘Views’. Each view is capable of recording which screens are open, which screen 
is active and which filter criteria are defined. Each saved ‘view’ can be restored as and 
when required. 

Under Tools/Options, the ‘Views’ tab provides options to create New views, Update 
existing views, Delete views that are no longer required and to set one of the views as 
the Default view. If the ‘Startup using default view’ box is selected, the application will 
automatically open with the default view opened. 

 
On selecting ‘Tools/Select View…’ or pressing the F6 key, the select view window 
opens with a list of available views that have been registered. Select a view by clicking 
on it and then click on OK. This will restore the various windows and filter criteria 
associated with that view. 

 
In the above screen shot, the ‘Stock Control’ view has been selected. When you click on 
OK the open windows you have associated with the view will automatically open 
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7.11 Delegate Mailbox Access 
The Delegate Mailbox Access is part of the Workflow module. 

Users can delegate their mailbox access (if the delegate private mailbox access control is 
enabled) to another user for periods of holiday etc. and then un-delegate their mailbox 
on return to work. 

 
If the access control entitled delegate mailbox access is enabled for the user, they will be 
able to delegate any users mailbox to any other user. 

7.12 Mailbox Access Log 
The Mailbox Access Log is part of the Workflow module. 

If the access control entitled delegate private mailbox access is enabled for the user, they 
will be able to view all access history for their personal mailbox. 

If the access control entitled delegate mailbox access is enabled for the user, they will be 
able to view all mailbox access history for any users mailbox. 

.
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A Layouts and Reports 

A number of the AMOS M&P registers contain a field called Full Description. It is 
possible to create layouts to make it easier for the user to enter the correct data in such 
fields in a faster and more efficient way.  

AMOS M&P offers a number of pre-defined reports that present data about components, 
stock items jobs etc. It is possible to create new reports for the organisation if needed, 
and to edit the pre-defined reports.  

The programs PowerBuilder or InfoMaker from PowerSoft may be used to create and 
tailor layouts and reports. The latter is basically a “light” version of the former, but it 
contains all the necessary functions to create layouts and reports. Below, the description 
is based on using PowerBuilder, but those instances you use different techniques in 
InfoMaker are pointed out in the text. 

Note: 
This chapter has been written for use with PowerBuilder/InfoMaker 5.5 and is intended 
as a basic introduction to creating your own layouts and reports. Future versions of 
PowerBuilder/InfoMaker may differ in appearance and operation to the following 
sections and we therefore recommend that you read any related documentation supplied 
with the software. 

A.1 Brief introduction to PowerBuilder and 
InfoMaker 

PowerBuilder is the development tool used to create AMOS M&P. InfoMaker is a 
reduced version of the same program, but it contains all the same functions to create 
forms and reports to interact with a database. Extensive documentation is available for 
these products, and it is beyond the scope of this manual to describe all the 
PowerBuilder and InfoMaker features.  

The text will focus what needs to be done in order for AMOS M&P to handle layouts 
and reports. However, a brief description will be given of the basic PowerBuilder and 
InfoMaker techniques. If you only need to make small modifications to existing layouts 
or reports, or to create simple new layouts or reports, you will probably find the 
information you need in this chapter. 

A.1.1 Making and using layouts 
These are the most important steps involved in the process of making and using layouts 
as Full Description field templates: 

The tools in PowerBuilder are used to create the layout that is going to be 
presented to the user, with the desired fields, texts and other controls. 

• 
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• The layout is stored in a .Pbl file, a library file that may contain several layouts. 
Appendix A.1.4 includes a description of how a new .Pbl file may be created. 

AMOS M&P contains a register that used to name the various templates in use. 
The process of importing a layout to template is covered in section 3.1.12.1. When 
the user updates information that contains a Full Description field with a connected 
layout, that information is stored in BLOBs in the database. This means that the 
data from the form is transferred to the database in the defined field sequence. If 
the field sequence is changed, data will be displayed incorrectly to the user. Once a 
form has been used to input data, it should not be changed. 

• 

• 

• 

A.1.2 Working with reports 
AMOS M&P provides a number of reports that present data according to selected 
criteria when they are run. Section 7.4 in this reference manual contains an overview of 
the available reports and how they are used. 

It is also possible to create new reports if necessary. Like layouts, reports are stored 
in .Pbl files. The reports may display data stored in AMOS M&P tables and fields.  

Once a report has been defined, in should be included in the report hierarchy to be 
available to users who want to run it. This is described in Appendix A.5. 

A.1.3 Creating a database profile 
The first time PowerBuilder is used, it is necessary to define a database profile. 

  Note:   In PowerBuilder, the amos user should always be used. 

To define a database profile: 

1. Click the DB Profile button.  

2. In the next dialog box, click New to enter the Database Profile Set-up dialog 
box. 

3. Fill in the fields as follows: 

Profile Name: maintenance 
DBMS:  odbc 
User ID:  dba 
Password  
Database Name: amos 

4. Click OK to enter the SQL Data Source dialog box. 

5. Select Maintenance from the list, and click OK twice. Give the user name amos 
wherever applicable.  

You are then connected to the database with the correct profile, and are ready to 
start the actual work on the form. 

 
If an error message occurs on trying to connect to the database, a ConnectString 
must be defined: 
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1. In the Database Profile Setup shown above, click More>> to expand the dialog 
box. 

2. In the field DBPARM, enter the following: 

 ConnectString='DSN=Amos' 

3. Click OK to connect to the database. 

A.1.4 Creating a new .Pbl file 
When AMOS M&P is installed, a \PBL folder is created within the AMOS M&P 
program folder. It is recommended that new .Pbl files be placed in this folder. 

At this point in the process, there are some differences between PowerBuilder and 
InfoMaker. There are two main aspects: 

• Reports and layouts are stored in files of the type .Pbl. When working in 
InfoMaker, you select an Environment, which is the .Pbl file that you want to work 
with. In PowerBuilder, you select an Application and the application may access 
reports stored in different .Pbl files 

• In PowerBuilder, you can get an overview of the various .Pbl files for the 
application in a Library window. This resembles the Explorer program in Windows 
95. This option is not available in InfoMaker. 

In PowerBuilder, you can press the Library button to get a graphical representation of 
the .Pbl files in the application: 

 
The Application icon looks like this: 
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If you are working in InfoMaker, start by clicking the Environment button: 

 
You will see a list of reports in the currently selected report library. If you need to open 
a different library, select Open from the File menu to do so.  

If you want to create a new library in PowerBuilder, select Create from the Library 
menu and select the name and location for the new library. 

 

A.2 Designing layouts 
Below is a description of the necessary steps involved in the process of creating a layout 
to be used in a Full Description field 

1. Start PowerBuilder and double-click the Library icon for the library in which the 
layout is to be stored. 

  
2. Click the DataWindow button to open the Select DataWindow dialog box, and 

click New to create a new data window. 
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3. In the New DataWindow dialog box, select External in the Data Source area of 
the dialog box and Freeform from the Presentation Style area. 

 
4. Click OK to enter the dialog box called Result Set Description. 

5. Specify the Name, the Type and the Length for the first element in the layout to 
be created, and click Add to add a line for a new element. 

 
6. Continue to add the elements in the layout. 

The Type drop-down list contains the various possible choices for the elements 
that may be defined: 

 
7. When you have added the elements to be used in the layout, click OK display the 

data window. 

It is possible to add new elements to the layout later, so it is not absolutely 
necessary to add all the layout elements at this point. 

8. Click Save to name the layout and save it in the currently open library file Then 
use the available design tools to format and design the layout, and remember to 
save the layout at regular intervals during the process. 

A description of some of the design functions available is included in section  
A.4. 
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9. Use AMOS M&P in order to connect the created layout to a Template definition, 

as described in section 3.1.12.1 of this reference manual. 

10. Test the layout that has been created by entering or editing an item in the register 
to which the layout has been connected. 

For example, a Full Description field may look like this: 

 

A.3 Making and tailoring reports 
Once AMOS M&P has been set up in the organisation and has been in use for a while, 
its database will contain large amounts of useful data. A number of pre-defined reports 
have been created in order to present data from the database.  

It is also possible to tailor new reports to extract and display data from the AMOS M&P 
database. Once a new report has been created, it may be added to the report hierarchy, 
from which it may be used the same way as the pre-defined reports. The process of 
adding a user defined report to the report hierarchy is described in Appendix A.5. 

A.3.1 Creating a new report 
Here is a description of how to create a new report: 

1. Select the .Pbl file in which the report is to be stored, and click the Data window 
button in PowerBuilder or the Form button in InfoMaker. 

 
The Select Data Window dialog box will be displayed. 

2. Click New to create a new report. 

You enter the New DataWindow dialog box to set up the new report: 
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The New Form dialog box in InfoMaker contains somewhat fewer options but 
the ones you need for your reports are available. 

3. Select SQL Select as Data Source and Freeform as the Presentation Style/Form 
Style. 

4. Click OK.  

The Select Tables dialog box is displayed.  

 
5. From the list of tables, select the one you want to use, and click Open. 

It is possible to select multiple tables and define necessary join relationships 
between them in order to create complex reports. It is beyond the scope of this 
manual to describe such complex reports. 

6. Select each column in the small table window in the middle.  

As you do, you notice that the column names appear near the top of the window, 
below the title bar, as shown in the picture below.  
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7. Click the SQL button, which by now should be pressed, and will actually come 

back “out” when you click it. 

  
Finally, it is time to edit the actual report. The screen now looks something like this: 

 
Note: When you make a new report, AMOS M&P and PowerBuilder might be working on the 

same library. Unfortunately, this can cause conflicts and you will not be notified about 
them before you try to save your changes. Save the report at this point, before too much 
work has been put in it. See the next section. Then start designing the report. 

A.3.2 Saving the report 
It is a good idea to save the report early in the process, and then repeat saving it at 
regular intervals. 

AMOS M&P Reference Manual 5.3.00 Layouts and Reports  •  216 



 

To save the report use the following procedure: 

1. Select Save from the File menu or click the corresponding toolbar button. 

 The Save DataWindow/Save Form dialog box will be displayed. 

2. Type the desired name of the report. 

We recommend that the report be given a name that consists of a report prefix 
plus the name of the table upon which the report is based. 

3. Click OK and the report will be stored in the currently active report library. 

A.4 The window to design the report or layout 
The illustration in the previous section shows the PowerBuilder window that is used to 
create and design the report. All the columns in the selected database table are 
automatically placed in the report. There are two elements for each table: A data field 
and a text field. The latter contains the Column Name. 

In the window, there is a toolbar that contains the tools used in the design work. The 
most important buttons are named in the illustration below: 

 

 

 

 

 

Insert new Autosize height 

Preview the 
form Properties Foreground 

 Border Tab order Background color 
Alignment  

 

Use standard Windows techniques to design the report. For example, an object may be 
dragged to a different position and dropped there. The buttons in the toolbar shown 
above can be used to select alignment, colour and other object properties. 

A.4.1 Moving and aligning fields 
To move an object, click it and drag it to the new location To select multiple objects, 
draw a selection box that partly covers the objects you wish to select, and drag them as a 
group. To select multiple objects that cannot be selected with this method, press CTRL 
and click each object to include. 
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It is easy to align fields. Select the fields you wish to align, and open the list of 
alignment options from the toolbar. 

 
It is fairly simple to interpret the function of each individual icon and which effect it will 
have on the selected objects. If in doubt, let the mouse pointer rest on a button for a short 
while. A tool tip will appear, informing you about the function of that icon. 

A.4.2 Setting field properties 
The properties can be set for each individual field in the report. To open the properties 
window, select the object to work with and click the Properties button, or simply double-
click the object. 

The properties window for a Text Object looks like this: 

 
Use the various tab cards to enter or edit properties for the selected object. In the 
example above, the Text field on the General tab card is used to change the actual text of 
the field. The Font tab card is used to set font, size and other textual properties, etc.  
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The properties window for Column Objects looks like this. 

 
It is beyond the scope of this manual to describe all the possibilities offered to you by 
InfoMaker/PowerBuilder: Refer to the relevant documentation or online help for more 
information. However, here are some tips about function available on the different tab 
cards: 

• Edit makes it possible to make different presentation styles, such as drop down 
lists, check boxes and radio-buttons. Edit masks force the user to type data in a 
special format (for example a telephone number or a date, described in the next 
section). 

• Validation is useful to test the legality of the data the users type in: For example, it 
is possible can make certain that a number always is positive. 

• Expression is the most complex: It makes it possible to change the colour of the 
text depending on what is typed. For example, negative numbers can be displayed 
in red. Certain fields may be made invisible. 

If the main concern is with the look of a report, it is probably sufficient to manipulate 
items on the General and Font tab cards. The Position tab card may be used to specify 
the exact position of an object. Other properties require a deeper knowledge of 
PowerBuilder, InfoMaker and database applications, and such topics fall beyond the 
scope of this reference manual. 

A.4.3 Setting date format masks  
Whatever format you use in the database for dates, they will always be stored in an 
internal format. By default, PowerBuilder will show the date according to the system 
default, so it is not necessary to bother about date formats. If the user is to be presented 
with a mask only permitting to type legal dates, follow these steps:  

1. In design mode, select the actual date field and choose the Properties from the 
Edit menu.  

A screen shot of the column-object property tab is found in the Appendix A.4.2. 

2. Select the Edit tab, and set Style to EditMask. 

3. In the Mask field, type [date]. Do not forget to type the brackets. By typing 
[date] instead of a string like dd/mm/yyyy, it is certain that your reports behave 
coherently with the system set-up.  
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In the example below, the system date is set to year-month-date (yyyy-mm-dd), that is 
why the Test: box contains 0000-00-00. For your system, it could be 00/00/0000. 

 

A.4.4 Inserting new objects 
It is also possible to add other objects to the report in order to make it look good and be 
easy to use. Open the drop-down list from the tool for inserting new objects to see which 
object types may be inserted. 

For example, to insert a new static text field, click the Static text button (with the capital 
A). The pointer turns into a cross hair, and the text field may be drawn at the location in 
the report where it should be placed. Later, the new object may be manipulated in the 
ways described above.  

To insert a picture, for example a company logo, click the Picture button and draw the 
location for the picture. A dialog box to specify the file name of the picture is opened. 

 
Click Browse to find the picture file, locate the correct folder, select the file to use and 
click OK twice to return to the report. 

Note: In order for such a report to work properly at the site, make sure that the picture file is 
available on the PC where the report is to be used, and that it is located in the specified 
folder. 
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A.4.5 Previewing the report 
To look at the report itself, click the Preview button in the toolbar. Note that if there are 
no data records containing data in the previewed report, the report appears to be empty 
when the preview mode is entered. However, the Insert Row toolbar button may be 
clicked to see what the report looks like. 

A.4.6 Setting the tab order 
When all the fields have been placed as desired, specify the tab order of the report. 
When the report is actually used, this information is used by AMOS M&P to determine 
into which field the cursor should move when the user presses TAB in a given field. 
Press the Tab order button in the toolbar, and PowerBuilder shows the current tab order 
of the report. 

A small, red number appears in the upper right corner of each field. To change a 
number, simply click it and enter the desired value. If the tab order is edited, it is 
necessary to keep track of the numbers. The same number must not be used for two or 
more fields. All values must be higher than 0. If a field has the value 0, it will be 
protected from editing. Save the new tabbing order before exiting PowerBuilder. 

A.5 Adding user defined reports 
AMOS M&P contains a set of standard reports, and it is also possible to include user-
defined reports. A Report Browser is used to select the report to be run. 

A.5.1 The Report Browser 
To access the report browser, select the command Tools/Reports and select the desired 
report folder in the hierarchy on the left. Then double-click the icon for the desired 
report. The report hierarchy may look like this: 

 
In the example above, the item “My own reports” has been added to the hierarchy. The 
command contains the two sub-commands Label reports and Utility reports, and the 
former contains the actual report called Tag stickers. The section below explains how 
this is done. 

First, specify where in the report browser the reports are to be placed with the command 
Tools/Configuration/User Defined Reports/Reports. 
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The screen for user-defined reports opens. It contains a tree structure that is similar to 
the hierarchy functions found, for example, elsewhere in AMOS M&P and in Windows 
Explorer. Click on the plus and minus sign to open or collapse levels, or double-click the 
icons in the tree structure. The Options menu contains the corresponding menu 
commands. 

  
Click the New button on the left-hand side of the secondary toolbar to insert a new 
record The dialog box that opens is used to choose the type of object to create: 

 
Select whether to create a Top-level menu, a Sub-level menu or a Report, and click OK. 
If a menu item is selected, a new folder will appear in the tree structure where the cursor 
was located. To change the name, click in the name field and type the name to use. 

When a Report is inserted in a menu or a sub-level menu, a report icon appears in the 
tree structure. A report is named in the same way as a menu item, by clicking in the 
name and typing in the desired name. The tab cards to the right in the window may be 
used to specify more information about the report. 

Click on the search button to the right of the Library Filename in order to locate 
the folder where the report definition is stored. A library file with the file extension 
.Pbl or .Pbd may be used. If a library file stored in the Report directory (see section 
7.7.4.4) is selected, only the file name is used in the field. If the file is stored 
elsewhere, the full path name of the library file is used. 

• 

• 

• 

If a library file of the type .Pbd is used, the functions in AMOS M&P will not be 
able to list the contents of the file. This means the fields Window Name and 
Datawindow Name must be filled in manually without using the search buttons. 

The Window Name field may be used to name the window to display the report. 
The field is optional. 
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• The Datawindow Name field is for the name of the data window of the report, and 
must be filled in. The search button may be clicked to see a list of available 
windows in the selected library. Select one in order to get access to the last field on 
the tab card. 

• 

• 

• 

• 

• 

• 

• 

It is possible to set up AMOS M&P to make modifications on a report when it is 
run. To do this, use the Modify String field to specify editing and display masks. 
For example, it is possible to specify that the report should use the number mask 
defined in the system. This is done on the Auto-Numbering tab described in section 
7.7.4.2. 

These are the mask names and the corresponding modify strings that may be used: 

Component Number Mask #CompNoFormat# 
Form Number Mask #FormNoFormat” 
Function Number Mask #FuncNoFormat# 
Stock Item Number Mask #PartNoFormat# 
Transport Number Mask #TransDocNoFormat# 
Work Order Number Mask #WONoFormat# 

Please note that the Modify String text is case sensitive. 

When a mask is specified, enter the name of the field in the data window where the 
modification should be applied. The same applies to the property of the field that 
should be changed. For example, a data window called d_test may contain a 
column field called formno. This shows the form number associated to a Purchase 
Order. This makes it logical to display the number with the mask defined in the 
system. Enter the following value in the Modify String field: 

formno.format=#FormNoFormat# 

This will tell AMOS M&P that the field property of the formno field is the mask 
defined as the Form Number Mask. 

It is also common to define an edit mask for query data windows. Such a mask is 
used when the user enters numbers in a field. The property is called 
editmask.mask. If you have a number field and want it to use the Form Number 
Mask, you use the following field value: 

formno.editmask.mask=#<Xxxx/No># 

It is possible to define multiple text strings in the Modify String field by separating 
them with spaces. 

The Query tab card is used to specify an optional filter window. The tab card 
contains the same fields as the Report tab card. 

The Misc. tab card contains the two optional fields User Defined Fields and User 
Defined Table. The field Printer Task may be used to specify a printer task to be 
executed for the report.
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A.5.2 Defining a new Module 
The next step involves defining a module for access control purposes. Give the 
command Tools/Configuration/User defined reports/Modules and click New to create 
a new one. 

 
Enter the report name in the Module column and click the Save icon. Make sure the 
module is selected, and give the command Options/Module Contents. Click New to 
add a new line in the window, place the cursor in the Name field and press Enter. From 
the Select list, select the report to use and click OK. Remember to save the information, 
and close the User Defined Modules window.  

A.5.3 Grant Access to a Report 
Then give the menu command Tools/Configuration/Groups, and select the user group 
to which access to the report is to be granted. 
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Now, select Access Control from the Options menu to enter a screen to specify access 
for the chosen group: 

 

A.5.4 Testing a New Report 
After saving, the selected group now has the necessary access. To test this, give the 
command Tools/Reports, click My own reports and Label reports, and double-click the 
icon for Tag stickers to enter the report preview window. It is possible click Zoom to 
change the view and Print to print the report. 
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B Condition Based Maintenance 

Condition-based Maintenance (CBM) provides a means of integrating various 
equipment measurements and monitoring systems with the maintenance features of 
AMOS M&P. Any or all periodically planned jobs can be activated prior to their normal 
due date, as dictated by the deterioration of the equipment.  In this way, planned and 
condition-based work can be completely integrated. 

In addition, the CBM module also offers an automated mechanism for updating counters 
in the system (like running hours).  These can be discreet values (like temperature or 
pressure), or accumulated ones (e.g. running hours, take-offs, etc.). 

Finally, AMOS M&P supports a CBM dialog from several sources at the same time, 
allowing the system to simultaneously connect the various data capture systems installed 
at the site. 

Note: It is important to remember that the CBM is not an alarm system.  CBM-active values 
should indicate non-critical states as compared with alarm levels; therefore, the 
monitoring system must make a distinction between these two degrees of severity.  The 
principle behind the CBM module is to stop the trend before the alarm level is reached.  
Since the CBM module is designed to provide a signal prior to the alarm level, 
maintenance periods can then be stretched as far as possible without endangering the 
equipment. 

B.1 Overview 
The CBM solution is based on the transfer of special information files between the data 
capture system(s) and AMOS M&P.  These files are called CBM day-files, as they are 
named according to the date when they are written.  

These day-files are written by monitoring and other data capture systems to a directory 
shared with AMOS M&P and contain the id’s of measurement points or values which 
have either reached a pre-defined CBM-active threshold, show an unwanted trend or 
simply have updated counter information.  

The shared CBM directory must be on a file server which is accessible to the various 
systems, and where AMOS M&P has been instructed to search for day-files at pre-
defined intervals.  As day-files are found, they are processed and deleted if the operation 
went without error.  Otherwise, they are renamed to prevent the system from attempting 
to process them again and the user is alerted. 

During day-file processing, each line in the day-file is read by AMOS M&P and 
matched to one or more components in the system.  At this point maintenance work is 
flagged as CBM-active and/or counters are updated with new values.
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B.2 CBM Jobs 
All periodic jobs registered in AMOS M&P have an attribute called CBM Status.  This 
value reflects the current state of the job with regards to condition-based maintenance 
signals received.  In other words, any scheduled job in the system can be activated by an 
external monitoring system via the CBM module interface, causing it to appear in a 
checklist or Work Order printout regardless of its normal schedule. 

In order to view the CBM Status of a job, simply bring up the job (using the 
Options/Job selection from the Component window). 

 
The three CBM status values have the following meanings: 

 
Normal Indicates that this job is not CBM-active, and that it is 

included in the maintenance plan according to its 
schedule. 

Acknowledged This is the value set for CBM-active jobs that have 
been included in a maintenance printout (e.g. checklist 
or Work Order). 

Unacknowledged When a job is first triggered by the CBM module due 
to information in a day-file, then its CBM status is set 
to Unacknowledged.  The job will keep this status until 
it is included out in a maintenance printout, or 
manually reset. 

AMOS M&P signals the user of the general CBM status through the CBM state 
indicator at the bottom right-hand corner of the screen. 

This indicator will be red if there is a single job with the CBM status of 
Unacknowledged.  If there are no unacknowledged jobs, but some have the status 
Acknowledged (e.g. CBM-active, but included in a maintenance printout), then the 
indicator will be yellow.  Otherwise, green shows that there are no CBM jobs which 
need immediate attention, or which are pending.
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B.3 CBM References 
Each line of information in the day-file contains a code identifying the measurement 
point from which this data was read.  In order to match the measurement point code with 
the correct components, jobs and/or counters in AMOS M&P, the system needs some 
sort of “look-up” or reference table. Give the menu command Tools 
/Configuration/CBM References to use this function. 

 
The register contains a list over all known CBM measurement points along with the 
components to which they are attached.   

 
Each entry in the reference table has the following fields: 

ID Two-character code identifying which data capture system 
this entry applies to, as described at the start of this chapter. 

CBM Code Here comes the id of the measurement point in the data 
capture system. 

Inst/Dept Contains the installation and department number of the 
component that this measurement point is linked to. 

Component This is for the number of the component whose counter is to 
be updated, or whose CBM work is to be activated (or both). 

Type This field tells whether this entry is of the counter update or 
job activation type. 

Job Code If this reference is for activating CBM work, then this field 
will contain the code of the job attached to the specified 
component that is to be triggered. 

Counter For counter update references, this field will indicate which 
counter to update. 

This table is a global one, applying for the entire company, and specifying references to 
components in any or all installations and departments. 
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Note: There may several references for the same CBM code, allowing a single signal from the 
data capture or monitoring system to activate any number of jobs, or update any number 
of counters for different (or the same) components.  Similarly, the same component may 
appear in several references, again facilitating both job activation and counter updates 
for the same piece of equipment. 

B.4 Day-files 
As mentioned above, day-files are used to transfer CBM information between data 
capture and equipment monitoring systems and AMOS M&P. As was also mentioned 
above, day-file are named after the date when written: 

19970428.%NC 
The filename is a date is in the form YYYYMMDD with an extension made up of a percent 
sign (%) followed by a two-character code called the CBM id.  This CBM id tells the 
system which data capture system created the day-file.   

CBM id’s are issued by Xantic and are unique for every supplier of data capture and 
equipment monitoring systems.  Some examples are NC for NorControl and SP for SPM 
Instrument International.  Since day-files created by systems from different suppliers 
have dissimilar extensions, then these files can co-exist in the same CBM directory 
without conflicting with each other. 

Each day-file contains the CBM information accumulated for a single day from a single 
monitoring system.  When this system needs to register additional information for the 
same date, it must append this data to the same day-file.   CBM day-files are in ASCII 
text format, each line ending with a carriage return character.  These lines may be in one 
of two formats: 

 
<code> Containing only the measurement point code, this 

type of day-file entry indicates that one or more jobs 
needs to be flagged as CBM active. 

<value>,<code> Indicates a change to one or more counters tied to 
the specified <code>. 

 

Where the <value> field shown above is a numeric value followed by a Counter code 
(like “H” for “Hours”). 

Therefore, the following examples are all valid CBM day-file entries: 

MAIN_EXH_VALVE • 

• 

• 

• 

• 

TEMP_POINT_3 

+10.5,DIESEL_GEN_1 

=53.25,MAIN_COMPRESSOR 

=1054H,PACKING_MACH_1 

The first two lines above would be signals from the monitoring system that related CBM 
jobs needed to be carried out.  The third line specifies that 10.5 be added to the counter 
registered for the measurement code DIESEL_GEN_1.  The next line sets the counter 
for MAIN_COMPRESSOR to 53.25 (using the default counter which is Hours).  
Finally, the last line also sets the total value of the Hours counter, this time updating the 
PACKING_MACH_1 counter to 1,054 hours. 
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